Pay via Paypal

  • Author
    Posts
  • #1571295

    I have a problem when I try to buy more space on the wordpress shop. When I choose to pay via paypal I see a blank screen with no options.
    Is it forbidden to use paypal from Italy?
    Please let me know, thank you.

    The blog I need help with is massimilianobarison.wordpress.com.

    #1571406

    timethief
    Member

    Are you logged in under the exact same username account that registered the blog in question? If so your ought to be able to go to > Dashboard > Store > My Upgrades and purchase your space upgrade there. http://en.support.wordpress.com/space-upgrade/

    #1571418

    kraftbj
    Staff

    Hi,

    Can you try again? There may have been an issue with PayPal at that time—you should be all set from Italy.

    If it still has an issue, try visiting PayPal.com directly and logging out, if you’re logged in.

    Please let me know if you continue to have issues.

    Cheers!

    #1571480

    vadimosya
    Member

    Hello, I have an issue paying for my $99 premium upgrade via PayPal.
    1) Selected the Upgrade option to link my domain to wordpress.com blog
    2) Select United States from the list of locations and entered correct zip
    3) Click Pay with PAyPal
    4) Login to PayPal on the following page
    5) Got an error:
    “We’re sorry, but we can’t send your payment right now”
    Snapshot:
    http://cl.ly/image/1c121G0U2L2K

    6) Logged in to PayPal separately and double checked that ZIP is correct
    7) Tried to Pay with different PayPal account that belongs to my business. Same story.
    Help.

    #1571482

    kraftbj
    Staff

    Hi,

    My understanding is that may be an issue from your PayPal account, possibly needing it to be verified (see https://www.paypal-community.com/t5/Sending-and-receiving-money/We-re-sorry-but-we-can-t-send-your-payment-right-now-HELP/td-p/714319?profile.language=en-gb ).

    You can contact PayPal for more information via https://www.paypal.com/webapps/helpcenter/helphub/home/

    I’m sorry for the difficulty and I hope it is something that can be resolved with PayPal soon.

    #1571485

    vadimosya
    Member

    Hi kraftbj,

    I don’t think it’s the case in my situation.

    Both of the paypal accounts I tried to pay with are long term standing (6 and 10 years) US based personal and business VERIFIED accounts.

    Here’s a snapshot from my business account: http://cl.ly/image/403w3H1I3o40

    Here’s a snapshot from my personal account:
    http://cl.ly/image/0t1047011O20

    Again, I logged in separately and double checked that the ZIP code I enter on my wordpress side matches the account settings on both accounts.

    Still in all I couldn’t pay for your service with either one of my VERIFIED PayPal accounts

    #1571486

    kraftbj
    Staff

    Thanks, Vadim.

    Has PayPal responded back to you yet?

    The issue isn’t on our end, as far as we can tell, since it is still within PayPal’s side of the transaction.

    As an alternative, I can have one of the store folks send a direct payment request to your PayPal account, but I’d rather resolve the root of the matter so this isn’t an annual problem!

    Cheers!

    #1571487

    vadimosya
    Member

    A call to PayPal resolved the issue. However, all they asked me to do is to reset my browser’s history which I did many times prior. PayPal rep also did an “account reset” on his end…. and … tah-dah, it went through.

    I am glad you guys added a bitcoin option. I hope eBay will never buy them.

    #1571488

    vadimosya
    Member

    Oh PayPal also mentioned not to use Google Chrome as they “seem to have most of their problems occurred on this browser”. I cant believe one can beat IE though, but well…

    #1571489

    kraftbj
    Staff

    Not to use Google Chrome? Interesting; thanks for passing that long.

    While your account was verified, sounds like something else on their end was preventing it. In any case, glad it is resolved!

    If you need anything else, please let me know. Have a good weekend.

    #1571499

    vw2024
    Member

    I’m having the same problem right now.
    I tried with both Firefox Aurora and Chromium – same result. That was on a freshly installed system, by the way.
    I’m going to delete cookies&cache and try again.

    This is a risky issue for me, as I only have 1 day left to make the payment work…additional help from WordPress Staff would be appreciated!
    :-)

    #1571501

    raincoaster
    Member

    a freshly installed system

    And what is the URL of that system?

    #1571502

    vw2024
    Member

    No URL – “a freshly installed system” = “I had installed Linux Ubuntu on this computer a few days ago”.
    That was meant to say there were no previous cookies of Paypal.com or WordPress.com on this computer.

    Anyway I just tried manually clearing both cookies and cache from both Firefox Aurora and Chromium, and that didn’t work:
    the “Paypal” tab is still empty.

    I’m now going to try a different workaround, which would be switching to English language in the WordPress.com interface. Who knows.

    #1571503

    raincoaster
    Member

    What is the URL of the blog? If you don’t give it to us, we’re going to assume you are in the wrong forum and are trying to buy an upgrade for a blog that does not exist.

    #1571504

    vw2024
    Member

    I can pay with Paypal again now.

    Apparently this issue may be worked around by switching to English language, which I did in two places: WordPress.com interface and Blog Language. Not sure which of the two, if any, actually made the trick.

    I may able to provide more details later.

    #1571505

    vw2024
    Member

    Well, I may be in the wrong forum, as I wasn’t trying to buy more space, just renewing Domaing Mapping.

    I bothered to comment here anyway because my situation was similar to the one described in the first post, that is a blank PayPal tab when trying to pay from Italy.

    My blog is opensourceobscure.wordpress.com.
    Thanks!

    #1571506

    vw2024
    Member

    As a last post,
    I confirm that the PayPal is currently only visibile for me if I choose “English” as the “Interface Language” in https://opensourceobscure.wordpress.com/wp-admin/users.php?page=grofiles-user-settings

    If I set “Italian”, the PayPal payment tab becomes blank/empty.

    I didn’t try any other language apart Italian and English.

    By setting English language, I could successfully pay for the Domain Mapping.

    #1571509

    kraftbj
    Staff

    Thanks for providing all of the information. In testing, I confirmed something is erring when using Italian and attempting to checkout with PayPal. I’ve let our Store devs know so we can get it fixed ASAP.

    Thanks again!

The topic ‘Pay via Paypal’ is closed to new replies.