People are shown as clicking on links that aren’t there …

  • Author
  • #342292


    On my Blog Stats page, under ‘Links’ there are four links showing as having been clicked on that aren’t on my blog … at least I very much HOPE they’re not:

    What is happening, and what can I do about it?

    I suspect the problem’s arisen because I wrote a post about tits – cute, feathery, long-tailed ones …

    The blog I need help with is



    “Links” are links from other blogs TO your blog. “Clicks” is clicks on links on your blog going away.

    Without a link to your actual blog, we can’t really help you. Please either give us that link, starting with http, or change the link on your name to your blog, not your website.



    Sorry … I’ve changed the link to the blog … I thought I had done it, but I probably forgot to hit ‘Update’.

    They are in fact listed under ‘Clicks’ rather than ‘Links’. I can’t see anything on my page to account for it. They didn’t reappear yesterday or – as yet – today … they seemed to appear specifically in connection with the ‘Portrait of a Bully’ post.

    Thanks for looking at this for me.



    These were most likely clicks on links in the “Possibly related posts” block on the bird post.



    Thanks for the thought, tellyworth, but it’s not that. I have that feature turned off – at least I have if it’s the one under “Appearance” and “Extras” that says “Hide related links ….” The box is ticked.




    I’ve been getting exactly the same thing on my blog ( It’s been happening for several weeks now – though not regularly. I also have the ‘Hide related links’ feature ticked and the links that people appear to click on are definately not part of my blog and are usually totally unrelated.

    I’ve just put it down to one of life’s litte wordpress mysteries!



    Well, I’d be happy to do that if (a) I knew that my regular visitors weren’t actually FINDING those links on the site and (b) they weren’t the sort of links that they are.

    I have nothing against them as blogs … whatever turns you on and all that … but in view of the nature of MY blog, it’s a bit ‘off’ really.

    They haven’t reappeared – nor anything like them … but I would like to be able to prevent it from happening again if at all possible.

    I mean, I might want to write about great tits next time …



    I hadn’t had this happen in the past couple of weeks so I thought whatever had caused it had ‘gone away’. However, I’ve just looked at my stats and another click has appeared that goes to an unrelated biblical site. At least that’s a bit more respectable than the clicks you’re getting! Ha-ha I think you’re going to have to be careful in your choice of birds! Good luck.

    I’d also love to know how this is happening.


    Go to appearance > extras and disable the “possibly related posts by selecting “Hide related links on this blog, which means this blog won’t show up on other blogs or get traffic that way” and then click “save changes.”

    That is all I can suggest to keep it from happening.



    Thank you for the suggestion … but it IS ticked. That’s what makes it so odd …


    Odd indeed. All I can do then is shrug.

The topic ‘People are shown as clicking on links that aren’t there …’ is closed to new replies.