Permalinks with Pages (not Posts) Not Working

  • Author
  • #303429


    I’m a web developer using WordPress for the first time to add a blog to a client’s site. Despite the supposed ease of use of WordPress, I am running into a lot of problems. (I’m assuming this is because I’m using WordPress as more of a CMS than a blogging tool–it looks easy enough if you just use the pre-packaged themes and what not.)

    That said, I have spent hours reading the documentation, trying to figure this out on my own, and I cannot resolve this issue–I think maybe I am missing some basic component or understanding of how permalinks and my folder structure should work. I’m going to be very detailed in hopes that someone will not accuse me of not reading the documentation and so that someone might better be able to diagnose what I’m doing wrong.

    – I have apache set up as a localhost for testing. I have mod_rewrite enabled and have set up my httpd.conf file to allow the rewrites.
    – My root folder is http://localhost/wordpress . There is an .htaccess file in that root folder, and it reads as follows:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    # END WordPress

    – I have created my own theme (kathyelliot) which is now a folder in the themes folder.
    – Seeing that this site has 6 pages, there is a PHP template for each page in that themes/kathyelliot folder (blog.php, contact.php, etc.)
    – I have created a page for each page in WordPress and linked the page to the proper template (ex. the page Blog is attached to the blog.php template, the Contact page is attached to the contact.php template, etc.)
    – I have gone to Settings > Permalinks in WP and changed it from default to “Day and name”. Now the links to my pages come up as you would expect (ex. http://localhost/wordpress/index.php is my home page, http://localhost/wordpress/blog/ is the link for my Blog page)

    However, it’s almost like WordPress is actually looking for a /Blog/ directory. Am I understanding the whole permalink thing wrong? Should http://localhost/wordpress/blog/ not be looking for my blog page in WordPress, which is attached to my blog.php template in my kathyelliot theme folder where all my php files are for that theme?

    I have a feeling that I’m simply not understanding the hierarchy correctly. I will PayPal $ to anyone who can help me make this work–I’m not kidding.




    Moderator Emeritus

The topic ‘Permalinks with Pages (not Posts) Not Working’ is closed to new replies.