Photo not showing?

  • Author
  • #884298


    Hello. I apologize if this has been posted elsewhere. I saw several posts regarding photo/uploading issues, but nothing like this.

    Please observe this post:

    Does the photo load to you? I have checked it in Firefox and IE (Firefox latest, IE old) and it does not load. I have deleted the photo, resized the photo, renamed the photo, deleted the post, scanned the photo again, all to no avail. I have never come across this issue whilst using WordPress before and I am at a loss as to what to do to get this photo to load.

    Does anyone have any suggestions, or is there anyone out there that has also experienced this that can offer some insight? I feel as if I have exhausted all troubleshooting avenues available.

    I am using the latest version of Firefox, Flash was recently updated, and I connect through the Internet using DSL. This does not seem to be an issue with uploading the photo, but rather, getting the photo to show. If you check the entirety of my blog ( you will notice that (hopefully) none of my other posts have this issue.

    Thanks in advance…

    The blog I need help with is



    I am having the same problem – instead of the photo showing, I have a black box.



    Try deleting it from your media library and uploading it again, sometimes that help me when I have that problem (I don’t see it either, FYI, and I’m on Safari).



    Gretak – I tried deleting the photos and then uploading them again – same problem. I tried just doing one, because I thought maybe I did too many at one time. Still had the same problem. I see the photo in a brief flash. and then a black box. When I look at my blog after I publish a post with a black box, I can see the photo.

    I uploaded photos 3 days ago and did not have this problem.


    Just a thought – are you using the ‘Standard’ post format or something else?

    The curious thing is that looking at the post in Firefox via the browser, I can’t see the image, but looking at the ‘Media’ part of ‘Page Info’ (via Tools in Firefox) there’s this:


    Type: JPEG image

    Size: Unknown (not cached)
    Dimensions: 0px x 0px (scaled to 0px x 16px)
    Associated text: fckd0026a

    The thing is, if you’ve rescaled it, it should show the dimensions of the rescale not zeros. And the Size should show the resolution of the file.

    And I just tried looking at the error console. I’m NOT experienced with that at all, so this is just a guess, but it said “image corrupt or truncated” so I did a search on Google for the phrase plus and came up with this thread:

    it addresses a slightly different problem (an image for a background not a post, but still an image file. And it refers to an earlier version of Firefox, but I think the solution might apply to this.) Read the comments to it and decide for yourself if there’s something workable in it.


    Sorry – the Location in my above comment shouldn’t have become a link. Whoops!



    I resigned myself to black boxes of photos while creating a post, and then I clicked on that ABC icon (Proofread Writing) and when I went back to my post, the photo images showed. A mystery …

    I’m leery of trying it again, but will be courageous and see what happens next time.

    absurdoldbird – thank you.


    @wibbus – I’m glad your problem has sorted itself out.

    @ryansandford – I just clicked on the little grey vertical line that should be your image and got this:

    At a guess, I’d say that you – or the image editor – have somehow changed the size of the image to zero x 16 pixels and that all that’s left of your photo is that little grey vertical line (it’s in your post, below your text and to the left side).

    Look at this page and scroll down to the Advanced settings to see where and how to adjust the image size and resolution and see if that helps:

    also have a look at this to understand the link options, because it’s opening fine in another window but not in your blog, so you may want to adjust one of these, as well:



    Please observe this post:

    May I please add something? Please read this >


    @wibbus – where are you seeing a the ‘ABC icon’? The ABC icon in the editor is for a strikethrough. Are you using Word or similar? If so, you need to take note of this:

    Ah, hang on – are you using the grammar add on via Firefox? This:

    If so – it might be a problem with an add on or plugin (I mean a Firefox plugin, not a plugin here – blogs can’t use plugins). So try disabling all your add ons in Firefox. You can do that via Tools (on your Browser toolbar) – Add Ons – and then just click disable by the side of them. If things improve, then you’ll know it’s an add on and you can enable them one by one to see which is wrong. The culprit may need updating or may just not work with something else you’ve got on your computer/in your browser.



    I looked just now and see there are two ABC icons – the one third from the left is for “Strikethrough” and the one third from the right is for “Proofread Writing” (I think of it as sort of a spell check). I clicked on the “Proofread Writing” icon and then when I went back to my posting, I could see the photos.

    I am using FIrefox 8.0.

    If I have trouble again, I’ll try disabling my add-ons. Thank you, absurdoldbird.



    I am having a similar problem with the Featured Image on my Home page––just a gray box. If you click on the title that links to the full post, everything displays perfectly. Visibility is set to Public and Stick to Front Page. It’s only the Home Page image display that some times comes up like this.

    I checked the file size, deleted the file and reloaded, Updated every time and even clicked on the ABC button, which is only a spell check. Same results.

    I don’t understand how the same image appears properly in the full post, but not the Home Page–and only does that sometimes. I can’t find anything I am doing differently. It’s very frustrating to Preview it, it works perfectly, and then Publish it, getting a gray rectangle on the Home Page. Any suggestions?



    I realized that I was having the same problem with some photos on Facebook so wondered if Firefox was the problem. Searched for problem with Firefox 8.0 and saw that some users solved the problem by uninstalling and then installing the latest Flash Player. I had the latest Flash Player (or thought I did), but apparently it wasn’t installed correctly. So I did the uninstall/install procedure, and now my photos are showing properly in WordPress when I insert one into a post I’m creating, and also all the photos on FB are showing.



    May I please add something? Please read this >

    @timethief Fascinating and entirely unhelpful, thank you!

    @absurdoldbird, I appreciate your recommendations but the item has not been resized. The image itself is of the size I scanned it to be, and the HTML shows it resized to fit the layout of the page. It is exactly the same as every other post in my blog, so there should not be this issue.

    I have tried deleting it and uploading it again, to no avail.

    I cannot understand why this post has decided to do this, furthermore, I can’t understand why there’s not an easy fix.

    I will try uploading it again later. I can’t be arsed to go through and try and struggle with this again at the moment. Thanks for the suggestions.



    Edit the post and switch the editor to HTML. You’ll see this:
    src="<strong>?w=500&h=337</strong>" alt="" [etc]
    Remove the part I marked as bold.

    See here:



    Sorry, I mad a mistake above – remove this part:


    i too have tried what seems to be everything and i can’t get my photos to display
    any ideas would be appreciated.



    ryansford – have you uninstalled/installed Flash Player? That worked for me.



    justpi – Thanks for the suggestion but every post has that in it so it does not make sense that this post alone would be malfunctioning in the way it is.

    wibbus – I have not tried that. I do not think that could possibly be the problem, though, because the photo is clearly there. It has uploaded, you can click on it to see it, it just won’t show in the post, so it shouldn’t have anything to do with Flash Player.

    I am at a loss of what to do.



    Right. But if I were you I would be more interested in what works than in what seems to make sense. As absurdoldbird suspected, your file is corrupt, the browser can’t display it if the URL is the way it is, and my suggestion would make it show up. Anyway, here’s a corrected copy of your image:
    And here’s your image downsized to the right width for the theme you’re using (500px):
    You can copy them and use them; second one will give you better quality on the post, because images downsized by WP lose some color and sharpness.

The topic ‘Photo not showing?’ is closed to new replies.