Need help? Check out our Support site, then

Pictures not appearing in emails of blog posts

  1. Hi there
    Almost every time I post a new entry to my blog, the pictures are not included in the email of the post that gets sent out automatically. I have tried various different ways of posting, including having the pictures embedded in the blog post before and after the text, and I always have a featured image set. It appears I am not alone either, as a number of blogs I follow by email seem to have the same problems.

    I really someone can explain what affects this.
    Many thanks!

    The blog I need help with is

  2. This is the RSS Feed for post on your blog
    Note the image files are in that feed.

    Some email clients display images and some do not. Some email clients have the option for the account holder to suppress image display and some do not. Which email client are you using?

  3. Hi timethief, I'm using Mail on Mac but I'm pretty certain in my case the issue is not down to the email client, although you are right that that is a valid problem for some. Once or maybe twice my blog posts have had their images embedded when they've landed in my inbox, but most occasions they have not, and the same goes for my wife's blog posts too. Neither of us can determine what it is that will get our images to reliably appear in our emails... Very frustrating!

  4. I don't have a solution for you. In fact I set my blog feed to summary so excerpts are emailed to subscribers and that compels readers to visit my blog to read full posts, so an actual page view stat is created.

    I tagged this thread for Staff assistance. Please subscribe to it so you are notified when they respond.

  5. Thanks, I'm subscribed.

    I actually just wrote a new blog post and changed one parameter to see if that did the trick. I set the alignment of each image to 'none' – thinking that maybe this was the reason they once worked, but as usual when it landed in my inbox there were no images embedded. So I at least now know it's not the image alignment...

  6. Hi tombland1,

    As timethief already noted, your images appear to be showing up in the feed, and everything appears correct in the blog itself. It may indeed be an issue with the email client, but to rule it out, I've added myself as a follower to your blog. I'll watch for your next post, so I can see if the images are coming through on my end.

  7. Hi jackiedana, thanks for your response and for looking into this. I posted to my blog today and as usual the email I received did not include the image. I'm assuming you experienced the same. I'd really appreciate your insight here as to what determines this – is it the method that the image is embedded into the blog, the resolution, the alignment, the file size? I could go on. So many possibilities...

  8. Hi again,

    I did receive the notification, and there was no image in it.

    I have a few more questions for you so I can troubleshoot this further.

    When you initially published the post, the image was part of the post, correct (confirming that you didn't add the image after you published it)?

    Did you draft the post in the Dashboard Visual/Text Editor or from the W menu (the quick post option)?

    Did you post from a computer or a mobile device?

    And which browser/browser version are you using?

  9. Yes the image was part of the post, but on this occasion I did forget to set a 'featured image' – although I'm not sure this has any bearing on the issue as my previous post did have a 'featured image' yet that one also showed no image when it arrived by email.

    I wrote the post via Dashboard / Posts / Add New

    All of my posts are done from a computer only – an Apple iMac running OSX 10.8.3 using Safari 6.0.4

    Thanks for your assistance...

  10. In your blog's Dashboard, under Settings > Reading try changing this setting:

    "For each article in a feed, show" to Full Text. From my tests, that should resolve the issue.

    Note also that the email will display an image in your post itself rather than your featured image.

  11. Great, I've made that change so fingers crossed our next post looks as it should in everyone's inbox. Thanks Jackie...

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.