Pictures show up when editing but not on blog.

  • Author
  • #732307


    When editing posts, I can see images that I’ve uploaded. But when I publish the post I can see only the text but not the photos. I’ve read some forum responses that suggest the pictures may be too large, but I can’t find any guidelines for how small I need to make them. Any suggestions?

    The blog I need help with is


    We need a link to a post where this is happening please.


    There should be 5 pictures inline with the text. They show up on the editing screen but not when I view the posting.


    Monotone and Duotone in general only show one image per post. That is the way they are designed. Basically they are designed for photography only, or perhaps a photograph and some descriptive text, but they are not designed to operate like a normal blog.

    You can have multiple image in a post, but they have to be inserted as a gallery, which groups them all together.

    See Panos’ review of Monotone and Duotone here.



    Thanks. That makes sense. I am now experimenting with some other themes!


    My problem at is that 4 out of the 8 home-page pictures are gone…But they are still in the message as featured image. I tried reloading, but it doesn’t work. Can somebody help me?


    You need to upload and use images presized to the right pixel dimensions. See here:


    I’m experiencing the exact same issue. A while back i posted some pics, and two of them vanished, with their captions sticking to the pic above. I’ll include a link to this post. Today, I’m trying to publish a post with 15 pictures from my recent trip to Germany. Looks fine in ‘edit’ but as soon as I publish or preview all but 2 of the pictures disappear. Again, the captions remain, and are stuck to the 2 remaining pcitures. So i end up with 2 pictures with 7 or 8 captions jammed together. Earlier today i posted a text post just fine. Any help would be greatly, greatly appreciated. I love uploading pics, and it’s basically impossible now.

    An Afternoon Stroll in Cologne

    Between the 2nd and 3rd pic i lost one, hence the nonsensical caption on pic #2, same thing between pics 9 and 10….. I use the pilcrow theme, and i’m pretty sure it’s not a theme thing, as in the past i haven’t had this problem at all.

    Thank you so much in adavance.


    Your issue has nothing to do with the previous two complaints (which are already two unrelated issues: mguinther is using a photoblogging theme that is designed to display only one image per post, vanessadebruyne has a problem with featured images because of a recent change WP made).

    Captioned images are very sensitive. There are two things you need to be careful with: a) After inserting a captioned image, make sure you move the cursor outside the caption area before doing anything else (that’s what caused the problem you’re having). b) Never highlight the caption to try change its formatting via any of the tools of the editor: image captions aren’t directly editable.
    In both cases the image+caption code gets messed up, the results will be erratic, and the only thing you can do is delete the images (by clicking on the image then clicking the delete button) and reinsert them.


    Thanks a lot for your reply… I really appreciate it.

    I tried again this morning, being very delicate with the photos/captions as you suggested. Unfortunately, the symptom persisted. I already have the pictures uploaded to the “gallery” inside the photo uploader, and tried reinserting them. I guess the next step is to delete everything and start over from scratch and re-upload all the pictures while being careful with the captions. I’ll let you know if it works.

    Thanks so much.



    I am also experiencing the same problem for the Structure Theme. The feature image for my new post isn’t showing. Can someone help? Thanks!


    ok, i got mine figured out. It turns out if i hit enter several times between each photo, and was very carefull about not editing the caption directly or having the cursor left in the caption when i uploaded the next photo (As suggested by panaghiotisadam) everything worked fine. For whatever reason, putting space inbetween the photos (which i could then delete later no problem) was really important. If the photos back to back it didn’t work… Live and learn. Thanks everyone.


The topic ‘Pictures show up when editing but not on blog.’ is closed to new replies.