Pinterest button doesn't seem to work

  • Author
  • #1142118

    Pinterest button doesn’t seem to work, I’m re-directed to personal Pinterest page instead of pop-up window to add a post.

    Don’t know whether it is a Pinterest problem or WordPress problem.

    Anyone else has this problem?

    Thank you, Berthold Bouman

    The blog I need help with is



    Hello there,
    You can use any widget that has pure HTML on your free hosted blog but you cannot use any widgets that contain restricted codes like iframes or JavaScript widgets. In the case of Pinterest, you cannot use the Pin-it Javascript code on a blog.

    But you can put the code for the Pinterest follow button in a text widget.

    1. Go to this site, choose which one of the red Follow Me images you want, and copy the code for it.

    2. Then, go to your widgets > Appearance > Widgets and select a text widget.

    3. Paste the Pinterest follow button code into the text widget, “save” the widget, “close” the widget and place it where you want it to display in your sidebar.

    4. Please see here for enabling sharing buttons including Pinterest on your blog.

    5. Since November 15th Pinterest has been rolling out business accounts and requiring the verification for those accounts.

    We now have two sets of terms—one for people and one for businesses.

    Pinterest does not require that you have a business account. You can have an ordinary account for “people”. From:

    See here


    The Pinterest button has always worked, I use it the same way thousands of others use it. Only today it doesn’t work.

    So I like to keep using it as I always did. Why has it always worked and not today?

    I just use the sharing buttons from the Settings, Sharing page. Always worked. Didn’t change anything since I dragged that button 7 months ago to the Enabled Services like you describe in point 4.

    Maybe you should test it before you come up with all kinds of things and tell me I’m not using it in the correct way. Do you want access to my blog? Then you can see for yourself! Nothing wrong with me.

    Test it first please! When I click on the button my blog page disappears, my Pinterest page with my previous posts shows, while the address still says “”

    That’s not normal and certainly not my fault! I would like to see a professional opinion on this please!


    Posted a screendump here:

    See for yourself,

    Thanks you!


    And the same happens when I use the Pinterest button on this one:


    And updated that page with another screendump, different blog, same result, blog page disappears after clicking on the Pinterest button, Pinterest page shows while blog address is still in the address bar on top. Is not normal.

    Any ideas? Might be a problem with Pinterest API . I didn’t hear you say anything about that?

    Thank you!


    So, I’ll explain again. I do NOT use widgets of any kind, I use the social media buttons as WordPress offers them, go to Settings, and then Sharing.

    I made a screendump and you can see the Pinterest button is enabled. It has been like that for 7 months and never caused any problems.

    See screendump of my settings:

    Nothing wrong with that or is it? So, again, it doesn’t work. Maybe you can ask someone to take a look at it?



    Now timethief, I know you hate my guts, ignore me if you want, but I really would like a staff member to take a look at this.

    This concerns all blogs that use the standard WordPress Pinterest button.

    Can you please ask a staff member to take a look at this and inform me about what is going on? It would be nice if you would answer me instead of the eternal silence?

    Thank you.



    This thread was already tagged for Staff assistance with “modlook” in the sidebar tags when I posted into it. Please be patient while waiting for Staff to help you.



    P.S. I noticed this on the Pinterest help center known issues but I’m not aware if this is the same issue or not


    Sorry, but you could have said that straight away. Now can we smoke the peace pipe, because I really do not want to upset anyone around here, sorry but it seems I have to say things 5x to provoke a reaction.

    Sorry if I offended you in any way, but I had the silly idea you didn’t take me serious!

    And regarding your last comment, no, I don’t think that has anything to do with it. That is about secret boards people have at Pinterest, for private viewing only, and it seems the secret boards can’t be found. No wonder! Secret!

    So the problem is still the same.

    Berthold Bouman



    Hi there Berthold,

    Here is how the Pinterest button should be working (let me know where things are NOT working for you):

    *See the Pinterest button on someone’s blog
    *Click the button
    *Select the image you’d like to Pin
    *Get the pop-up window specifying which of your boards you would like to pin this to, plus any text you’d like to include (you may have to log in first at this step)
    *Click “Pin it!”
    *You return to the original blog where you began the pinning process.

    Just let me know where that is running afoul for you. You should see the blog’s URL in the address bar, since you don’t go to Pinterest – you get a pop-up window that is a bookmarklet that posts to your Pinterest page for you, however.

    Does that make sense?


    Yep that works, but that is completely new for me (and others too I presume), it didn’t work like that yesterday.

    Normally you would straight away see the second pop-up window you mentioned and not a page with photos first. As my posts today contained picture galleries, all those pictures were shown on that first page, and it didn’t immediately become apparent what the purpose of that page was. It does now after your explanation :-)

    So it will stay like that?

    Just out of curiosity, who changed the m.o, WordPress or Pinterest?

    Thank you for engineering my happiness back to the usual level again, also thank you timethief,

    Berthold Bouman



    Hi there – we’re working to improve the Pinterest pinning feature so that it works better for our users.

    Just let us know if you have any further issues!


    Hi on my website or, not sure which way you needed it, I have the pin it button at the bottom of each post. When I click the button it brings up the popup window like it is supposed to but it randomly selects the image to pin. I can not pick which image I would like to pin. Example on my post today

    I click the botton and it brings up the third image only, which is not the image I would like to pin.
    Can you please advise me on this?
    Thanks, Nancy


    Would like to add something. I tried the above blog and the Pinterest button, and the result is quite different from what I get to see. Does the Pinterest screen you get depend on the theme you use?

    With the above blog I get a small popup (like I used to have before I posted this question/problem). However, on my blog, the whole page of my blog is used to display the photo that is supposed to accompany the link on Pinterest.

    Unfortunately it displays ALL photos of the home page of my blog, not just the photo of the post. Difficult to explain, but please try before replying.

    Please click the Pinterest button on my blog:

    and on the above one:

    And note the difference. Why is that?

    I tagged this topic modlook again.

    Thank you, Berthold Bouman



    Berthold – it looks like the pinning behaviour is indeed different on those two sites, due to the type of button in use on each.

    This site is displaying small sharing buttons, which show when “Icon Only” is selected under Settings > Sharing. The other site is using the “Official buttons” option. I will bring this to our developers’ attention so they’re aware the two options are providing different sharing options. Thanks for the heads-up.



    Nancy – if you take a look at my reply to Berthold, you’ll see that the pinning options differ depending on which button style you choose. If you’d like more image options, you could choose “Icon only” from the drop-down menu button style choices under Settings > Sharing.

    In the meantime, I’m letting our developers know about the issue so they can have a look.

The topic ‘Pinterest button doesn't seem to work’ is closed to new replies.