Need help? Check out our Support site, then

Please help! Blog showing properly to viewers but not me!!!

  1. Hi

    My blog seems to be displaying properly to other users but not to me...i have been blogging since Jan and it has all been fine since a few days ago....the post background is transparent and all the tabs like dashboard, statistics etc has gone to the very bottom of the page....i thought it had disappeared...even the calendar and archives that i had set to the right of the page has gone to the bottom of the blog...i have tried forced refreshing, clearing cache and cookies but nothing seems to be working

    Please please please help!

    The blog I need help with is

  2. Hi there. Have you checked whether you have the same issue if you use a different browser? You can download and install a different browser to check here: While you're at it, make sure you have the latest version of your regular browser.

    The widgets appearing at the bottom could also have to do with screensize. Your theme automatically moves the sidebar widgets to the bottom on narrower screens, so if you have a small screen or if your browser window is not full-screen that could be the reason.

    If none of that helps, it would help if you could provide a screenshot of what you see. Upload the screenshot to your media library and post the link here. You can also use a service like to post your screenshot. Also let us know exactly which browser and version you are using.

  3. i checked with different browsers and all of them showed the same result until i added an https to the url and then it displayed like it normally does...i have no idea what happened...when i normally log into my blog it just shows up like it normally does and then by itself a few days ago it showed up with the probs above...but once i add in the https it looks fine

    I have no idea what's happening....does the blog look normal to you when you look at it? or does it look messed up?


    The link above is the blog link....when i click on it opens a very very messed p version of the blog...when i add an https to the url it displays normally. what does it look like when you click on the link

  5. Your blog looks fine to me. Everything is where I'd expect it to be and I can load it fine in http and https.

    Please post a screenshot of what you see and provide that browser info, then I'll tag this for staff to follow up in case they have an idea what could be causing this.

  6. I am having a similar issue on my blog
    in Chrome and Firefox
    the header images does not show
    the page layout is haphazard
    It has been like this for several days
    Im using Windows 8.1
    The stats page continues to work
    any suggestion??

  7. try adding an https to your url instead of an http

  8. u look like you have the same problem as mine...ur url looks different with an http and with an https

    Try the above link and see if its displaying properly now

  9. @ynotoman
    Thanks for that screenshot. It appears like your page is loading in outline view for some reason. Try resetting your modem/router in case this is a connection issue and try using an https connection as @zuleika2014 suggested. Let us know the result.

    Also let us know exactly what browser and version you're using (which versions of Firefox and Chrome):

  10. Thanks for providing that. I've tagged this for staff to follow up. Please be patient while waiting for their response.

  11. m guessing ynotoman and i have this problem because its something to do with blocking probably in the region we are in

  12. thank @kokkieh.....I shall wait patiently....the blogs working and displaying properly when i use https now so m partially at peace :)...cheers

  13. hi again Kokkieh and Zeleika
    I checked and Im using the latest Chrome and Firefox with all plugins uptodate
    I reset the router and also checked using my mobile for connection - still the same appearance in all cases.
    Hower you are right - https works!

  14. Im in Oman - using OmanTel landline (with wireless) -
    I have checked using the pre-paid mobile service by OmanTel using my mobile connected by cable.
    Both the above are the same as the screen shot.
    However - using another mobile post-paid by Nawras service also connected by cable - and the page loads correctly
    So I guess its an OmanTel issue with WordPress
    so thanks for your input Kokkieh and Zeleika

  15. lol its definitely a region problem...all my friends here are having the same problem with their blogs.....

  16. maybe I'm in Oman too so are the friends i checked with...cheers!

  17. Thanks for that extra information. I'm leaving the staff tag in case there's something they can do, but I suggest you contact your service providers as well to see if there's something they can do.

  18. Hi there,

    Thanks for bringing this to our attention! I'm sorry to hear that you're having such problems viewing your site, though I'm glad that you were able to find a work around.

    I am not sure if there is anything which we will be able to do, however I have made the folks who are responsible for our network systems aware of this, so if there IS anything which can be done, we will get on it.

    Thanks again!

  19. charlottehbest

    ynotoman thanks for posting - I've been having this problem for days, and didn't even consider the fact that it might be due to my location (and therefore internet provider!) - I'm based in Oman too, so have done as others suggest, and switched to https instead of http.
    Thanks All!

  20. davidalockwood

    I see I am not the only one having problems of this sort: Omantel...........
    Nawras 4G is ok so might just be a speed problem (nothing new there then) so have added htpps:// in front of my address and gives me a work around for now.

  21. Hey folks,

    Could all of you please do me a favour? Could you all please visit the following site and let me know your results?

    Our systems folks are looking to get some additional information, and it would be great if everyone would give it a try.

    Thanks in advance!

  22. amightywp
    I have just done (or tried to) using OmanTel landline - wireless and the result....

    "This web page is not available"

  23. Hi - Thanks for trying. Can you please provide the details (or a screen shot) of the Chrome Dev tools network panel for this request? More information can be found here:

    Also, can you please confirm that works for you?

  24. Barry
    https: //
    comes up with "Hello World"

    Re Chrome Dev tools network panel
    I cant figure out how to use it !

  25. Hi -

    Thanks for the update. It seems like your ISP or something on your local network might be filtering some of your traffic. If the problem persists across multiple browsers and computers, I would recommend contacting your ISP and reporting the problem. If they provide you an explanation, we would be interested in hearing it.

  26. lol nice to know so many people are all having the same problem..... welcome to Oman...i hope everyone's problems are resolved...i know its hard...u do get attached to your blog :)

  27. Barry,
    thanks for the investigation.
    I think as its our (all 3 users) ISP we will unfortunately leave it as it is

  28. Hey everyone,

    Ynotoman, I believe there're many users here in Oman, I'm one of them. It's just matter of time before they realise their blog doesn't display properly.!!

    I'm trying to contact Omantel, however I could not get in touch with the responsible team... HelpDesk are useless..

    I searched in google about the nature of this problem and found this forum!

  29. Hi, based from your detailed explanation of the problem and the screenshots.

    I can see that jQuery and CSS links are not properly loaded that makes your WordPress website act that way.

    The disappointing part is, the above behavior of your websites only appears when using Omantel connection, I have checked your website with Nawras and its working perfectly without https

    Here is a screenshot of ynotoman blog with the error showing in the Console

    I made further inspections and found out that the stylesheet and javascript which is located at won't load unless you use https.

    1. is the stylesheet file
    2. is the javascript file

    Now, to get this thing working in Oman, our ISP should allow the access to

    With regards to the query of @amightywp, here is a screenshot when you open

    as you can see there is a status code of 502 when GET method is initialize.

    and here is the response header

    and of course when using https it will return status of 200 and working perfectly.

    Hope this will help :)

Topic Closed

This topic has been closed to new replies.

About this Topic