Please, PLEASE let me use the old editor!!!

  • Author
    Posts
  • #213989

    zgates
    Member

    Okay, I get it. You guys wanted to upgrade the appearance, but it’s KILLING me. I cannot use this thing!

    First off, I can’t upload images. I have the newest flash and I get as far as the little box that shows upload progress, but it freezes there. I use a lot of images and this is simply unacceptable.

    Secondly, when using old images, what the HELL is up with all the weird extra parameters it just throws in?? Let me use my own. I want to use “class=left” and that’s ALL, but when it has me choose alignment, it gives me a totally different parameter value, not to mention the fact that it even puts an alignment value in when I choose NONE. I have to delete and replace crap EVERY time I want to put in an image!!

    And that’s just with what little use I have of it. At least give me the OPTION of using the old editor. I have people writing for me as well and it’s IMPOSSIBLE to keep up with explaining to them how to do everything. They’re not all computer whizzes, and I just want them to be able to add images and write, but you’re making it impossible by changing things like this.

    To put it bluntly, this new editor is NOT HELPFUL.

    #214090

    raincoaster
    Member

    You can use the old editor on an independently-hosted WordPress blog, but WordPress.com is not going to go back.

    #214096

    In this thread, tisme gives a good explanation on how to insert images into posts with the tree icon. You still have to be able to upload though which you will have to do through the add media section.

    You might think about an offline editor, such as blogdesk or windows live writer, both free, and both will actually upload the images with the post when you send it to wordpress.

    #214099

    I just thought of something for Firefox users. If you are using AdBlockPlus, turn it off (tools > addons) and restart your browser and try uploading. AdBlockPlus may actually be interfering with the Shockwave Flash uploader (many ads are flash based).

    #214240

    zgates
    Member

    I don’t have Adblock.

    I am, however, on a Linux machine using a Firefox variant, and currently it just sits there, attempting to upload. At least give me another way of uploading images, this flash business is, for lack of a better word, bullshit. You’re quite literally damaging my site by rendering me unable to upload images, something I was perfectly able to do before the “upgrade”.

    #214241

    mikecane
    Member

    zgates: I second thesacredpath’s suggestion of finding an offline composition tool. You can avoid the new interface altogether. I just tried it and it’s great!
    http://mikecane2008.wordpress.com/2008/04/09/blog-notes-blogdesk-is-fantastic/

    #214253

    riraito
    Member

    guess getting used to it is the best option

    http://www.riraito.wordpress.com

    #214272

    There is a bug in the Shockwave Flash plugin for Linux that Adobe has not yet adressed. It is something that is out of the control of WordPress, but hopefully Adobe will get it corrected real soon.

    #214287

    mikecane
    Member

    @thesacredpath: Adobe is not known for its speed. Plus, I’m beginning to find it very strange that WordPress *must* have known of this shortcoming with the Linux version yet went ahead with the changeover anyway.

    At some point, I’d like to go to Mac, but seeing all the problems happening to Mac users tends to make me believe I’ll have to run Windows too on a Mac under virtualization. (Unless, of course, there are no problems with offline composition tools…)

    #214288

    blaxter
    Member

    I use MacJournal on a Mac – you can send it to a blog using an official menu item as other offline editors do (post to blog, or similar), but in fact I am simply copying and pasting from the journal page into the WP editor and it does it fine. (I also run XP on a windows partition so I can check what IE does to it!)

    zgates – you’ll be a lot happier of you try an offline editor. Be brave!

    #214289

    animalluver
    Member

    Im having the SAME PROBLEM! Please help!!! Ive been saving a draft since the new WordPress style came, and I cant upload pix! Help?!

    #214474

    eatknowhow
    Member

    It’s impossible to use the new wordpress system. I can’t upload links, insert links or new pic’s. Please allow us to use the old wordpress editor. The new one does not work. Many other people are frustrated and are switching to more friendly media. I’m seriously considering exploring my options. I can’t operate in this capacity!

    #214485

    jamesobrien
    Member

    I’m using Firefox 2.0.0.13 on a Linux machine without any problem in uploading photographs. I’m happily uploading pics and inserting galleries. For whatever reason, the new interface is working fine for me, even if some others are finding it difficult.

    #214487

    techtrix
    Member

    The old version plz, for me as well.

    #214490

    tellyworth
    Staff

    Folks,

    If you want help with a specific problem, please contact support or post a new forum thread with a detailed description of the problem and any relevant information (your blog address, browser name and version, OS and anything else that might help).

    Tacking a “me too WordPress are teh suck” on the end of an existing thread might burn off a little frustration but that’s about it.

    We’d like to help but need details, straight questions and answers.

    #214498

    keyjeysi
    Member

    Ok,

    Im in the window with “new post”, click on “add image” icon, click on the “choose files to upload”, choosing photo…uploading process…crunching, file is uploaded in gallery, fill windows with titles and descriptions, choose alingment and size – done, click on the “insert into post”…window becomes white and nothing happens. When I want to close this window information “done but with errors on page” on the bottom bar appears…So Im closing window, there is no photo in the post window but file is uploaded in the Gallery…
    I can’t upload photos. Don’t know how to solve this, I was following instructions from wordpress automatic e-mail but it doesn’t work.

    #214508

    helenazarin
    Member

    Hi! How can I upload a pdf file in the new editor? I cannot see the upload tab! I am using IE, Windows 2000 (SP4).
    Thanks!

    #214509

    elcadillo
    Member

    “a detailed description of the problem “

    details:

    With IE v7 simply don’t work upload images

    see graphic example:
    http://www.grillonautas.com/index.php?showtopic=5695

    What do you not understand, tellyworth?
    Please, help us.

    Salud!

    #214510

    lazyaussie
    Member

    There are so many, many idependent cries for help on image upload not working across multiple browsers and versions, (20 + posts by now?) that i think it is time to call it a wordpress problem, not a user probem. It’s not the flash version, it’s not the browser, it’s not the platform. It’s the uploader.

    #214516

    gender
    Member

    I am having all the same problems described above. Here, however, is a work-around that I tried (in desperation) and <crossing fingers> it has worked so far …

    When editing a post and getting to the place where you want to insert a photo, SWITCH from VISUAL editing mode to HTML mode.

    Find the place in the HTML code where you want the photo to appear (don’t worry about alignment at this point). Place your cursor at that point in the midst of othe HTML soup.

    THEN click on the “add media” icon and proceed. There are other problems I’m having with the uploader (half of it is below the bottom edge of my browser; the only way to see all of it is to change the view percentage at the lower-right corner of my IE browser window, from 100 percent to 75 percent).

    BUT, the photo appears when I go back to visual editing. And, from that point, I can click on the picture, then the appropriate icon in the editing tool bar, and change alignment, horizontal and vertical spacing, and other paramenters).

    Hope this helps some of you.

The topic ‘Please, PLEASE let me use the old editor!!!’ is closed to new replies.