Post attribute

  • Author
    Posts
  • #849616

    samadams1773
    Member

    I have created 3 straw man posts in each of the 3 panels available in the DePo Masthead theme, and am in Private Mode for now (under construction). When I view the appearance (click tab in upper left-hand corner, above Dashboard), below the text I entered in the respective posts, it displays “Edit this entry.” I’m hoping this would only be available to me as Admin., and not actually visible on the ultimate (formally-published) website. True?

    Also, below this string is, of course, the Comment button (to allow viewers to post a comment). Would there be a way to control these Comment buttons? That is, is there an easy way to disable them until such time as I might want to allow comments?

    Any help is appreciated.

    #849712

    timethief
    Member

    The Admin edit link you see is only visible to you as a logged-in Admin of the blog. I cannot be seen or ysed by others.

    #849713

    timethief
    Member

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    We can also override the default settings and enable or disable future comments on any post or page.
    Depending on the theme we use when we close comments a phrase like “comments closed” or a similar phrase may appear and if so, it can only be removed by CSS editing after purchasing a custom design upgrade.

    #849714

    samadams1773
    Member

    Perfect. Thanks for the confirmation, Timethief. That was my presumption. Sounds like it’s merely a convenience for the Admin.

    How about disabling the Comments? Any thoughts there? Or is that a tall order?

    #849716

    samadams1773
    Member

    We got cross wired. I’ll take a look at the links you provided. Gracias!

    #849717

    timethief
    Member

    I’m assuming you were typing at the same time I was above because I did provide the links for setting up commenting default settings and disabling comments on posts and pages above.

    #849721

    samadams1773
    Member

    Got ya. It looks like the global Kill Switch for comments is under Default article settings:

    Allow people to post comments on new articles

    UNchecking this should disable all comments.

    Thanks again.

    #849726

    samadams1773
    Member

    Hmmm …

    I did as above (to disable comments) and saved. When I went out to view the result, it still displays the Comments buttons and allows submission of comments – at least from me. Does this make sense?

    Is something hung up in cache ??

    #849729

    justpi
    Member

    Changing that Discussion setting applies to post/pages created after the change. For already published posts/pages you need to disable comments and pings in the Discussion module of the post/page editor.
    If you’re not seeing the Discussion module while on the post/page editor screen, click Screen Options (top right) to activate it.

    #849738

    samadams1773
    Member

    Thanks for the clarification about after the change, Just Pi – that did the trick. Now, all the Comments buttons appear as Permalink.

    #849740

    justpi
    Member

    You’re welcome.
    Unfortunately the theme you selected is faulty – documented here:
    http://wpbtips.wordpress.com/2010/04/23/comments-off-1/

    #849741

    timethief
    Member

    I’m sorry I didn’t emphasive “future comments” in my comment above by making it bold. We can also override the default settings and enable or disable future comments on any post or page.

The topic ‘Post attribute’ is closed to new replies.