Post by email delay not working

  • Author
    Posts
  • #1093129

    maegraith
    Member

    As per instructions http://en.support.wordpress.com/post-by-email/ I tried to delay posting, but it is not working. In my last attempt I used these settings in the email to post:

    [category eat]
    [tags my goodness, eat, drink, live, Wendy’s, Lobster, Caviar, burger, Lobster and Caviar burger]
    [delay +4 hours]

    What am I doing wrong? Do I need to change a dashboard setting in the blog?

    The blog I need help with is mygoodnesses.wordpress.com.

    #1093335

    zandyring
    Staff

    Hi there,

    Did your post go through and it just wasn’t delayed, or did it not post at all? Could you give me the title of the post as well?

    Cheers!

    #1093339

    maegraith
    Member

    All the posts by email publish ok, but the only setting that does not work is [delay]

    I just published an example post http://mygoodnesses.wordpress.com/2012/12/13/favorite-travel-photos-of-2012/

    This is what I emailed:

    [category live]
    [tags my goodness, eat, drink, live, travel, beach, holiday, christmas]
    [delay +4 hours]

    You can see the category and tags show, but it was not delayed 4 hours, it published immediately

    #1093341

    zandyring
    Staff

    Hi there,

    I just tested this on my blog and it correctly scheduled the posts instead of instantly publishing them. So the first thing I’d suggest you do is make sure your time zone is correctly set (Dashboard > Settings > General). If that looks right to you, we’ll keep digging!

    I’ll ask around on my end at the same time.

    Cheers!

    #1093349

    maegraith
    Member

    I went into settings where time zone was set to my city name, I changed it to UTC +1030 but this didn’t fix

    I just posted a test and it posted immediately

    http://mygoodnesses.wordpress.com/2012/12/13/test/

    #1093350

    zandyring
    Staff

    Ok, so I haven’t dug anything fresh up yet, but I got a strange result myself when I pluralized “hours” in the shortcode. Will you try one more test for [delay +4 hour] instead of “hours” and see if it publishes immediately?

    Thank you!

    #1093352

    maegraith
    Member

    no, didn’t work

    http://mygoodnesses.wordpress.com/2012/12/14/t3/

    I used

    [category live]
    [tags my goodness, eat, drink, live, travel, beach, holiday, christmas]
    [delay +4 hour]

    #1093357

    zandyring
    Staff

    Hi David,

    I’m sorry this is still happening. One more question: what email client are you using? I’ve asked our internal team what might be happening here, and that information may be helpful to them.

    Cheers!

    #1093359

    zandyring
    Staff

    And one more “one last” question :)

    Your time zone is set to UTC +10:30 – are you currently in that time zone when you send the posts by email? If you’re not, that will affect when they schedule.

    #1093366

    maegraith
    Member

    Re client, I use both gmail and outlook exchange for posting. I also just tried it on my android ph in case desktop the problem, but same problem again.

    Yes I have tried various timezones through settings – do I need to wait a while for the settings to kick in?

    Meanwhile I have found a workaround by using delayed email in Outlook, which requires a few more clicks, but does the job

    #1093371

    zandyring
    Staff

    You shouldn’t have to wait for the time zone settings to kick in.

    I spoke to a member on our internal team, and he said that the way the delay was working (after we experimented) was not functioning correctly, so he was going to make some edits. The delay should work for whatever time zone your blog is set for. So even if you’re in UTC+0, if you email your blog and say +2 hours delay, it should translate into UTC+10:30 +2 hours delay (which it wasn’t currently doing).

    Could you try a new delayed post today?

    Cheers!

    #1093372

    maegraith
    Member

    Hi, I’ve tried with diff posts via outlook and gmail, neither work. This sucks, that Microsoft trumps WordPress, who woulda thought

    #1093373

    zandyring
    Staff

    I’m very sorry this is still happening to you!

    We are looking into it, and I’ll let you know when we have a better answer for you.

    #1093374

    yoavf
    Staff

    Hi – just to let you know that this should be fixed now. Please let us know if you’re still having any problems with delayed post-by-email posts.

    #1093375

    maegraith
    Member

    not working, just tried it for http://mygoodnesses.wordpress.com/2013/01/04/after-crispy-pig-ears-10-trends-for-2013/

    with these settings

    [category eat]
    [tags my goodness, eat, drink, live, pigs ears]
    [delay +1 hour]

    also, the post by email has stopped showing the image in the post on the home page of the blog, but it shows in the post itself

The topic ‘Post by email delay not working’ is closed to new replies.