Post Sharing Not Working

  • Author
  • #1945317


    On when I create a new post it is set to share with my Facebook, Tumbler, Twitter, and Google + but the posts are not being shared. I disconnected and reconnected all the accounts and tested them, still not working. If I go to the post and click the share button for whichever service it will then post. Using the WP mobile app any posts created there are shared. I noticed this started happening when was updated. I wasn’t able to find mention of others having this issue, just thought I would mention it to see if there is something I am missing or if it is an issue with the site.

    The blog I need help with is



    Have you tried using the Facebook debugger and or flushing your Facebook cache?

    Please consult Common Reasons Why a Post Failed to Publicize

    Post the snippet and link manually To Facebook to save time first and then proceed as follows.

    1. Try flushing your FB cache but disconnect from FB first

    2. Try the full reconnect procedure again detailed at

    3. Another way to help Facebook update its cache faster is to enter the link in its debugger here:

    Note: RSS Grafitti can be used for posting to Facebook walls if you prefer. RSS Graffiti periodically checks the RSS/Atom feeds that you specify and posts any new entries it finds to the Facebook Walls that you specify. You can get any feed written on any wall (Facebook Profiles, Fan Pages, Groups, Events and Application Profile Pages). In fact, multiple feeds to multiple walls. You choose the combination.

    Please note that reconnecting Publicize with Facebook and/or with Twitter. LinkedIn, etc. does not re-publicize missed posts, but it will work for future posts.



    Are you creating posts via the New Post button on the dashboard Add New Post page? I’m wondering if this might be an issue with the former.



    I have posted test posts from the dashboard and also from the pages section in settings. I will try to disconnect and reconnect once more.



    Ok so I was able to post from the dashboard/settings > posts > add new button.

    I tried again from just the dashboard and still no dice. It shows they will be shared but once the post is published all the fields to the right are cleared out. The sharing checkboxes, tags, and other info are wiped out.

The topic ‘Post Sharing Not Working’ is closed to new replies.