Need help? Check out our Support site, then

Post won't post

  1. Hi,
    I have been trying to post something for the last two hours and I just can't get it to post. Also, I can't switch to rich text editor, insert hyperlinks or upload pictures. I have cleared my cache, updated my browser, logged off and then logged back on in a new session and nothing seems to change. Also when I go back to the draft to edit it, there is nothing there but the title. Any advice?
    Thanks in advance,

    The blog I need help with is

  2. You may be able to recover an earlier Post Revision. Go to Posts > All Posts, hover over the title of the post, click Edit and check the Post Revisions module for previous saved versions of the post.

    If you're not seeing the Revisions module while on the editor screen, click Screen Options (top right corner of your Admin page) to activate it. Then select the post and page modules to include them. Then you ought to be able to go here > Dashboard > All Posts > Posts and locate the post and recover it from post revisions.

    If you cannot locate the post by using the instructions I provided for locating and restoring a post revision, and it's not in your Trash folder then you will not be able to recover it.

    When you start a new post, add the title, set it to private and then publish it. When you are done with the post, set it back to publish and update it. The problem with posts disappearing when saved as a draft has been around for a while, but only seems to hit a small number of people randomly.

    The other choice is to get and use an offline blog client such as Windows Live Writer (Windows) or Ecto (Mac) and then everything is saved on your computer and when you are done with the post, you actually publish it directly from the blog client software. See here for offline blog editors so you don't have to go through this again

  3. Hi Timethief,
    Thanks for the suggestions. I'm not worried so much about losing the post, as I always write them to a word doc before posting (having had a few too many lost in the past) -

    I haven't set the post to private yet and maybe that will work. But the problem is that most of the writing tools on the post writing page just aren't working. Not sure if it's just me or there is a server problem or....but I've tried everything I know how to try.


  4. Update, just tried the 'private' but it won't let me edit that. Maybe it will all just be okay tomorrow. Sometimes when inexplicable things happen the next day everything returns to normal. Fingers crossed.


  5. Update - the issue seems to have resolved itself. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic