posterous import

  • Author
  • #1206843



    i have a posterous blog. when i import my blog to wordpress it e-mails me to say import is finished but 4 posts out of 176 imported only. i tried many times. imported post number changes but it never is all of them.

    The blog I need help with is



    You deleted several posts which are still in the Trash sub-section of your Dashboard’s Posts section.

    The importer will not duplicate existing posts, so you’ll need to empty the Trash sub-section.



    right now there are duplicate posts on my blog. i dont know what is going wrong.



    Would you like me to empty your blog so you can try again?



    yes. thank you.
    this way it’ll be a controlled trial.
    here is the xml file: [removed]



    I don’t need the export file yet myself, so I removed the link, since we’re on a public form, but keep it uploaded there just in case.

    I have emptied your blog, so please feel free to try again yourself and let us know how it goes!

    If it doesn’t work within the next 24 hours, then I’ll need your export file.



    just finished importing the xml. there should be 176 posts. waiting for now.



    it worked!
    thank you for your assistance :)



    You’re welcome!



    I have similar problem. Seems only a few posts of the uploaded posterous backup xml file is imported.

    My Posterous export xml file “wordpress_export_1.xml” is too big, > 25M, so I tried to split it at the boundary between </item></item> tags into two parts 01.xml and 02.xml with similar size around 12.5M (since the posterous importer dialog told me that max size is 15M).

    After splitting the file, I appended the “</channel></rss>” end tags to 01.xml and prepended the xml header tags by copying from 01.xml to 02.xml, so both files should be complete in format.

    Since the Posterous export file is without \n line ending but a single line, it’s hard to edit in text editors, so I pre-processed them with Perl to add \n to tags with space or tab characters next to them, with the substitution statement “s/>[ \t]/>\n/g”.

    I tried to upload the resulting 01.xml file to through the Posterous importer menu. It told me that authors are not found, I got an email reporting successful import, but there is no posts imported even after 24 hours.

    Then I tried to search and replace all the authors in the 01.xml file to be the same as the WordPress blog to be imported into and tried again, this time the author is recognized and I selected the mapping to current author. After that, the same result is found, none of the posts were imported.

    Then I tried to convert the xml file back to be one big line by stripping all the \n characters with a Perl script to “chomp” each line. I uploaded the resulting 01a.xml file and this time I got 16 posts imported, while the xml file includes over 600 posts. Moreover, all the titles of the 16 posts are blank, which is also not correct.

    I guess maybe the number of posts are too big, so I reduced the number of posts included in the xml file to only 10 posts by manual editing the xml file. After uploading it, to my surprise, only 5 of the 10 posts were imported. I checked the titles of the posts and found that only the odd numbered (1, 3, 5, 7, 9) posts are imported.

    I’m going to try importing the 10 posts one by one, to see what happens.

    How to solve this problem? Since is closing the end of this month, I’m facing an urgent problem.



    I edited the xml file to include only 2 posts and found that the second post is always not imported, whatever post comes first.

    So I suspect that some format change in my editing caused the problem. I suspect the “\t” tab character is important for the import to work so I should not have removed them. So I changed the Perl script to insert newline chars for easy editing by “s/>\t/>\n/g” , and recover the tab character after editing by the Perl script “s/\n/\t>”.

    Then I tried to import 10 posts, and it succeeded.

    Next I’ll try with 1200 posts.



    Succeeded import with over 1200 posts. Problem solved.

    The tab char “\t” is important in the xml file. When trying to split big xml for import by parts, take care to recover the tab and other characters as in the original file.



    I found a problem with the Posterous exported wordpress_export_1.xml file. On my, there are 3774 posts, while the wordpress_export_1.xml file in the downloaded export zip file contains only 1275 posts. But there are 3776 xml files for each of the 3774 posts in the “posts” sub-folder of the zip package. I don’t know what’s the extra 2 files for.

    I’ll try to concate all the xml files into one, add the proper wordpress export file header and footer, and strip all the newline characters and try to see if they can be imported.



    I found the incomplete Posterous export file was caused by some JPG or binary code embedded in the webpage text that break the output of xml. I used Perl script to strip off those binary code:

    while(<>) {
    s/[\x00-\x08\x0a-\x1f\x7F]/ /g;

    In the above code, “oldid” is your old author name on Posterous, and newid is the new author name on WordPress blog.

    There is a head.xml in the Posterous export package, concate it with the combined xml file and append the end tag “</channel></rss>” to create an xml file, then process the xml file with the above Perl script to stripp off the newline and control characters, and substitute the author name.

    Choose to combine proper number of single post xml files to ensure the resulting xml file is below 15M limit.

    The DOS batch command to combine text files is:
    copy head.xml+posts.xml+tail.xml upload01.xml

    Then import upload01.xml to WordPress and it’s tested OK.



    Your problem isn’t really similar, it’s quite different.

    In the future, please open your own thread, and we can help you with any import issue.

The topic ‘posterous import’ is closed to new replies.