Posterous Import: Comments are Anonymous

  • Author
    Posts
  • #1155087

    duffxcom1
    Member

    I’m trying to move my company’s blogs over from posterous. I finally got it working properly, except for the fact that 95% of comments are showing up as “anonymous” – they’re not importing author name or website fields. I’ve done some Googling, and no one else seems to be having this problem, but I just imported about 20 blogs and it’s the same case with all of them.

    It seems that wordpress is only importing author name for users who were registered with posterous when they posted – if they posted with a name and URL, this information is ignored during the import.

    Example post with comments from one of the blogs:
    http://lcentralpt2.wordpress.com/2010/03/19/a-situacao-de-aprendizagem-de-ingles-no-brasil/

    And the original:
    http://lingqcentral-pt.lingq.com/a-situacao-de-aprendizagem-de-ingles-no-brasi (no posts are anonymous – they have author and web URL fields that were stripped during the import).

    Note that this is the case with 20 separate imports, so trying it again is not going to yield a different result.

    I’m using the “import from posterous” option. I tried using the “import wordpress” option previously using posterous’s exported XML file, but that simply failed to import any posts whatsoever.

    Am I really the only one encountering this problem? Are there any workarounds?

    The blog I need help with is lcentralpt2.wordpress.com.

    #1155180

    timethief
    Member

    Hi there,
    I’ll tag this thread for Staff assistance with your imported files. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1155342

    zandyring
    Staff

    Hi there,

    I believe I already have a thread on this from you (or is this a different issue?) – so we’ll wrap up there. We are currently working on this; it is ultimately an issue on Posterous’ side, but I think we can work with them to solve.

    Cheers!

    #1155348

    duffxcom1
    Member

    Hi,

    Same person, sorry. I figured this was a different issue and thought someone on the forums might have experienced the same problem and have some advice (whereas they wouldn’t notice it buried 5 messages deep in an unrelated thread).

    The imports now seem to be working (they stopped hanging on the “processing” screen), so the only problem now is the anonymous comments. Feel free to close this or the other thread. I appreciate your help.

    #1155353

    zandyring
    Staff

    No worries – it’s fine!

    We’ve worked on this, and could you try importing again? The API option has been removed to make the experience work better – could you try re-importing the file for the blog that is having this issue? Going forward you shouldn’t see this again.

    #1155362

    duffxcom1
    Member

    I reimported the file, and here are the problems I’m now having:

    1) Comment author’s URLs are not imported:
    EX: Andrew’s comment here http://linguisttest3.wordpress.com/2012/11/26/aprender-idiomas-sobre-todo-la-escucha-y-la-l/ vs the original post http://blog.thelinguist.com/aprender-idiomas-sobre-todo-la-escucha-y-la-l (just one example, but as far as I can tell not a single URL was imported across all the comments).

    2) Blog author’s comments display as ‘Anonymous’:
    EX: http://linguisttest3.wordpress.com/2012/11/27/lingq-20/#comments vs original http://blog.thelinguist.com/lingq-20

    3) Foreign language characters are imported as “?????”. This can be seen in both of the threads above (the post in the second link should be in Japanese, and in the first link see Carl Uroc’s comment). I think this is a problem on Posterous’s end, since I opened the XML file and question marks are displaying there as well. However, with the old “import” option, this wasn’t a problem.

    #1155383

    kathrynwp
    Staff

    Thanks for letting us know about these issues.

    1) & 2) – Posterous is not currently providing comment author URLs in their export files, and it looks like there’s a bug in the file when it comes to the blog author name. Our developers will bring both these issues to Posterous’s attention.

    3) Posterous advised us a few days ago that they’ve fixed issues with character corruption, although we’ve since had a few reports that some folks are still seeing the problem. You may want to do another export from Posterous and have a look at the file in a plain-text editor, to see if the question marks are still there. Let us know.

    In the meantime, we’ll keep you posted if we hear anything from Posterous on items 1) & 2).

    #1155384

    duffxcom1
    Member

    Just re-exported the XML file, and foreign language characters are still displaying as question marks. No change as far as I can tell.

    #1155385

    kathrynwp
    Staff

    Thanks for confirming. We’ve let Posterous know that there are still issues with character corruption in the exports and will keep you posted on a fix. Thanks for your patience.

    #1155386

    kathrynwp
    Staff

    Hi there – for both comment issues (1 & 2) – Posterous has informed us that they’ve fixed those problems in the latest exports. You’d need to re-export/import your file to see the fixes.

    They are still working on the character corruption problem as it’s a more complicated issue. I’ll keep you posted as soon as I have more news.

    #1155388

    duffxcom1
    Member

    Just re-exported and imported. The problems I listed above seem to be fixed, but now… it’s only importing 1 comment per post!

    The statistics show 226 comments imported, when it should be something like 813.

    Seems like two steps forward, one step backward ;)

    #1155389

    macmanx
    Staff

    Ok, this could be because the content already “existed” in some form.

    The best way to be sure would be to empty your entire blog so you can try the import again.

    Does http://lcentralpt2.wordpress.com/ only contain imported posts? If so, would you like us to empty it?

    #1155390

    duffxcom1
    Member

    No, I created a completely new blog for the test (because there’s no quick and easy way to delete the existing blogs), so that can’t be the problem.

    The blog I’m testing is http://linguisttest6.wordpress.com/ and I’ve shared the XML file in case it helps with troubleshooting: [removed from public forum]

    #1155391

    macmanx
    Staff

    All of the comments on the blog do have names, which is how it’s supposed to work.

    They do not provide commenter email addresses and URLs for comments left by Posterous users in the export file, and we can’t import what we can’t see in the file.

    #1155392

    jamestest582
    Member

    Same user, different account. My other account got locked, probably because I’m creating so many test blogs trying to get one of them to finally import correctly.

    The problem now is that there are 813 comments in the XML file, but wordpress is only importing 226 of them. Any idea why this is happening?

    #1155393

    macmanx
    Staff

    What is the URL of the blog that was imported to?

    #1155394

    jamestest582
    Member

    Same as my last post: http://linguisttest6.wordpress.com/

    And here’s another one I just tried, same result: http://lingtest.wordpress.com/

    #1155395

    macmanx
    Staff

    Would you please try the import one more time, maybe from a fresh Posterous export?

The topic ‘Posterous Import: Comments are Anonymous’ is closed to new replies.