Need help? Check out our Support site, then

posting a link doesn't work

  1. I get jetpack_error when trying to post a link.

    I did add title and description and tried again. Got same vague 'Jetpack_error".

    the link is

    I tried with http as well, still same stupid jetpack_error!

    don't your users post links? is this problem happen to me?

    The blog I need help with is

  2. Hi there,

    Are you talking about your self-hosted site? You've reached support for the free sites hosted at

    If your site is self-hosted with a different provider, support staff at do not have access to your site's files or the ability to provide support for your current issue.

    You can find support for your self-hosted WordPress site here:

    I'm not sure if it's related, but please update your Jetpack Plugin:


  3. wow! after days, this is a reply I get? if it was a self-hosted site, why would I come here for support?!

    it's a site. I cannot 'update' my jetpack!!

  4. We don't have Jetpack on - it's only available on So, if you don't have a site then you wouldn't need to update Jetpack because it doesn't exist here. Let me know if you have any questions with this!


  5. since you don't get it honey, I recorded my screen. you DO have jetpack on!!

    watch this youtube video

    if I were your boss, I'd fire you by now.

  6. I can't reproduce your issue. I was able to publish the exact link you tried.

    We're going to need more information:

    Does it happen for all post formats, or only links?

    Does it still happen if you enter a link title?

    Does it happen when you try to share other links (try or just that specific link?

  7. it happens for all post formats. I cannot post anything from

    as I said in my first post, it doesn't matter if I change the link, add title and description. it does not work!

  8. Hi there,

    Thank you for the information.

    So, our team looked into this and it looks like you left your primary blog set to your old Jetpack site and you never disconnected it from, which is why you were seeing that error.

    I have removed that Jetpack site from your account, and you shouldn't be seeing the error any more. Please let me know if you do.

  9. I now get 'unauthorized' error.

    your developers seem to like one word errors. unfortunately, I can't possibly guess what this 'unauthorized' error is related to.

  10. ok. it turns out, Ad block plus was to blame.

    now I have different issue. looks like 'link' post is nothing more than a link inside a normal post. that sucks. I thought it's more like Tumblr kind of link post.

    is this because of my theme? or it's just how wordpress is?

  11. your support is very slow.

  12. A link shows up as a link on your site/theme on It is working as it was designed.

    If you want to make this suggestion for open up a thread here:

    Since you original question is now solved. I will close this thread. If you have another questions please open up a new thread.


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.