Posting problem with Opera

  • Author
  • #14345

    I’m frequently getting “Connection closed by remote server” when saving or publishing entries. The frustrating thing is that this only happens about half the time. Otherwise it’s fine. I’m using Opera 8.54 with a 56k connection. As far as I know I’m not behind a firewall.



    (For the record, I, as a moderator, can see your IP address when you post here)

    Your IP address tells me that you’re coming in via a company that was bought out by a company that was bought out by Earthlink. I’m assuming that that is true as I know Earthlink uses proxies on their dial ups and Opera’s website tells me that that error usually appears when one is behind a (poorly run) proxy server. And you mention that this error occures when dealing with entires (or forms as per Opera’s FAQ on the subject.)

    I’m looking at point two in that quesion and wondering if maybe writing your post first, clicking on the Write post link in your backend, and pasting it your post would help at all. I dount that the WP database is keeping the connection open though.

    I don’t remember this error occuring before or at least anyone else discussing it over here.

    I’m sitting here with the error report and Opera plugged into Google and all I’m seeing is issues with Proxy servers and cached servers.

    I do see a mention where the size of the input is mentioned but I seriouslt doubt you’re uploading 2 meg files, right?

    I’m leaning to either your setup or something on Earthlink’s end.

    *chuckle* I do see where Opera and PHP pass the buck between each other on this error though.


    Yes, I came across that Opera FAQ entry too. Most of it went over my head, but I figured the problem was something like that.

    Usually in Opera when an error occurs when sending a form like this, one can hit the Back button and the content will still be there so you can try sending again. Unfortunately WordPress appears to force a reload, and I’ve lost many entries this way. I’ve gone back to the old trick from Blogger’s early days (when it was down more than up :)) of copying and pasting entries into Notepad before trying to save in WordPress. That works as a stopgap, but nonetheless I think I’ll use Firefox or IE for WordPress for the present time.

    Thanks for your help!



    When I was at Blogger, I could never use my Opera browser. Certain features were missing at my Blogger blog.


    It’s been ages since my personal blog was on Blogger, but I’ve recently joined a few group blogs at BlogSpot, and I haven’t experienced any real difficulty posting there using Opera. The ‘Preview’ is kinda finicky, but overall I was pleasantly surprised by how Blogger’s grown up. Of course, it still doesn’t hold a candle to WordPress!

    Edit: Oh, I just realized you meant the lack of formatting buttons in the entry editor. I don’t really need them so I never noticed that before. That is rather pathetic of Blogger, isn’t it?



    I downloaded Opera after Mozilla stole all my bookmarks. I refuse to go to IE. lol But then that happened at Blogger. So I would blog on Mozilla browser but use the Opera browser for everything else. But that was getting silly. So I’m back at Mozilla and God help me if my bookmarks vanish again.



    Same here: “Connection closed by remote server” occurs often, about half the time seems realistic.
    I’m using Opera 8.54 on a DSL connection, no proxy.

    Usually in Opera when an error occurs when sending a form like this, one can hit the Back button and the content will still be there so you can try sending again. Unfortunately WordPress appears to force a reload …

    This is getting on my nerves as well. Is there anything one can do to suppress the reload?

    For the time being, I always save my work in notepad before saving/publishing a post. I’ll try Firefox to see if the same thing happens, but Opera has always been my browser of choice.



    The reload request would be coming from your browser making a call for the page.



    hello west468,

    Opera tried to post a form, or request a URL having “?” in it over an already open connection, which the server was not willing to keep open any longer. Such request are never retried (“Hey! I did NOT buy two cars!”)

    in case this happens again, I guess FF will greet you with a “The connection was reset” or “The page isn’t redirecting properly”, the MSIE just tells you “This page can not be displayed” etc.

    just not to dive into an HTTP implementation debris or wordpress design, my only suggestion would be disable ‘Attempt to notify any Weblogs’ option.

    see also this thread.



    Thanks drmike and options for the information. I’ve noticed that I haven’t had a single “connection closed” in days. So apparently it was not a browser issue since I did not change any settings.

    As for reload requests: there are other sites, like e-mail services, where the reload does not occur in similar situations. I am so used to going back and forth in my browser that the reload when using WP is a real pain…
    In fact, to me it seems that it is only with WP that the reload occurs.


    Update: I’m still having “Connection closed by remote server” problems with certain other websites like Gmail (which does not force a reload, or at least it doesn’t in HTML mode). A word to my ISP about this proxy business is definitely in the cards, but in the meantime I found a workaround solution for WordPress, i.e. BlogDesk. I prefer it over having to use a different browser just for WordPress.



    Well glad to see you found a work around. Pity that you’re still having issues though.

    I do have to ask since I’m a system admin. What is the label of your ISP? If it is labeled Earthlink now, there are some concerns I need to adress with ICANN on it.


    #14854 – a regional ISP based in central Kentucky

    Thanks for all your help, drmike.

The topic ‘Posting problem with Opera’ is closed to new replies.