Posts cannot be seen on main page.

  • Author
  • #1202418


    In setting up my blog I edited the main categories and deleted “Home”. Since then I tried to publish my first post but what appears is “This is somewhat embarrassing, isn’t it? It seems we can’t find what you are looking for.”

    I’m assuming that deleting Home was my error. How do I get it back? Or, should I delete content and start again? Fortunately there isn’t a huge amount of content so this would not be much of a problem.

    Thanks for any help.

    The blog I need help with is



    Under Settings > Reading, what radio button is selected next to ‘Front page displays’? If you have it set for a static page (Home) then you could just recreate that under Pages > Add New.

    Or, if you’re luck, check Pages > All Pages > Trash to see if you can just restore it.


    Thanks for helping.

    By default the front page of your blog displays all posts. The 404 (page not found) error message on the front page of the blog appeared because the Admin of the blog deleted the placeholder Hello World post. As soon as you publish a post, not a page it will disappear. Read the differences between Pages and Posts.

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts.
    Choice 1 static front page
    Choice 2 running page for all posts on front page
    Which do you choose? It’s one or the other.
    If you choose a static front page then you have to create two pages as I said above. After you do that you go to > Settings > Reading and make the designation change and click “save changes”.

    Front page displays
    __ Your latest posts

    A static page (select below)
    Front page:
    Posts page:


    Or, should I delete content and start again?

    We Volunteers have noted an increase in bloggers who think deletion solves anything when it doesn’t. Please note that deleting content is never the way to go here. You can change themes and settings a million times but the content will still be there, provided you do not panic and delete. Know also that deleting any blog URL at is irreversible. No deleted URLs are ever recycled. Once deleted they cannot be reused by anyone.



    Since you’ve published a post but the front page shows the 404 (not found) message, this means you set a static page as your front but then trashed that page.

    If you want your latest posts on the front page:
    go to Settings > Reading and set your front to display the latest posts.

    If you want a static page as your front:
    go to Pages > All Pages, click Trash and restore the page you trashed;
    or go to Pages > Add New, create a new intro page, then go to Settings > Reading and set your front to display that page.



    Many thanks for your help and advice gureggu, thistimethisspace and justpi. All sorted for now, I think!

The topic ‘Posts cannot be seen on main page.’ is closed to new replies.