Posts don't show when activating new theme.

  • Author
    Posts
  • #768326

    rocketsound
    Member

    Every time I have activated a new theme into my blog, my posts don’t show and it displays an error message. In my old theme I had to add a page so it would display. I have now tried to activate another theme, and it still happens, even with a page there. Need help quick! Thanks. :)

    The blog I need help with is rocketsound.wordpress.com.

    #768484

    timethief
    Member

    We cannot even begin to help you until you post an active link starting with http:// to the blog in question.

    #768485

    rocketsound
    Member

    My apologies, here it is:

    http://rocketsound.wordpress.com

    #768486

    timethief
    Member

    As soon as you actually publish a post the 404 (page not found) error message on the front page of your blog will disappear. It was caused by you deleting the “Hello World” placeholder post.

    #768487

    timethief
    Member

    For some bizarre reason your username is linked to the WordPress.com home page. It ought to be linked to your blog. It’s easy to do this. Dashboard -> Users -> Personal Settings -> then scroll down to Account Details. Then scroll down to where it says ‘Website‘ select the URL for your primary wordpress.com blog and then save changes.

    Now every time you sign into the forum we can all click on your username and your blog will be linked to it. And every time you leave a comment on a blog your username can be likewise clicked and your blog can be instantly located.

    #768491

    timethief
    Member

    I suspect that you do not clearly comprehend the differences between static pages and posts. I also think have changed the front page of your blog here > Settings > Reading because you lacked an understanding of the differences between the two (pages vs posts).
    http://en.support.wordpress.com/pages/front-page/

    #768495

    rocketsound
    Member

    I did understand the difference, I just had the settings wrong, or better said I had the settings unset to display my posts.

    I have now changed it and it seems to work, thanks a million! :) :)

    Funnily enough, my account settings do display my primary blog (rocketsound.wordpress.com) there. Weird.

    #768498

    timethief
    Member

    That’s weird. When you click your username in this thread do you also end up on the home page of WordPress.com?

    #768501

    rocketsound
    Member

    Yeah, I do. Though when I put my mouse and hover over it it says (rocketsound.wordpress.com).

    #768502

    timethief
    Member

    Thanks for replying. I’m flagging this weirdness for Staff attention.

    #768508

    rocketsound
    Member

    Thanks, I appreciate it. :)

    #768514

    timethief
    Member

    Happy blogging! :)

    #768578

    macmanx
    Staff

    Make sure that you have your front page or posts page set correctly at Settings -> Reading when you switch themes. If you do, please leave it as is (with the error) so we can take a look.

    #768630

    auxclass
    Member

    When I click on the name for rocketsound – I end up on freshly pressed – when I click on the rocket sound link in the third post above I end up at the correct place

    looks like one for @macmanx!!

    #768633

    rocketsound
    Member

    Yes, it’s very weird. I wonder what’s up with that.

    #768634

    rocketsound
    Member

    I think I fixed it, I think the problem is that I had the (http://) included in my URL. I didn’t know that made a difference. Thanks everyone for helping out!

The topic ‘Posts don't show when activating new theme.’ is closed to new replies.