posts not showing up

  • Author
    Posts
  • #284992

    amyfrazier
    Member

    Newbie here. I read through some threads on posts vs. pages, and I have not found the answer to my problem. I have several static pages, including the home page, which is a child of the page titled “Posts.” (I think I read to do that somewhere on the forum several days ago when I first started…) Anyway, when I write a new post, it shows up under categories and archives, but not on the “Posts” page. Evidently, I’ve done something wrong in setting up the pages so that I have a dynamic spot that contains all of the posts.

    I realize that I’ve set this up to act more like a website than a blog site. That was intentional. But I can’t get my head around how to get the posts to show up, or, perhaps, I don’t know where they’re showing up, and how to represent that in the navigation.

    Thanks for the help!

    http://www.chateauseminars.wordpress.com

    #285198

    Correct link to your blog please?

    #285200

    amyfrazier
    Member

    oops. sorry. You’d think it would be ingrained by this point.
    http://chateauseminar.wordpress.com/

    #285203

    lizii
    Member

    I think the problem is that you’ve created the page that you have entitled “Posts.” You have also set the Home Page as a child page of this “Posts” page, which hides it from the top bar. Your posts are unable to appear on a page you have created.

    #285204

    Your “Posts” page is blank, as it should, so I guess you haven’t gone to Settings > Reading > “Front page displays” to select that page as your “Posts page”. Don’t forget to click Save Changes after that.

    #285207

    (No lizii, that’s the way to do it if you have a static fornt page. And hiding the Home page is necessary in themes with a builtin home tab of their own.)

    #285208

    amyfrazier
    Member

    Pan:

    That was it. For some reason, I thought the “posts” setting would undo the “static page: home” setting.

    All better now. Thank you!

    #285221

    You’re welcome – and you’re right, it’s rather confusing in the beginning. Usually the “front” or “home” page is where your posts appear. But if you opt for a static front page instead, then you need another page for your posts: hence that double setting in Settings>Reading. (The only thing that wouldn’t work, of course, is selecting the SAME static page as your front AND posts page.)

    #285236

    amyfrazier
    Member

    Got it, thank you. That really helped explain things!

The topic ‘posts not showing up’ is closed to new replies.