Posts not showing up on reader right away

  • Author
    Posts
  • #3244894

    oxria
    Member

    Hello!
    Ever since the beginning of the year I’ve noticed that my new post don’t show up on the Reader page right away. Instead, they take up to 24 hours to show up.

    I was wondering if there is anything I or you can do to fix this. I’d like my posts to show up on the Reader right when I publish them.

    I’ve tried disconnecting and reconnecting the Jetpack plugin, but the posts still take time to show up.

    The blog I need help with is https://www.oxria.com

    Thank you!

    The blog I need help with is www.oxria.com.

    #3245843

    kokkieh
    Staff

    Hi there,

    Some delay is normal for Jetpack-connected sites, but it definitely should not take 24 hours.

    Your site’s Jetpack connection and Reader feed both look fine, but this could be caused by another plugin on your site. Jetpack shows you have WP Super Cache installed on your site. Can you please try disabling that and then see if it makes any difference the next time you publish a post?

    #3246605

    oxria
    Member

    Thank you for your answer!

    I installed the plugin to try and clear my cache, after seeing that several new posts took around 10 hours to show up on Reader. So I don’t think the plugin is the problem. In the past it used to take 5 minutes for my posts to show up. Could it be another plugin that is causing the delay?

    (I also disabled the WP Super Cache plugin and published a new post to test it, and it’s still not showing up.)

    #3246742

    supernovia
    Staff

    @oxria right now when I look at https://www.oxria.com/feed/ , the latest post I see there is from January 6:

    https://cloudup.com/cinrq70N-ys

    I saw your test post and that it was deleted. Would you be willing to check https://www.oxria.com/feed/ next time you make a regular post? You can just search the file for your most recent title to see if it’s there.

    #3248887

    oxria
    Member

    I’ve just published a new post and checked the link you provided. The post does appear on there, but it’s still not showing up on the Reader page.

    #3249209

    kokkieh
    Staff

    The new post is showing in the Reader now, but it’s again been over 24 hours since you published, and there’s no way to check when it actually appeared. We don’t have a staff member online all the time during weekends, so a weekend day is really not a good time to test this.

    Please let us know here the moment you publish your next post during a week day, so we can check on things immediately.

    I’m also subscribing to your site so I’ll get a notification when your next post is published – if it happens while I’m working I’ll be able to check it immediately.

    I installed the plugin to try and clear my cache, after seeing that several new posts took around 10 hours to show up on Reader

    That plugin is used to cache information from your site, and can actually make existing caching issues worse if not configured correctly, or if your web host already does caching on their end. If you want to clear your site cache it’s better to use the built-in tools in your web host’s control panel to do that.

    Could it be another plugin that is causing the delay?

    That is possible. The only way to test would be to disable all plugins except Jetpack to see if that makes a difference, and then re-enabling them one at a time until the issue starts happening again to narrow down what. Looking through your plugins list that Jetpack shows on our end I don’t see anything obvious, though.

The topic ‘Posts not showing up on reader right away’ is closed to new replies.