Posts won't publish

  • Author
  • #936853


    Hi. Feeling quite foolish right now. I use a customized Bueno theme, but I don’t know CSS. The customization was created by a friend. I can compose and save drafts of a new post, but nothing at all happens when I click Publish. I have tried: restarting my computer (natch), switching browsers (Chrome & Firefox), and changing the theme to Twenty Ten (didn’t help). I don’t seem to have any Plugins — this option doesn’t even appear in my Toolbar — so unless I’m really clueless, I don’t think I have any to disable. Anyone have other ideas? Thanks in advance.

    The blog I need help with is



    I don’t think this issue is connected to the CSS cutomization of the theme.

    You may be able to recover an earlier Post Revision. Go to Posts > All Posts, hover over the title of the post, click Edit and check the Post Revisions module for previous saved versions of the post.

    If you’re not seeing the Revisions module while on the editor screen, click Screen Options (top right corner of your Admin page) to activate it. Then select the post and page modules to include them. Then you ought to be able to go here > Dashboard > All Posts > Posts and locate the post and recover it from post revisions.

    If you cannot locate the post by using the instructions I provided for locating and restoring a post revision, and it’s not in your Trash folder then you will not be able to recover it.

    When you start a new post, add the title, set it to private and then publish it. When you are done with the post, set it back to publish and update it. The problem with posts disappearing when saved as a draft has been around for a while, but only seems to hit a small number of people randomly.

    The other choice is to get and use an offline blog client such as Windows Live Writer (Windows) or Ecto (Mac) and then everything is saved on your computer and when you are done with the post, you actually publish it directly from the blog client software. See here for offline blog editors so you don’t have to go through this again



    Thank you! I tried recovering a couple earlier versions of the site and publishing them “private.” No go. I tried creating an entirely new post, making sure to have a look at the HTML and also publishing that privately. Still getting a “page not found” in preview. I’ll try Live Writer. Thanks for the suggestions. If anyone else has any other ideas or recommendations for good offline editors, I’d be happy to hear them. Thanks again, Timethief!


    If you use AdBlock on your browser, turn it off. I don’t need to on my real blog, I do need to on my test blog. I’ve since whitelisted the test blog in AdBlock, but if I remove that I get the same issues you are having.

    I hope that helps!



    Hi again. If you are not using the https:// secure log in please try it.

    If you are using IE9 in compatibility mode disable that as it reduces the functions of the browser to IE7 and IE7 is no longer supported.

The topic ‘Posts won't publish’ is closed to new replies.