Need help? Check out our Support site, then

Press This Tool Will Not Drop & Drag

  1. I am trying to use the"Press This" tool and it will not drop & drag OR right click at all.

    The blog I need help with is

  2. What browser and version are you using?

  3. I agree with raincoaster this does sound like a browser issue. What is your operating system?
    1. Have you had any recent updates to it?
    2. Has your security program and/or firewalls been updated recently?
    3. Have you recently scanned your computer for viruses, malware, etc.?
    4. How are you connecting to the internet and to
    5. Which browser and version of it are you using?

    Have you tried any troubleshooting?

  4. I am having the same problem... I am using Internet Explorer 8. I'd be happy to upgrade to IE 9, but am not allowed unless I also upgrade to Windows 7... and I can't upgrade to Windows 7 until... well, you get the picture. I will try the instructions for specific browsers.

  5. I hope someone posts the answer. I've tried all the fixes, cleared browser, cache, cookies, history. I am on IE8.... thanks, all!

  6. @ideahost2012
    I suggest you download either a Firefox or Chrome browser and then try again.

  7. I'm having same problem, using IE8, Windows 7, ran virus scan, deleted cookies; etc. All I get when I click to drag Press This to favorites, is a diamondy shaped square. I have the Chrome browser, as well.

  8. I'm sorry I can't help and I do hope Staff or another Volunteer will be able to. I'm using Firefox 7.0.1 on windows XP and I was able to drag Press this to my favorites.

  9. Have changed security settings under miscellaneous to allow mixed data, as instructed under changing browser settings/instructions for specific browsers. Hm. Hope someone out there has the answer. Looks like this has been happening a lot in the past day or so. Thanks.

  10. Are you willing to try another browser?

  11. I switched to Google Chrome, and it works fine, now, timethief. Thanks!

  12. Yay! I'm so happy you have resolved this. You're welcome and best wishes for trouble-free blogging. :)

  13. I use Mozilla and it won't work for me either. I even cleared my bookmark bar but when I drag it up it shows a NO sign (circle with line) When I try to right click....nothing. It sound like a cool tool if we can get it to work.

  14. I use Mozilla and was able to drop it to "Bookmarks"

Topic Closed

This topic has been closed to new replies.

About this Topic