Prevent Automatic Link Insertion When Composing

  • Author
    Posts
  • #1655919

    raywoodcock
    Member

    I am writing along. I insert an example: yourblog.com. The WordPress composition window determinedly insists that this must be an actual URL: it converts it into a hyperlink, and I cannot remove it. Or can I? I’m sure a lot of people appreciate the convenience, but for my purposes, it is really unhelpful. I insert links manually when I want them; often, I don’t.

    The blog I need help with is raywoodcock.wordpress.com.

    #1656002

    raincoaster
    Member

    Don’t use http in front of those links.

    #1656032

    raywoodcock
    Member

    Unfortunately, as in the example given, it does it even when all I write is something like yourblog.com. No http in sight.

    Even worse, sometimes it does it in the published version without even displaying it in the draft. Consider this post: I am editing it right now and the http://yourblog.wordpress.com link in the first indented quote is not showing up as hyperlinked text in the WordPress composition window.

    #1656033

    raywoodcock
    Member

    I see WordPress does it here too. I didn’t mark that yourblog text as a link in the preceding comment.

    #1656034

    timethief
    Member

    @raywoodcock
    I have noticed this also. I had a Resources Page for years with links that were not active (I deliberately set it up so they were not active) then suddenly one day they all became active – hundreds of them! I cursed and made the page Private.

    #1656035

    raincoaster
    Member

    That’s interesting. On my browser, myblog.com or whatever is not highlighted here.

    #1656036

    raywoodcock
    Member

    You mean my 2/15/2014 2:03 PM reply here? When I view it in Firefox, Chrome, Internet Explorer, and Opera, the “http://yourblog.wordpress.com” text, not marked as a link by me, is automatically highlighted as link by WordPress.

    #1656129

    raywoodcock
    Member

    Well, is there any way to get WordPress to fix this? It is really annoying. Surely there could be a user option to let link creation be manual or automatic.

    #1656131

    timethief
    Member

    Hi there,
    This thread was tagged back on February 15th for Staff and they are working their way through the many threads tagged for their attention. Staff work through all forum threads tagged for their attention and through all email support tickets in order of datestamps and timestamps – first posted first served, as would be expected.

    It’s in your best interest not to post to threads after they have been tagged for Staff help. When bloggers keep bumping any thread thinking they are going to get service from Staff more quickly they aren’t thinking straight because that moves the timestamps forward and it takes longer to get a response. The same is true if you email more than once the date moves forward and it takes longer to get help.

    Sorry for the long wait.

    #1656134

    raywoodcock
    Member

    Sorry — am I supposed to be able to tell when a thread has been tagged for staff? I’m looking around here and not seeing anything, but maybe I’m overlooking something. As far as I knew, I had posted a follow-up question, on Feb. 15, and nobody replied. Looks like raincoaster was also under the impression that this was an ongoing discussion.

    #1656135

    timethief
    Member

    I’m sorry that the fact the thread was tagged with modlook for Staff got lost.

    #1656145

    @raywoodcock It’s hard for me to tell (when looking at the post you linked to) which instances of yourblog.com are giving you trouble. Only to links contained in blockquotes, or those in paragraphs too? Also, are you including the

    http://

    part as well, or only something like yourblog.com only?

    Thanks for the additional info!

    #1656146

    raywoodcock
    Member

    Hi, Jerry. Thanks for getting back to me. The user interface seems to aggressively convert every possible thing into a link, including even examples like http://folder/blogs (which does appear in that post). It does this regardless of whether they are in blockquotes or not. (BTW, the spellchecker here is marking “blockquotes” as a typo.) In a test right now, it does it with http://www.yourblog.com and with http://www.yourblog.com (without the http). I believe there have also been instances when it would even create a link out of yourblog.com (without either http: or www).

    What I’m hoping for, as you probably already gathered, is an option to let me decide what text should be accompanied by a hyperlink and what should remain just plain text.

    Thanks again.

    #1656147

    Gotcha, thanks for explaining. So this is an automatic behavior on WordPress and if will try to take any structurally valid plaintext URL and turn it into a hyperlink, such as the examples you gave:

    http://folder/blogs
    http://www.yourblog.com
    yourblog.com

    It doesn’t work every time, as you can see above, but it will work for most common occurrences of “looks like a link” this is what will happen.

    If you want to avoid having those converted into live links, you will want to switch from the Visual editor to the Text editor by clicking the tab on the right. From there, you will want to wrap your urls (if not your entire code examples) in HTML “pre” tags as shown in this code example here:

    Which will give you a plaintext output:

    http://folder/blogs
    http://www.yourblog.com
    yourblog.com
    #1656148

    auxclass
    Member

    @jerry – the convert to links is a recent “enhancement” to the format here – it used to just happen in the P2 theme – then I noticed a few months ago that a Page that had some links on it to show what I was using as a stick on label and for years it had the http….. stuff just fine – then one day it just converted to links – was not able to beat the “upgrade” and finally scanned a copy of the label and put the scan on the Page –

    #1656149

    raywoodcock
    Member

    Jerry, there are several problems with that. First, even your examples turn out not to be plain text: it looks like what you intended has been commandeered after the fact. That is a good part of what I’m talking about: it is very aggravating that, even after the code has been managed and no link-conversion has occurred, you come back later and, as auxclass says, the gremlins have decided to rewrite your stuff. And as s/he also says, this is a new imposition.

    There may well be solutions that a dedicated HTML coder could manage. But I’m not that. I’m just trying to write my blogs. I don’t know how to do what you’re describing, and I dread the thought of trying to manage it within a table or other complex HTML.

    I don’t understand why things were changed. Was there some kind of desperate need to help people insert links — were they not aware of the Link button available to every WordPress blogger?

    #1656150

    raywoodcock
    Member

    I should add: note that Timethief (a WordPress employee?) indicates (above) that she, too, had a page that was working fine for years, and then suddenly it got rewritten with these undesired links. Note also that, in my case, the post I am talking about has dozens of these undesired conversions. This is not just some occasional thing. This is a real burden for some of us.

    #1656151

    auxclass
    Member

    Timethief is a long time volunteer helper in the forum – not an employee and has a blog on better blogging

    I am a he by the way – –

    most of the time when I refer to people in the forum I use gender neutral like “they”

    #1656152

    @raywoodcock – That is a separate issue with the forums (which is on a different code base) and has been reported.

    Using PRE or SPAN tags around your URL (that you want to render as plain text) will work on your site, and this is something I have tested and verified.

    There may well be solutions that a dedicated HTML coder could manage. But I’m not that. I’m just trying to write my blogs. I don’t know how to do what you’re describing, and I dread the thought of trying to manage it within a table or other complex HTML.

    There is no other way to prevent automatic linking, so you will need to add HTML tags to get what you are after.

    If you are uncomfortable with composing your posts in the Text (HTML) editor, you can write the entire post first in the visual editor. Then switch to the text view, and use the search function in your browser to locate the strings you want to not be converted to links by adding the appropriate HTML.

    I don’t understand why things were changed.

    It is uncommon for users to add a URL to a post and not want it to be a link. So for them, this is a great convenience. With that in mind, it’s worth noting that this is a feature, and not a bug, and not something that we’ll be “fixing” any time soon.

    #1656153

    raywoodcock
    Member

    Jerry, I hear you. Thank you for getting back to me. But if you would, please consider a couple of caveats.

    Note, first, that we are not talking only about full URLs. I suspect the situation is not as clear-cut as you suggest in some instances. For example, a businessperson, describing his/her company, is not likely to appreciate that *every* reference to OurCompany.com is converted to a highlighted link, given that there may be a half-dozen such references in a single paragraph. In other words, I am suggesting that the feature has been overdone. Convert a full URL, if you must; perhaps revise the URL link button to suggest a possible full URL for something like OurCompany.com; but hesitate to insist that every last thing that *could* be a link *must* be a link.

    Another adjustment to consider: there is a difference between a feature that offers a one-time default treatment (i.e., converting a full URL to a link at the time of composition) and a more aggressive feature that perpetually insists upon a single outcome in all instances. In other words, suppose I type http://www.webpage.com. The editor converts this to a link, immediately or at the time of saving. Fine. Now I go back and click on the break-link button. I have signaled that this URL is not to be converted to a link. Can that act not result in the automatic insertion of the HTML code you recommend, or in some other change, so that my express formatting wishes are respected?

The topic ‘Prevent Automatic Link Insertion When Composing’ is closed to new replies.