Need help? Check out our Support site, then


Private page does not show

  1. I have created a page that has "Visibility: Private". My thought was that the title of the page should show together with the other page titles when I am logged in as administrator. This does not happen. It shows as expected if I set "Visibility: Public" or "Password Protected".

    Are there some interference with other settings?

    The blog in question is askeragility.wordpress.com

    Thanks a lot!

    The blog I need help with is askeragility.wordpress.com.

  2. panaghiotisadam
    Member

    That applies to posts on your main page, not to page tabs in your menu.

  3. Thanks for your answer, panaghiotisadam!

    I am trying to hide a page tab, and that seems to be a feature in "Publish" section of the "edit page" page.

    Are you saying the feature doesn't really exist?

    Thanks!

  4. panaghiotisadam
    Member

    Your original question seemed to be if you could display a tab for a private page. Now you seem to be asking the opposite. Anyway: the regular top menu of a theme displays all your published parent pages; to modify that, you need a custom menu.
    http://en.support.wordpress.com/menus/

  5. Thanks for trying to help, panaghiotisadam!

    First of all, I owe you a beer for showing me "custom menus"! I find the possibility of building pages based on categories a very nice feature!

    ---
    What I am trying to achieve is to have a place to exchange ideas with other editors on the blog, hidden from ordinary readers. I thought it could be implemented with a "Private" page. What I *thought* should happen was that the tab would only be visible when logged in as editor or administrator.

    In my test I don't ever see a tab for a private page in the regular top meny. When applying a custom menu everyone see the private tab, only editors and administrators see the content while a blog reader gets an error message telling "This is somewhat embarrassing, isn’t it" .... Is this the way it is supposed to work?

    Thank you for your patience!

  6. http://en.support.wordpress.com/pages/page-visibility/

    I don't think the Page shows as a Tab - but that you need to view the page some other way - but not sure. Maybe the above will help.

  7. panaghiotisadam
    Member

    As already explained, a tab to a private page will be visible to none or to all - no intermediate option. You can give the URL of the private page to your other editors and they can turn it into a bookmark in their browsers.

  8. Then it seems to me that the menu part of private pages seems a bit clumsy. I guess the way around is to never display the tab (menu entry) for a private page, and somehow share the url.

  9. There is a way to do what you want, but it involves customising your theme a little. In the place where you want your private tab/link to appear you need something like the following:

    <?php if(current_user_can('edit_others_wiki_pages')) { ?> <!-- html for your link or tab !><br /> <?php } ?>

  10. panaghiotisadam
    Member

    @antonchanning:
    Read this please:
    WordPress.com or WordPress.org ? The difference.

Topic Closed

This topic has been closed to new replies.

About this Topic