problem adding links

  • Author
  • #381237


    I’m wondering if anyone is aware of any problems associated with adding links to blogs.

    I’m trying to add this link…

    <center><a href=""><img src="" alt="NOTICE!" border="0"></a><a href="">Powered By Ringsurf</a></center>

    To this page…

    It tells me that the link has been added when I try it but doesn’t show up…help!

    The blog I need help with is


    Part of the problem may be the arrangement of the attributes, which is becoming more of an issue with each successive revision to web standards. This is the code the way that is preferred now.

    <a href=""><img src="" border="0" alt="NOTICE!" /></a><br />
    <a href="">Powered By Ringsurf</a>

    The above works just fine in my test blog. I added a break tag after the image link code so that the text link would be below the image and centered.

    One suggestion is to go to settings > writing and select “WordPress should correct invalidly nested XHTML automatically” and then click “save changes.” That way, wordpress will correct any arrangement or HTML issues for you automatically.



    I tried pasting the link as you have it written, and I tried adjusting my settings…still no luck…not sure what the problem is.


    OK, where exactly are you trying to put that? I though you were trying to put it into the body of a page.

    You have other problems that have to be fixed before that though. Virtually all of your images are too large for the post area which will break your blog and means the sidebar widgets will not show up. The maximum width of images for the post area on pressrow is 500px. You have many that are 1024px wide. Those have to be reduced down to 500px. You can have them linked so that when clicked they bring up the full-sized image.

    You need to go into each post, click on the image to highlight it, then click on the image edit icon at top left and click on the “advanced settings” tab. Look at the width shown there. If it is over 500, change the width to 500 AND then delete the height in the adjacent box so that the image will remain in proportion. Click update.

    If you wish the image to be linked to the original full sized image, then click on the image again, click on the edit image icon, and then click on the “link to file” button and then click update again.



    Thank You for the picture advice…I’ve begun editing all of my pics,but still can’t get the link in! I’m beginning to feel like Dr. McCoy on star trek…”Darn-it Jim, I’m a writer not a computer hack”


    Where are you trying to put the image and link?


    I’ll take a guess and assume you are wanting to put the image and link into the sidebar. The image you have is too wide for the sidebar on the pressrow theme. It has a maximum width of 230px, so I made an adjustment to the code so that it will work in the sidebar.

    1. Copy to following code to your clipboard

    <p style="text-align:center;"><a href=""><img class="aligncenter" style="border:0 initial initial;" src="" border="0" alt="NOTICE!" width="230" /></a></p>
    <p style="text-align:center;"><a href="">Powered By Ringsurf</a></p>

    2. Go to appearance > widgets and put a text widget into your sidebar and after you place it there, it will open up. Paste the code above into the body of the text widget. Click “save” and wait for the little spinning donut to disappear and then click the “close” link at the lower left of the widget. If required, you can move it to a different location in the sidebar by dragging and dropping it (wait for the little grey outlined box to appear before releasing the mouse button). Go to your blog and the image and the text link should be there.



    Thank You Sir! The linked site now recognizes my site…it seems as if they’re having some sort of code problem…I appreciate your help greatly! Do have a wonderful weekend!


    You’re welcome, and I’m glad things are getting sorted out for you. You have a wonderful weekend as well.

The topic ‘problem adding links’ is closed to new replies.