Image upload errors?

  • Author
  • #617989


    “ 5-22-2011 7-25-14 AM.jpg” has failed to upload due to an error
    This file is empty. Please try another.”

    If I try to upload an image from my computer to a new post when using the latest release of Chrome (I’m thinking of changing from Firefox) I get the above error message.

    The exact same thing (same post, same file, etc.) works fine in Firefox.

    Any ideas?

    Blog url:



    I can’t reproduce this on your blog in Chrome, I tried several images (jpgs, pngs).

    Is this the same for all images, or just this one image? Are you using the browser or flash unloaders? Which operating system are you on? Which version of chrome are you using (you’ll be able to find this in the browser menu, under About Chrome or similar).



    As I mentioned, I’m using the latest Chrome release – 11.0.696.68

    My OS is 64 bit Win 7. I’m using the browser uploader (Select Files > From Computer).

    Here’s a new factoid – the upload works if the image is on the PC’s internal hard drive (I hadn’t checked this before, because that’s not where my image library is stored).

    I store all of my data on an external Windows Home Server system (specifically an HP Media Smart Server 495EX). The WHS image folder is mapped to Drive Z:/. My normal method of accessing my images (they’re all on the WHS system) is via drive Z:/ – and this is what doesn’t work. Since your reply I tried uploading the image directly from the server (that is, not as drive Z: but straight to the network server) and surprisingly that worked.

    So, here’s what we have –
    1. Image upload from C:/ works – but that’s not where my files are
    2. Upload from Z:/ gives me the error message cited in my original email (this mapped drive is for the image folder within the overall documents stored under WHS for convenience of access to my images – especially for my image database program)
    3. Upload straight from the server without going through the mapped drive works.

    Summary – after these tests, I now have a work around. However, it would be nice to know why the mapped drive can’t be accessed via Chrome when it works in fine in Firefox.

    Note – this problem is unique to WordPress. I just logged on to my SmugMug photo gallery and was successfully able to upload an image from Z:/ to SmugMug that will not upload to WordPress. Very odd.

    Any more ideas.




    PS – You asked about this image or all images. Any and all images (accessed via the mapped drive).



    I recommend bringing this up with the Chrome folks. It’s typically the browser’s responsibility to communicate the file’s size, and not part of our uploader, so you might have actually run into a Chrome bug.




    Since I have a workaround, I’ll pass on bringing this up with Chrome. I’ve tried the image upload with numerous sites since my initial post to this thread – and they all worked properly with WordPress being the lone exception – so I doubt that Chrome will place much priority on the “problem”. More likely they’ll just point the finger back to WP and I don’t want to be the intermediary in an inter-mural scrum among programmers ;-)

    Don’t you agree that it’s strange that of all my tests only WP’s uploader has this problem? Suggests to me that a fix might be pretty simple – and worthwhile.



    I do agree that it seems odd, but there’s literally nothing that we can do in this case. :(

    I just tested it myself and didn’t run into the same problem. Though, I can’t duplicate your exact setup, but I did try via an external hard drive at least.

    The only other thing that I could recommend would be to try uploading the file via an Incognito Window (via the File menu). This shuts off the browser’s add-ons, cache, and cookies, to rule out any third-party causes.



    Thanks for the follow up. I understand your position.

    Just to clarify – no further work/response needed though – as I pointed out earlier, I found that I can load an image from an external drive – just NOT the contents of a folder on that drive that’s been mapped. My WHS system contains all of my documents including several terabytes of images. The images are in a folder name “Imatch Images” and that folder is mapped to Z:/

    If I load the image from the server, MyServer/ImatchImages/xxfilexxx.jpg (not the mapped portion Z:/MyServer/ImatchImages/xxfilexxx.jpg) all is well. The problem occurs ONLY if I access the image from Z:/ (which is my normal workflow).

The topic ‘Image upload errors?’ is closed to new replies.