Problem using Google Maps

  • Author
    Posts
  • #279213

    I’m trying to embed a Google Map into a page using the shortcode. I’ve read the FAQ and following the instructions but no joy. I’m getting the message: “Forbidden – Your client does not have permission to get URL /maps?f=q&hl=en&geocode=&q=http://spreadsheets.google.com/pub?key=p-HTViFYZAjIrfiiCkpEZcQ&output=txt&gid=0&range=kml_output&time1=3973602&ie=UTF8&t=h&s=AARTsJqpNOS5c0kwFks2rUC01adNpmMpwQ&ll=-2.196727,123.310547&spn=30.377465,41.308594&z=4&output=embed from this server.”

    This map is generated using Spreadsheet Mapper, the map is public and the embed code from Google is:

    <iframe width="470" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://maps.google.com/maps?f=q&hl=en&geocode=&q=http:%2F%2Fspreadsheets.google.com%2Fpub%3Fkey%3Dp-HTViFYZAjIrfiiCkpEZcQ%26output%3Dtxt%26gid%3D0%26range%3Dkml_output%26time1%3D3973602&ie=UTF8&t=h&s=AARTsJqpNOS5c0kwFks2rUC01adNpmMpwQ&ll=-2.196727,123.310547&spn=30.377465,41.308594&z=4&output=embed"></iframe>
    <small>View Larger Map</small>

    Anyone have any solutions?

    #279342

    vivianpaige
    Member

    If the site in your user name is the one you are trying to post the map in, I’m afraid you are in the wrong forum. If you do have a blog here at wordpress.COM, please provide a link to it.

    #279351

    Sorry, the blog is at http://forest4climate.wordpress.com.

    #279361

    vivianpaige
    Member

    Thanks! I just tried using that same code on my test blog and you are right – it doesn’t work. I wonder if it has something to do with it having been generated using the spreadsheet mapper. There is nothing about using that in the FAQ http://faq.wordpress.com/2008/07/03/using-google-maps/ which makes me think that is the problem.

    Have you tried just using the straight Google Maps feature without the spreadsheet thing?

    #279362

    raincoaster
    Member

    Oooh, I hope this gets resolved. I’m going to have to be using this at my job soon and it would be great to be able to post it straight to a blog.

    #279375

    I haven’t tried a straight map embed, but this is actually a Google Earth layer (which is why I’m using the spreadsheet to make life easy for myself!) rendered as a map. I suspect it is the spreadsheet causing the problem for some reason – are there any moderators/WP staff who can shed some light on this?

    #279654

    fabiot
    Member

    I have the same result with

    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://maps.google.com/maps?f=q&hl=en&geocode=&q=Via+Massimo+D'Azeglio,+Bologna+Bologna,+Emilia-Romagna,+Italy&sll=45.154927,16.468506&sspn=2.746389,4.943848&g=Via+Massimo+D'Azeglio,+Bologna+Bologna,+Emilia-Romagna,+Italy&ie=UTF8&z=14&iwloc=addr&ll=44.498036,11.345358&output=embed&s=AARTsJo_Qx2-BXoGxKoDKx6uGPo1mfmi_A"></iframe>
    <small>View Larger Map</small>

    Nothing changes if I ask google for a API key for my blog.

    Blog name: http://christmascarolsbo.wordpress.com/
    google api ky for http://christmascarolsbo.wordpress.com/ : ABQIAAAASVZO4R-hRajxVcBnasXT3RTMtidnJOm6mZ1NGmdetJFuzvY4WRQrxS1zMoKGk22doEWUwc6VTAxWBw

    It should work if you substitute the string s=… with the key I retrieved from google

    #279658

    hepu
    Member

    Really annoying… I have the same issue with :

    ‘<iframe width=”425″ height=”350″ frameborder=”0″ scrolling=”no” marginheight=”0″ marginwidth=”0″ src=”http://maps.google.com/maps/ms?ie=UTF8&hl=fi&msa=0&msid=102643833412078836025.00045315c77e3178e1119&ll=13.743427,100.49377&spn=23.875,57.630033&output=embed&s=AARTsJqT_EC6B0VzFuKhCXL6oSrwNQeyWA”></iframe>
    <small>Näytä suurempi kartta</small>’

    I have succesfully used google maps in my blog before! Wonder what has changed… Please help!

    #279659

    @hepu: You cannot use iframe codes in WP.com. Copy the “src” part of the code (from “http” to “…NQeyWA”) and paste it in your html post editor this way:
    [googlemaps THAT_PART_HERE&w=300&h=300]

    #279660

    hepu
    Member

    Thank you! :)

    #279661

    asiesudest
    Member

    Actually. I tried using the last suggested solution and it doesn’t work !

    #279662

    @asiesudest: You could paste the code here so we can see.

    #279663

    luovotsi
    Member

    Hi everyone,
    I’m trying to embed a map in my blog and the best result I got is this:

    Google Error

    Forbidden
    Your client does not have permission to get URL /maps?f=q&source=s_q&hl=it&geocode=&q=associazione%20teatrale%20l%5C’uovo%20onlus%20l%5C’aquila&sll=37.0625,-95.677068&sspn=29.358024,56.601563&ie=UTF8&cd=1&ll=42.359432,13.401775&spn=0.006676,0.021973&z=14&

    First I followed these instructions http://support.wordpress.com/google-maps/
    Then I did what panaghiotisadam said ([googlemaps THAT_PART_HERE&w=300&h=300]) but nothing changed.

    If you think it could be useful I can paste the code I want to embed here.

    #279664

    It might be useful.

    #279665

    luovotsi
    Member

    The blog I’m referring to is http://uovoufficiostampa.wordpress.com (the page where I want to embed the map is still a draft).

    The code of my map is:
    <iframe width=”425″ height=”350″ frameborder=”0″ scrolling=”no” marginheight=”0″ marginwidth=”0″ src=”http://maps.google.com/maps?f=q&source=s_q&hl=it&geocode=&q=associazione+teatrale+l’uovo+onlus+l’aquila&sll=37.0625,-95.677068&sspn=45.418852,114.257812&ie=UTF8&ll=42.359178,13.401775&spn=0.010403,0.036049&z=14&iwloc=A&cid=42350180,13397580,16185121495850122354&output=embed&s=AARTsJqS9TImAckBTJkG5RYfFuex18VM3Q”></iframe>
    <small>Visualizzazione ingrandita della mappa</small>

    I just used this part:
    http://maps.google.com/maps?f=q&source=s_q&hl=it&geocode=&q=associazione+teatrale+l'uovo+onlus+l'aquila&sll=37.0625,-95.677068&sspn=45.418852,114.257812&ie=UTF8&ll=42.359178,13.401775&spn=0.010403,0.036049&z=14&iwloc=A&cid=42350180,13397580,16185121495850122354&output=embed&s=AARTsJqS9TImAckBTJkG5RYfFuex18VM3Q

    putting it in this “code” [googlemaps THAT_PART_HERE&w=300&h=300]

    #279666

    andrebonfim
    Member

    Hello guys, I see that many of you are having problems in embeding Google Maps.

    First, the way the FAQ says, does not work, if you copy the embed cod from google, it does not change as it does with youtube embed code.

    By trying to cheat the code by adding [googlemaps http...], earlier today, worked out with a personal mymaps, but later, it just does not work anymore, and and I have a preview of the page, in the place of the map it shows my own page, with a “Ooooops! Erro 404 :(” error message.

    The code is:
    <iframe width=”425″ height=”350″ frameborder=”0″ scrolling=”no” marginheight=”0″ marginwidth=”0″ src=”http://maps.google.com/maps/ms?hl=pt-BR&ptab=2&ie=UTF8&oe=UTF8&msa=0&msid=107834577013496409128.00046428ede3698e56fbd&ll=-14.956094,65.566406&spn=57.503,-135.351563&output=embed&s=AARTsJo1WAlew0mZ_xyBhqsCQw4rurmtVw”></iframe>
    <small>Exibir mapa ampliado</small>

    Thanks all for the support. Cheers!!

    #279667

    @andrebonfim: Well in my test blog the map shows up alright if you follow the suggestion I made in my first post above, i.e. if you paste this in the html editor:

    [googlemaps http://maps.google.com/maps/ms?hl=pt-BR&ptab=2&ie=UTF8&oe=UTF8&msa=0&msid=107834577013496409128.00046428ede3698e56fbd&ll=-14.956094,65.566406&spn=57.503,-135.351563&output=embed&s=AARTsJo1WAlew0mZ_xyBhqsCQw4rurmtVw&w=425&h=350]

    #279668

    andrebonfim
    Member

    @panaghiotisadam: thanks for the code, but it still not showing up.

    please, have a look at http://andrebonfim.wordpress.com/mapa/

    the first one is the shortcode I’ve made myself, and the second one, the code you wrote above. Both keep with the same error message.

    It’s freakin weird, cause in a first moment it worked pretty well, but now, the map just don’t show up.

    Maybe is there sometinh wrong with the google mymaps link? I’ve tried averything but nothing works.

    Thanks

    #279669

    I looked at the source code of your post, and what you’ve got there is not what you should have. Apparently you copied the code from my previous post and pasted it in the visual editor (which won’t work because the code registers as a live link here, so you’re actually copying and pasting extra stuff): you must paste it in the html editor.

    #279670

    galois
    Member

The topic ‘Problem using Google Maps’ is closed to new replies.