Need help? Check out our Support site, then

problem with image widget

  1. Hi
    I put an image as a widget, put when i go on my blogue, it show a little square with "? " on it,
    what did i did wrong?


    The blog I need help with is

  2. Hi,
    Do these help?

    You ought to be able to upload files in two ways: by going to Media → Add New from your dashboard or by clicking the new Add Media button right above the editing area of a page or a post.

    For troubleshooting see

  3. momslooking2save

    I'm having the same problem..... I've read everything on the suggested links, but the widget still shows a square... My image size is 300 by 450. Should I scale the image down further? Any suggestions on size. I would REALLY appreciate any help!!!

    If you need to look at my blog in order to suggest anything, here is my blog info.

  4. @momslooking2save: The Image widget requires pasting the URL of an image. Image URLs end with the filetype suffix (.jpg or .png etc). You didn't use such an URL, you used a shortlink. And again it's the shortlink for an attachment page. When you upload an image via Media > Add New, you copy the File URL. This is the URL you need:
    Ideally you should first downsize the to the right width for the sidebar (200px in the theme you're using), then upload it and copy its URL.

  5. momslooking2save

    @Justpi: Thank you so much! I REALLY appreciate your help! I am going to try it tomorrow and let you know!!!

  6. momslooking2save

    I got it!!! Thanks so much!!! I'm new to this so I'm sure I will posting more questions!!

  7. Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Topic