Problem with LaTeX in some posts

  • Author
    Posts
  • #418861

    richg74
    Member

    I’m having a puzzling problem including a LaTeX equation in a post. I have it in a sample post (HTML below), and it works fine. I cut and paste the ‘$latex … $’ portion into another, longer draft, and I get “Formula does not parse”. If I then cut and paste it from the second post (where it didn’t work) back into the first (where it did), it works again.

    Here’s the complete first post:

    Here is some text stuff:
    $latex s = \sqrt{ \frac{\sum_{i=1}^n (x_i - \bar{x})^2}{n-1} } $
    Some more stuff
    $latex s = \sqrt{ \frac{\sum_{i=1}^n (x_i - \bar{x})^2}{n-1} } $

    Does anyone have any suggestions about what might cause this?

    The blog I need help with is richg74.wordpress.com.

    #418996

    rchsbowman
    Member

    This isn’t gonna help. I copied and pasted your code in a new post. It worked perfectly. I opened an older post of mine with LaTeX codes and pasted your code, and it worked perfectly. There is nothing wrong with the code… I’m sure you already knew that. I did change the \frac to \dfrac and I liked the larger fraction better.
    I wished when I used LaTex, it didn’t look so out of place with the rest of my posts.

    Regards,

    #418998

    raincoaster
    Member

    rich, we can’t give you specific guidance without a link to your blog, starting with http.

    #419038

    richg74
    Member

    Sorry, the posting form asked for the blog URL, and I supplied it. Didn’t realize it wouldn’t show up with the post. Anyway, here it is:

    http://richg74.wordpress.com/

    #419250

    letsplaymath
    Member

    One thing I have noticed is that sometimes WordPress strips the slashes from LaTex markup. (At least, that’s what happened to a draft I was working on today at http://letsplaymath.wordpress.com/) I think that whatever program they have watching out for javascript gets confused and interferes with the LaTex stuff.

    Once it was so bad that I had to go back through my archives and correct every post I’d ever used a fraction in. Frustrating! It hasn’t happened for quite awhile, but it hit me today with some parentheses…Hmm, I wonder if I need to look through my back posts again…

    #419252

    richg74
    Member

    Whatever the mechanism is that vets the content (perhaps the JavaScript check, as you said) seems to be pretty fragile. I tried taking a formula in a draft post that worked, and then edited it to put in a (deliberate) error. It failed to parse, no surprise there. But when I went back and removed the error (3 characters), it still didn’t work.

The topic ‘Problem with LaTeX in some posts’ is closed to new replies.