problem with "Older Posts" button

  • Author
    Posts
  • #1426004

    solosocial
    Member

    When I click-on the “Older Posts” button on my blog–nothing happens, the older posts don’t load. Please advise.

    Thank you,
    Scott Mayo

    #1426082

    justjennifer
    Moderator

    I just looked at your site using both Chrome 29 and FF 23 and the Older Posts button loaded, well, older posts.

    Are you using an up-to-date browser? Do you have javascript and 3rd party cookies enabled? (See here: http://en.support.wordpress.com/browser-issues/ )

    If you need to update your browser, you can do so via http://browsehappy.com/

    #1426085

    lokerzhao
    Member

    I’m using Chrome 29 on windows7. Unfortunately, not working…

    #1426086

    lokerzhao
    Member

    To be honest, I kinda miss the old “link” to older post pages rather than this older post “button”(using Ajax maybe)…^_^

    #1426103

    justjennifer
    Moderator

    Did you try the other suggestions in the support doc, including logging out, deleting your browser cache and cookies, shutting down your browser and then opening it again and logging in?

    Could you also try with a different browser (FF, for example) and see if it works for you?

    #1426166

    maximeyocks
    Member

    I am having the same issue regardless of the browser.

    #1426167

    timethief
    Member

    I don’t have an issue with either blog loading older posts using Firefox 23.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm

    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    http://en.support.wordpress.com/third-party-cookies/

    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) And what any error reports you receive state.

    #1426168

    justjennifer
    Moderator

    @lokerzhao- it took three tries for me on newtabblog.wordpress.com so I’ll go ahead and mark this for Staff assistance.

    #1426169

    justjennifer
    Moderator

    @maximeyocks – no problem on your site for me in Chrome 29. Will test in FF23 as well. No, everything loaded as expected.

    Please try the suggestions given above.

    #1426178

    maximeyocks
    Member

    @justjennifer. The site is actually healthyapa.wordpress.com, but now I see both won’t work and the older posts link works from my iPhone (ios up to date). I have done ALL of the listed items above and still to no avail on either IE 10 or Chrome 29. Pardon my non-techiness.

    #1426187

    lokerzhao
    Member

    @justjennifer @timethief – really appreciate your help.

    1: I’m currently in Mainland China, because of some “awful” Internet restriction, I have to use a web proxy to access wordpress.com. So, is there any chance that the proxy is the root cause?

    2: Can i turn off this “one-page” loading technique, switch back to classic “links” to older pages? I mean, visit older pages on another web page, not on the same page.

    #1426199

    kraftbj
    Staff

    Howdy all,

    There are a couple of common causes for something like the older posts link to fail—a Javascript error or a connection issue.

    @lokerzhao — it is possible that it is an issue with the proxy you’re using to connect to WordPress.com, though let’s see if we can confirm that it isn’t a Javascript issue first.

    @all — First, can you try to clear your browser’s cache and try again? If your cache has either a corrupted version of one of the js files or an outdated one, it can throw an error that would kill all js processing that comes after the failed line of code. ( instructions )

    If that doesn’t resolve the issue, please visit your browser’s error console and copy/paste any errors located there. In Internet Explorer, you can press F12 to load the web tools, then click the Console tab. In Chrome, you can right-click on a page and click on Inspect Element, then click on the Console tab.

    Thanks all for your patience.

    #1426206

    lokerzhao
    Member

    @kraftbj, thx for your help.
    I have cleared all the cookies and restart the Chrome, the issue still exists.
    Here is the console error, after clicking the button:
    GET http://newtabblog.wordpress.com/?infinity=scrolling&action=infinite_scroll&…5D=false&query_args%5Border%5D=DESC&last_post_date=2013-09-05+16%3A56%3A59 500 (OK)

    Here is the snapshot: http://d.pr/i/MNUb

    and all error in TXT file:
    https://docs.google.com/file/d/0B8lT8VWswa3IZG40SGdaXzhzblU/edit

    or:
    http://pastebin.com/z1Lmb9Bn

    #1426207

    lokerzhao
    Member

    sorry about the bad formatting of last reply…
    but I can’t find the “edit post” button…

    #1426208

    justjennifer
    Moderator

    @lokerzhao- I just revisited your page in Chrome 29 and this time the Older Posts button worked on first click.

    There should be a way to turn off the new button if you have footer widgets, which you do. Go to Dashboard>Settings>Reading and there you’ll see “To infinity and beyond“. Uncheck the box if checked and save your settings.

    #1426213

    kraftbj
    Staff

    @justjennifer – With footer widgets, infinite scroll is disabled (where the posts autoload when the visitor scrolls down). The ajax-based button is the alternative.

    @lokerzhao – We’re investigating further. Thanks for your patience.

    #1426214

    maximeyocks
    Member

    I have restored IE10 completely (using only one browser right now as this issue is on all browsers), and this is the error I received for loading Older Posts for healthyapa.wordpress.com.
    CSS3117: @font-face failed cross-origin request. Resource access is restricted.
    noticons-regular-webfont.eot

    #1426215

    kraftbj
    Staff

    Thanks. Could you also run a traceroute to s0.wp.com.

    The CSS error wouldn’t impact loading additional posts. Since it is happening on all browsers and with the relatively low number of tickets about this, the idea of a connection issue has some validity that I’d like to explore as well.

    I really appreciate your patience as we figure out what may be the cause and what we can do to improve this.

    Cheers!

    #1426217

    maximeyocks
    Member

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\SarahH>tracert s0.wp.com

    Tracing route to cs82.wac.edgecastcdn.net [72.21.91.111]
    over a maximum of 30 hops:

    1 <1 ms <1 ms <1 ms 192.168.102.1
    2 1 ms <1 ms <1 ms 71.216.191.46
    3 24 ms 60 ms 23 ms tukw-dsl-gw67.tukw.qwest.net [63.231.10.67]
    4 24 ms 24 ms 25 ms tukw-agw1.inet.qwest.net [71.217.186.17]
    5 24 ms 23 ms 24 ms sea-brdr-02.inet.qwest.net [67.14.41.18]
    6 28 ms 34 ms 28 ms sea-b1-link.telia.net [80.239.194.29]
    7 24 ms 25 ms 24 ms edgecast-ic-151890-sea-b1.c.telia.net [80.239.13
    5.134]
    8 23 ms 23 ms 24 ms 72.21.91.111

    Trace complete.

    C:\Users\SarahH>

    #1426218

    kraftbj
    Staff

    Thanks. I appreciate your patience as we continue to investigate.

The topic ‘problem with "Older Posts" button’ is closed to new replies.