Need help? Check out our Support site, then

Problem with one page not publishing - Error message: "Nothing Found"

  1. I have created a website (with static pages) using I have created 4 pages. On three of the pages the information I entered shows up just fine, but on the fourth page (Contact IMe:), it continues to show the error message "Nothing Found - It seems we can't find what you are looking for. Perhaps searching can help." I don't understand why the phone number and e-mail address which I entered (and show up on the dashboard edit page) are not appearing when the page is published. I have deleted the page and re-did it several times, but I continue to get the same error message. I created this page the same way I did the other pages. Can someone please show me or explain how I can get this last page published? Thank you.

    The blog I need help with is

  2. See this guide do you can make an actual contact form

    Then disable the comments on that page.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.

    We can also override the default settings and enable or disable future comments on any individual post or page.

    Note: By default, new blogs on will have the Discussion hidden. You can reveal it by clicking on Screen Options on the top right corner of your Admin page, and checking the box that says Discussion so the module is included.

Topic Closed

This topic has been closed to new replies.

About this Topic