Problem with pages

  • Author
  • #860127


    I make pages, but my blog only lets me post once on pages that I make. It only lets me continually post on my home page. Can someone help me figure this out please?



    Well, you’ve got it figured out. Pages are static and sit outside the blog structure. They are almost invisible to search engines.

    Posts are what make up a blog. Just make posts.




    Pages are static and are for content that rarely changes. They sit outside of the blog structure and you cannot post to multiple pages in any blog. There is only one main page for posts in a blog and all posts will show on the main blog page. There is no way to exclude posts from the main posts (blog) page.

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then create a static front page for your site and a “blog” page for posts.

    Choice 1 static front page.
    Choice 2 running page for all posts on front page.

    Which do you choose? It’s one or the other.

    If you choose Choice 1 static front page then you have to create two pages as I said above. After you do that you go to > Settings > Reading and make the designation change and click “save changes”.

    We organize our posts by assigning Categories to them. When we publish a post it automatically appears on the dynamic page for posts and also on the Categories pages. (Note: There must be one published post in each Category and/or Tag in order for there to be anything to display.)

    With a custom menu we can display Categories and drop-downs to sub-categories in tabs along the horizontal navigation where normally only Pages tabs are displayed. We can also include Pages and drop-downs to sub-pages, tabs and Custom links tabs in our custom menu as well.
    This may be helpful > Custom menu walk-through

The topic ‘Problem with pages’ is closed to new replies.