Need help? Check out our Support site, then

Problem with "paste" in visual editor: Bad cursor placement

  1. I thought I had posted this already, but I couldn't find it using the search function.

    Formerly, when pasting into the visual editor, the cursor was left at the end of the paste. Thus the next character typed would immediately follow the pasted matter. Now, for the past couple of weeks, the cursor following a paste is instead left at the beginning of the last paragraph of the pasted matter. For example, If I type


    and then paste the URL, the cursor is left preceding the "[", so that when it type "]" I get:

    ][youtube=<pasted url>

    This is highly unsatisfactory and strikes me as a bug. It is certainly not the paste behavior prior to a couple of weeks ago.

    Can we get a fix for this?

    The blog I need help with is

  2. I'm noticing this as well using Firefox.

  3. Strange that I can't find this post using the Search function (searching on "leisureguy" for example, or "problem with paste").

    But I did track it down, and it continues to be a problem. I wonder if there's a way to escalate this so that the bug can be fixed.

  4. I'm not seeing this problem myself.

    First, make sure that your browser is up to date by visiting

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these four things:

    1. Try clearing your browser's cache and cookies:

    2. Make sure that you have third-party cookies enabled:

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    Please let us know how each step goes for you, and which browser (and version of) you're using if you're still having trouble.

  5. Okay, here's my report:

    Browser is up to date: Firefox I updated, and Chrome updates itself.

    In Firefox:

    1. I cleared cache and cookies. Problem persists, so:

    2. I made sure third-party cookies were enabled, and they already were. Next:

    3. Only one add-on was enabled (LastPass), so I disabled it, restarted Firefox: problem persists. So:

    4. Went to enable https, found it was already enabled.

    Problem persists on both Firefox and Chrome browsers.

    Firefox is version 16.0.2

  6. Hm, I'm still unable to reproduce the issue in Firefox and Chrome.

    Are you saying that you type something, then copy something, then when you click in the box to paste it, the cursor appears at the beginning of the line instead of where you left off?

  7. Let's say I highlight you entire (two-paragraph) response and copy it. - I just did that. Now I go to the "new post" visual editor page, and in the the box, I paste the passage. - I just did that. And now the cursor is just before the "A" in "Are": i.e., at the beginning of the last paragraph.

    Another example is the one in my initial post, on copying and pasting a YouTube link. That is still happening.

  8. Hm, I'm not seeing this at all.

    Where are you clicking the post box, or are you not doing that and just pasting straight away?

  9. I click where I want the matter to be pasted if the cursor's not already there. In the youtube example, for example, after I type "[youtube=" the cursor's correctly placed, so I just page. On a quoted passage, though, I have to press enter, and then click the "blockquote" button, which places the cursor for pasting.

    I'm using OS X 10.8.2 on a MacBook Pro, if that makes a difference.

  10. I just tried it again on Chrome, and that worked. Apparently Firefox is the problem. I was sure it was doing it on Chrome earlier...

  11. Hm, I'm still unable to duplicate this in Firefox.

    Are you sure that you have disabled all add-ons?

  12. When I look at the list of add-ons, they're all disabled. (That is, the button to click is labeled "enable.") I'm wondering whether it might be an OS X Lion problem, unless that is what you also are using.

    I might just pull off my edit window from Chrome (as a separate window, so I easily switch between my Web sites and my editing---that's why I use Firefox) since Chrome seems now to have the bad behavior.

  13. I'm running OS X 10.8.2, which version are you running?

    Also, does Safari have the same problem?

  14. Aha. No, it doesn't, and that will be my solution. I'll use Safari in lieu of Firefox. Doesn't exactly solve the problem, but does solve my problem. :)

  15. At least that works for now. :)

    I'll continue to poke around with Firefox 16.0.2 to see if I can reproduce the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic