Problems editing blog

  • Author
  • #782081

    Does anyone know if are having technical difficulties?
    Since last night I have been unable to insert pictures in my blog, despite already having the pictures uploaded and in the “gallery” section.
    One of two things happens – when in gallery, I click on the image and then “show”, but the page doesn’t respond. Or I don’t even get this far – when editing the blog I click “insert an image” and the page freezes.

    This is not the first time this has happened to me – does anyone know when this will be fixed, or is it a problem my end?

    The blog I need help with is


    I am having the same problem. Nothing happens when I click on the “add media” button. Nothing happens when I tried to add links as well.
    Like you, OP, I would like to know if this is a wordpress issue or another thing all together.


    I’ve been mentioning this problem in the forums for weeks and have heard from hundreds of others experiencing the same issue but either WordPress don’t care or they are unable to fix it as I have heard nothing from them about it and it’s most certainly not fixed. I have to do about 10 page refreshes to get it working and then it’s not guaranteed.

    Start by clearing your cache. However, that is only a temp solution and after a few posts/edits it breaks again.

    It happens with the Add Media button, Add Tags, insert link etc… Basically anything that is calling scripts doesn’t work at all.



    I suspect this is a WordPress problem, and for me I think the best option is find myself a server and change to – it’s much more versatile, it’s open source, and I need a service that’s reliable.

    BUT before we all start screaming abuse at, we should also remember it’s a free service!


    I know it’s free but a free service that doesn’t work is as useful as a chocolate teapot ;-)


    Interesting that you have been having this problem for weeks realestatemarbella. I posted yesterday and had no problem. I am using a different computer today and now I have problems! Any other ideas besides clearing the cache?
    Very frustrating when you can’t publish a post because it needs pictures and links!


    I can’t even SEE my dashboad! My blog exists, because you can go to it and see it, but when I log in there appears to be no blog!


    thriftytravelmama – the problem started for me about a month ago but was intermittent to begin with, every third or fourth post I would have to refresh two or three times to activate everything.

    Then it started happening on every post (also noticed Stats summary on dashboard didn’t load – constant loading graphic). So I made my first comment in these forums and waited.

    Nothing – so posted again. By now it is killing me as a single post can take half an hour with all the faffing about with refreshes, copying content and reloading, try to add tags – button unresponsive, try to add media, button unresponsive.

    A good way to check, before you start writing a post is to hover over some of the menu items on the left. If there is a submenu (tools, posts, appearance) you should see it. However, if it isn’t there it means the scripts are not attached and nothing will work so refresh until the submenus work, then write your post.

    Another temp solution I found is to write it, title it and publish it. Then go back to Edit the post. Stuff usually works in Edit mode so you can then add your media, tags etc.

    Not ideal, it’s obviously broken, but will get you posting again.

    Hopefully SOMEONE FROM WORDPRESS will take a look into it.

    By the way, what browser are you using? I use Chrome but have tried in IE, Firefox and Opera and, after first few posts, the problem appears in them all.


    I’ve also noticed that the stats often don’t load, as you say, I get the WordPress logo going round and round – I have to refresh the page several times.
    I’m using Chrome, but have also tried it with IE and had the same problem. Someone suggested clearing the cache – maybe temporary files are somehow slowing things down.



    realestatemarbella wrote:

    I know it’s free but a free service that doesn’t work is as useful as a chocolate teapot ;-)

    You’re right, it doesn’t help very much, especially if you NEED the blog to work properly. Mine is all about an alien world, and has pictures of the creatures discovered etc. If I’m unable to post these pictures or edit them to a useful size, my blog loses so much of its impact.

    It’s a shame, because the interface is actually quite job, if they could just sort this out it would be great. Personally I don’t seem any alternative but to abandon .com and use .org to set up on a proper server. People say it’s easy to do but I’m not tech savvy. But everyone I know who knows more about this sort of things says the same – if you want to make it look good and work properly you need .org not .com



    Hello there,
    In order to isolate the cause of your issue in each case there’s a need for specific information. The way Staff determine a fix is to duplicate the issue so please provide your own specific details to Staff in support tickets. Here’s what they need to know the answers to:

    1. How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. It sounds like there could be a problem with your ISP. Can you access any of these directly?

    2. Are you using http:// or https:// see

    3.Which browser and version of it are you using?

    4. Have you tried clearing your browser cache and cookies?

    5. Is your browser version up to date? You can upgrade any browser version here.

    6. Do you have third party cookies enabled?

    7. Do you have JavaScript enabled?

    8. Do you have another browser you can try?

    9. You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.

    10. Have your tried resetting your router and modem?

    11. Have you had any recent operating system and/or security program updates?


    I have tried it all. If I may say I’m pretty sure it is a scripting problem or temp files issue within wordpress. I’ve tried it on multiple browsers, all up to date, and experienced the same issues. Also on multiple computers all with the same issue.

    The problem is not related to the connection either. The problem looks like a conflict of some sort with some javascript or jquery stuff.

    The simplest example of the problem is the submenus from the side bar. When you are on your dashboard and you hover over Posts on the sidebar a submenu should pop out. It doesn’t.

    The Stats summary on the homepage is permanently loading.

    When composing new post the icon to “Upload/Insert Media” is inactive.

    Adding tags to a new post – “Add” button is inactive.

    Top of screen “Help” and “Screen Options” slide-in menus – both tabs inactive.

    All of the above will work after multiple page refreshes but is not guaranteed and it can fix it with one refresh or it can take ten.

    Clearing the cache does fix it but only temporarily. Within two or three posts the problems return.

    Incidentally, it either works or it doesn’t. I haven’t experienced any one of the problems by themselves – it’s all or none.



    Are you using a Chrome browser?



    Yes, I have managed to access all 3 of the links. I am using http://, browser is the latest version of Chrome, which I have just updated via The cache has been cleared and cookies are enabled, and flash is up-to-date. The router has been reset several times.

    BUT I have just noticed that the problem has just this moment disappeared – I had just updated Chrome on and this seemed to be the solution.

    I had previously tried clearing the cache, which made no difference whatsoever. But for anyone else out there with this problem, try updating your browser, folks, on – it seems to have worked for me.

    Time will tell whether or not it’s a permanent solution. But it could well be a case of making sure everything’s up-to-date and “switched on” correctly. We need to remember that we’re using online software, which must mean lots of Java and Flash, all that stuff needs to be regularly updated along with the browser.

    Don’t lose hope folks, it looks like there is a solution out there!

    And thanks to timethief for helping.


    Thanks for your help, timethief. I’ll work through this list and see if I still have an issue.




    BUT I have just noticed that the problem has just this moment disappeared – I had just updated Chrome on and this seemed to be the solution.

    Great news! Thanks for sharing it here. You’re welcome and best wishes for problem free blogging. :)



    Thanks so much for being solution orientated.


    @timethief – yes, using Chrome as default browser but have experienced issues in IE, FireFox and Opera.

    This morning, in response to the above, I checked for updates (was up to date) and cleared cache.

    Problem solved for first post but problem returned on second post.

    Are we not all solution orientated? If not we wouldn’t be here trying to find a solution would we? I just can’t find the solution, not a permanent one anyway!



    How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    Are you using http:// or https:// see Have you tried switching from one to the other?



    im having problem editing my website ,i trying to log in through my
    website,,,,,,,,, and when i type my user name and
    pass its say the password is incorrect type your email to reset your password when i put my email they didnt send me anything,,,so when i log in throug everything work good my password and user name,but i change the
    theme ,and i try to add something and i saved and say that web was update ,,but
    when i go to the internet search bar and i type i dont see
    it any change ,,so pls help me to reset my web and start again because im payin
    my hostin on godaddy and i cant even use ,,thankss

The topic ‘Problems editing blog’ is closed to new replies.