Problems inserting photos into blog

  • Author
  • #531515


    I haven’t had any problems inserting my uploaded photos into my blog until today.

    I can see the photos in my media gallery and edit them with no problem.

    But when I push the “Insert into post” button, the browser thinks for a while, then I end up with a blank page. Before I used to go back to the blog post that I was writing and continue on. Now it seems to be hung up on a blank screen.

    I am using the latest version of Firefox.

    I tried cutting and pasting the html code for a photo from a previous post, and it showed up no problem in the one that I am currently editing. I even tried to substitute a new url path linking to a new photo, and it nearly showed up (not quite good enough at my coding skills).

    I also tried to upload a photo gallery of the shots that I had taken thinking that maybe one of my setting was wrong, and the automated photo gallery might work; but it didn’t work either.

    Here is the photo I’m trying to insert into a draft blog:
    The settings that I am using are:
    Title: Yukon Wilderness
    Caption: The Great Canadian Wilderness
    “file url” choice for the link url
    Alignment: large, center

    Then I click the “Insert into post”

    Then I get a blank page. I’m not returned to the post.

    What am I missing?

    The blog I need help with is


    I’m having a similar problem – trying to update my blog’s front page with a thumbnail image for the latest post (in exactly the same way as usual) when I click ‘insert into post’ , it just goes blank, whether I take the image from the media gallery or direct from the computer, whichever photo. Tried deleting and uploading them again, without success.

    This has been a problem for over a week now, and I’d really like to be able to update the page on

    I’d be grateful for any ideas?



    Love your artwork daughtersofearth!

    I came across one possibility in my search:
    which seems to indicate that the internet service provider itself can cache info, in which case you have to wait for it to unchache.

    I’ve also discovered by searching these forums, that this exact thing happened in 2008, which resolved itself after a number of weeks…. so possibly this is what is happening.

    Anyone else having a problem posting images?



    If you have a flickr/picasa account, you can use the embedding code they provide, and copy/paste that into your post. It adds the picture, and doesnt take up any space on your WordPress account.



    Thanks tenophilia! That is certainly a useful piece of information. Since I am a newbie user, I’ve got tons of free room left in my account. When it fills up, I’ll certainly take your advice!

    Still seeking info on how to post a photo into my blog from my gallery. Is this problem wordpress? Or is it me?



    I’ve been posting images for the past several hours without problem.

    A question: What browser are you using? Have you updated the Flash plugin recently?

    Some suggestions: log out of entirely. Clear your browser’s cache and cookies and then log back in.



    Hi justjennifer:

    I followed your suggestions.

    It worked! I can post images again. I think the log-out, log-in was the trick.

    Thanks a bunch!


    Thanks for your kind words, mystressm, and for pursuing these suggestions. I’ve just tried the log-out, log-in, combined with emptying the cache, resetting Safari and restarting my computer – but unfortunately no success – I still can’t post an image on my main page, and now I can’t edit the text either – bold and italic buttons don’t work.

    I’ve sent a message to wordpress support but haven’t heard anything back yet.

    What seems so odd is that I’ve quite successfully added 30 thumbnail images to this page, without any problems. Is there a limit to the number of images per page? I’ve got lots of free space and haven’t had any problems before.

    I really need to be able to update, so if anyone has any other ideas, I’d be very grateful.



    @daughtersofearth Did you try what I suggested to mystressm in my last post just above hers?



    Hi Daughtersofearth:

    I am using Firefox, which is the preferred recommended browser for this site. My Firefox plugins were current, but my javascript wasn’t. I did update that. Why don’t you see if ANYTHING in you computer needs updating?

    Why don’t you test to see if it is your computer/browser by trying to update your blog from a different computer?

    Another suggestion: Download Firefox and try that as an alternative browser.

    I don’t think there is much of a limit on images, as I’ve just uploaded 40 of them via a gallery into one blog.

    I sent a message to wordpress support yesterday, and haven’t heard back from them yet either.

    Good luck! I know how maddening it is! I spent 4 hours yesterday trying to figure it out!


    Thank you both very much – I have updated everything, browser, Javascript and everything else on offer, and at last, success. What a relief.

    Thanks again, you were a great help.



    This post contains several troubleshooting techniques that can be used to solve such problems. Blogging and Troubleshooting

The topic ‘Problems inserting photos into blog’ is closed to new replies.