Problems uploading images, .doc and . pdf files

  • Author
  • #517139


    I have been trying for the last 24 hours to upload documents to my site. I can upload an actual picture (.jpeg or other extension), but when I try to upload .pdf files or Word files, the upload process seems to be normal, I select no link, but what I get is just the name of the file, but no image.

    This is happening on all my blogs, to include one that has a different template.

    I’m a new user, but this seems to be a straightforward process, which is not working.

    Also, when I tried to drag Press This to my ?? bar (too tried to remember what to call it), it just didn’t work. I finally saved it to my favorites, then was able to drag the icon to the top bar from favorites.

    This should be easier. Any help is appreciated!

    The blog I need help with is


    PDF’s and Word documents will not display in the blog. When you insert them, you have to select “link” and then it will put a link to that file in the post or page.

    If you want an image to be the link, then you have to insert the image, but before clicking the “insert into post” button, put the URL to the document in the “file URL” field. Then insert the image. It will then link to the PDF or doc file.



    Hello, thesacredpath.

    Where have you been, lo, these last three days? Without you, I have stumbled on in the darkness, nearly pulling my hair out!

    I just followed your instructions (which are better than those in “WordPress for Dummies”) and figured out how I can proceed with getting my WordPress site up.

    Thanks a million! I’m going to have about four WordPress blogs ‘ere long, and the future projects should be a snap compared to this “Alice in Wonderland” venture I’ve just gone through.

    Warm regards,

    Judy Barrett
    Santa Fe, NM


    Judy, you are welcome. This last weekend I was exploring Mauna Kea on Hawaii Island, and then after coming back I took it easy for three days.

The topic ‘Problems uploading images, .doc and . pdf files’ is closed to new replies.