Problems with landing page & blog posts

  • Author
  • #1245808


    I’ve tried to follow the instructions but it’s not working for me. :(

    I want my About page to be my landing page. This I can do. My posts page (now named ‘Blog’) is seen in the menu, but if I click on it I arrive on the About page again. Obviously I need to click on ‘Blog’ and arrive on my posts page.

    For the moment I have put things back to the Blog posts being my landing (home) page but I don’t want to leave it like this.

    Can anyone help? Thank you so much. :)

    The blog I need help with is



    Please be sure you fully understand the differences between Pages and Posts.

    The front page of the blog by default will display all of your published posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts.

    To do that create two pages > After you do that you go to > Settings > Reading and make the designation change and click “save changes”.

    Front page displays
    __ Your latest posts

    A static page (select below)
    Front page:
    Posts page:



    Thank you for your reply. Yes I understand about the difference – Posts V. Page.

    As I already have a lot of posts (renamed as ‘Blog’) I don’t want to be creating a brand new ‘posts’. To do this, correct me if I’m wrong, surely it would mean I’d lose all my posts to date?

    I made my About page my static page which worked fine. But I could not select ‘Blog’ as the ‘Posts page’ shown in your drop down box indicated in your reply. ‘Blog’ however still showed in my menu and when I clicked on it, strangely it took me to the About page. Therefore my posts were nowhere to be seen so I had to change the settings back to what they were.

    From what you say, it seems to me that unless I create a new ‘Posts’ I can’t use ‘About’ as my static landing page? If I do this it seems I’d have to lose my original Posts (now named ‘Blog’)?

    Thank you for any further clarification.


    I’m having a similar problem. I want to use wordpress as both my site (several pages) and my blog. I want a MENU link to a blog “landing page” so that when you click “BLOG” from my menu you get to a blog page with my most recent post. I obviously can’t link to an individual post because that will get old. Is there something along the lines of “/blog_index.html” that I could use as a link to my blog from the menu? (and from anywhere else that I want to create a link to my blog?)


    SORRY! I found it / figured it out!! Not sure if this is helpful with your problem, but the specific instructions are:

    1. Create a PAGE called “blog” (or whatever)
    2. Go to Settings –> Reading
    3. Front Page Displays: Check “A static page”
    4. Front Page (pull down menu) Select your “About Page”
    5. Posts Page: Select the new BLOG page you just created.

    I hope this helped.



    No, unfortunately not. That’s what the other contributor suggested but I’d already tried it and I can’t make it work without losing all my existing posts. :( Glad you’ve got yours sorted.



    Timethief’s and hellowellsdigital’s suggestion is correct, and what’s confusing you is your mistaken menu.

    Each post is self-contained and has its own URL, for example:
    There’s no way to “lose your posts” other than deleting them in Posts > All Posts.

    And you don’t create your main posts page in Appearance > Menus. Appearance > Menus is the place where you create menus only, i.e. groups of links to already existing items.

    So, first you go to Pages > Add New and publish a blank page titled “Blog”. Then you follow hellowellsdigital’s steps 2-5 (plus scroll down and click Save Changes, of course).
    Then you go to Appearance > Menus, delete the “About” and “Blog” items you have added, open the Pages module, click View All, select “Home:About” and “Blog”, click Add to menu, drag the newly added items to reposition them, click Save menu.



    Thank you for trying to help, and I have tried once again to remedy this using your step-by-step instructions, but sadly the result is the same… that is, the About page becomes my static landing page and whilst my posts (named Blog) appear in the menu sidebar, when I click on it, I’m directed to the About page, not my ‘posts’.

    I’ve now deleted the additional Blog page I’d created and put everything back to how it was.



    the About page becomes my static landing page and whilst my posts (named Blog) appear in the menu sidebar, when I click on it, I’m directed to the About page, not my ‘posts’.

    This means you didn’t follow the second part of my instructions but retained your original “Blog” item in your custom menu. That item is a link to your blog front, not to the “Blog” page you should have created and set as your posts page in Settings > Reading.



    Aaah thank you! I didn’t realise you meant delete the Blog (custom) – I thought you meant delete the one I’d just created. It’s working now. You’re a diamond… it’s driven me round the bend for days! LOL :)


    Thanks to Hellowellsdigital! Your instructions helped quite a bit!



    Thanks Aliceh for asking this question – I’m doing the same thing right now.

    And thanks to all who chimed in with advice.

    The feedback here was great and I’m up and running!

    Happy blogging, all ~p

The topic ‘Problems with landing page & blog posts’ is closed to new replies.