Problems with the "Add Media" centre

  • Author
  • #1090359

    Pictures upload fine, but “inserting” them into my post doesn’t even happen. They don’t appear at all. I have to insert them manually using the file URL and HTML coding. Not an ideal and convenient way to do things. Same goes with youtube videos.

    Web Browser Chrome 23.0.1271.95

    The blog I need help with is



    Hi campaignofshockandawe – I’m going to create a test draft post on your site to check this.

    Regarding this:

    Same goes with youtube videos.

    Could you please describe how you’re going about adding YouTube videos, step by step? If you have a post where you’ve pasted a YouTube link but it’s not displaying, could you please give me the link so I can investigate? Thanks.


    – Start up a new post.
    – Click the “add media” button.
    – click “insert from URL”.
    – copy-and-paste url of Youtube video, click “insert into post” button
    – “add media” window disappears, but nothing is added to my post draft



    Those are not the correct instructions for adding YouTube videos. :-)

    “Insert from URL” is only to be used when inserting a graphic that happens to be hosted on another site. For example, a URL like this:

    The Add Media button is not used to embed YouTube videos. Instructions for embedding YouTube videos are here:

    I also added a draft post (#3) to your site with an example so you can have a look.



    I created two draft posts on your site (#1 & #2) with images that I added through Chrome 23 – the first one was added from your Media Library, and the second was added by uploading it from my hard drive.

    Could you please let me know the steps you’re taking to insert images so I can see where things are going awry? Thanks a lot!



    Ahhhh, see, I was never aware that the change in media posting meant a change to how youtube links are posted. Guess that explains that. Thank you for pointing that out to me.

    The method by which I post images are as follows
    – Click the “add media” button.
    – I then opt to upload files from my computer using a drag-and-drop method.
    – File uploads, I see it in the media library. I select it from said library, press the “insert into post” button.
    – Picture does not appear in the post draft.



    Thanks for the steps. I will test your drag-and-drop method now.

    If you choose an image from your computer by navigating to the file, does it work?



    I just tested the drag-and-drop method on your site in another test post and it worked fine for me. Could you please provide a link to a post (even if it’s a draft) where you tried to drag-and-drop insert an image and it didn’t appear so I can take a look? Thanks!


    Navigating to the file does not appear to work.

    Also, I’ve discovered that click the “delete” option for a picture does not work. There is no response to that action.

    There is a draft in the post-queue entitled “Test title” in which I just made my last effort.



    Thanks for testing this. Would you mind trying a few things now?

    Please clear your browser’s cache and cookies:

    If that doesn’t work, could you please try deactivating all Chrome add-ons and extensions and see if that helps?

    Temporarily disable extensions

    • Click the Chrome menu Chrome menu on the browser toolbar.
      Select Tools.
    • Select Extensions.
    • On the Extensions page, click Disable (or uncheck Enable) for all extensions you’d like to temporarily remove.

    If that doesn’t work, could you please try a different browser, like Firefox or Safari, and let me know if it works.

    If you have a different computer with Chrome, would you mind letting me know if it works there.


    Clearing cache and cookies didn’t work.

    HOWEVER…disabling my extensions in Chrome allowed me to insert a photo into my draft no problem. As did using Safari. So it would seem that one of my extensions may be the culprit. What do you think?



    Thanks for testing this. It does sound like one of your extensions may be the culprit. To determine which one, you can try reactivating them one by one, testing an image upload in between each change, until you isolate the extension causing the problem. If you figure out which one it is, I’d be grateful if you would let me know.


    So, I believe I’ve discovered the culprit: “Better Pop Up Blocker 2.1.6”

    I don’t know how this happened (an oversight on my part probably), but but this post editing page on the blog was somehow removed from the “whitelist” of this pop-up blocker extension of mine. Adding it cleared up the problem.

    So, I apologize for taking up so much of your time with a simple mistake from my end. Your help in al this was much appreciated.



    Thanks for letting me know the culprit, glad you sorted it out!

    I’m going to close this thread now, but if you encounter further issues, feel free to start a new one.

The topic ‘Problems with the "Add Media" centre’ is closed to new replies.