Need help? Check out our Support site, then

Protected Blog: I own it, but can't read it in my main browser

  1. I'm creating a Web site in WordPress and have marked it private while I'm working on it. I successfully connected it to a domain I got through NSI, including email.

    In Firefox (my main browser): When I click View Page or try to go right to the site using the domain name, I get the Protected Blog login page. If I log in, the page simply redisplays.

    In Safari: It works fine.

    I can edit the pages going through the dashboard, but the Edit link is missing from the pages.

    It was fine until I connected the domain name. Browser problem? NSI/WordPress problem? Suggestions?


    The blog I need help with is

  2. I am not seeing any upgrades on Is this the site you need help with? If it is one of your other sites, can you let me know which one?

  3. is the site. It's marked private for now.


  4. So when you go to log in using firefox, you are just seeing the login page pop up again with no error message or anything? Are you entering your login info manually or are you using browser "remembered" info that is pre-filled in?

    What happens if you log in at first and then go to

  5. Question 1: yes.

    Just to be clear, it's the login page that says " is marked private by its owner. If you were invited to view this site, please log in below. Read more about privacy settings.".

    I type my login information (Firefox doesn't put in my username, and I overrode the password to be sure). And then the page redisplays. The username and password fields are erased and there's no error message. (If I type junk into the fields, I get that nice head-shaking thing, so that's working.)

    Question 2:

    I clicked the WordPress logo, which took me to my home page. I clicked Sign Out under my photo, and logged in at the WordPress home page, then typed in the address bar. It took me to the login page, and the same sequence happened.

    Then I realized I probably shouldn't have this forum page open, because I'm logged in here. So I closed it, and tried this all again. This time, a slight change: When I type in the URL and log in, the page redisplays WITH the username and password remaining in the text fields.

    I tried clearing all WordPress cookies, but it didn't help. It's odd that it works in Safari, but not Firefox.

    What's next?


  6. Hi, Sounds like a problem with 3rd party cookies being blocked. Can you make sure they are allowed for the domain? See

  7. Perfect. Thanks so much for your help

Topic Closed

This topic has been closed to new replies.

About this Topic