Publicising new blogs with Twitter

  • Author
  • #1042884

    I’ve recently noticed that when I publish a new blog post, the automatic Twitter notification goes out with the right text, but below it in my timeline it says “View photo” rather than “View media”, and if I click on that it expands to a badly formatted snippet with someone else’s name and Twitter account attached to it.

    I’m not sure if this is something that’s set up wrong, or what, but the tweets are going out from my Twitter account, so I’m not sure why this is going wrong.

    The blog I need help with is



    That’s strange and I have flagged this thread for Staff assistance.


    I’ve taken a screenshot in case it would help, but the name and Twitter account is my wife’s. I’m signed into both WordPress and Twitter, so I’m not sure how this is happening.


    I tested by publicising an old post and that worked fine, but trying to publicise my last one through different routes (copying the link into a tweet, or using the WP app on my phone) gave me the same problem as yesterday. Seems to be a problem with posts, but don’t really want to investigate further until I’ve got more of an idea of what’s going on.

    Screenshot is here.


    6 days on from the initial post (as it’s Sunday today, it looks like a full week’s on the cards), no response at all, and I’ve since published another couple of posts which I’ve been unable to publicise because the details were all completely wrong when posted on Twitter. Has this fallen down the memory hole or something?

    I’d have thought this would be a pretty serious priority, and that someone would at least have posted to say it’s being investigated or update on progress, so I’m surprised that it’s just gone quiet. If you don’t know how to resolve this, or can’t be bothered, just tell me and I’ll move my blog to another platform. I can’t run the risk of my personal ramblings being associated with my wife’s professional identity.


    Looks like I have to do all my own investigation! Some basic testing indicates that this appears to have been going on for many months. I just verified that a post from May (before my wife started her own WordPress blog) shows up in the same way, which knocks down the only working hypothesis I had left. So I give up.

    My blog is now on hold until there’s some way of publicising it without entirely wrong details being associated with it. It’s a shame, because I had lots of things I wanted to write about, but I’ll devote the time I would have spent writing content to finding a platform that won’t cause problems for both of us by mixing up identities like this. I don’t want the hassle, but as I don’t know where else this could be happening, it looks like it’s the only option left.

    I find it quite incredible that this could happen, and even more incredible that this problem could go 9 days with not only no resolution but no response of any kind. I suppose that’s my fault for believing that anyone would bother to fix an obviously broken system.


    Although timethief says she has flagged this for staff, there is no ‘modlook’ tag on this thread, which is probably why you have not had any assistance from staff! Add modlook to your tags on the right.


    Thank you. I’ll give that a go.



    Indeed redsoulnights is correct. I most certainly did place a modlook tag in the sidebar. i clearly recall doing so and I’m so sorry it was removed and Staff have not responded to you as yet.



    The name is unfortunately cached on Twitter’s end, and we have no control over that.

    First, reconnect with Twitter following this guide:

    That will “fix” the issue, but I can’t say when Twitter will refresh their cache to show the correct name.


    Thanks. I’ll give that a go.



    You’re welcome!


    I disconnected from Twitter as instructed, I cleared my cache, reconnected, and nothing changed. I did it several times. Since then, I’ve disconnected, cleared cache, left it for days, reconnected, and I’m still getting exactly the same thing.

    I’ve raised the fault with Twitter, who say it’s a WordPress problem and nothing to do with them.

    I’ve also discovered that I don’t have to be publicising with any app or widget or anything like that – if I shorten the address of a post (with, for example) and tweet that shortened URL, it still appears with the wrong details attached. That suggests to me that the problem lies with the wrong information being held by WordPress on the post details, but I may be wrong, as I’m finding all of this both baffling and deeply frustrating.


    Using a new dummy Twitter account to “publicise” a few posts in turn to an audience of 0 (having disconnected every possible connection to Twitter from my proper account), I’ve discovered that some posts appear with the same error as described above, and some appear as expected. Running through the first 8 posts I made, they appear as follows:

    There and back again? (12/11/11)
    In remembrance of things past (13/11/11)
    Rise and fall of the human empire (23/11/11)
    I ain’t afraid of no Holy Ghost (26/11/11)
    Secularism, Freedom and Indoctrination (1/12/11)
    Distinctiveness of Christianity (4/12/11)

    The Oddity of Theodicy (15/11/11)
    Management is a holy calling (19/11/11)

    The only possible explanation for this, as far as I can see, is that something has been attached to some of these posts and not the others. I have no idea what that could be, or how it happened, but I’m assuming that someone with a greater level of access than me would be able to look into it, identify the differences between the posts and correct them. I hope so, because I’m at my wit’s end.



    Were the correct posts published on your blog by a different Author than the incorrect posts?


    No, they were all published by me. No one else has any permissions to publish anything on my blog. I have always had the same Twitter account and blog details, and in fact, these were posted before I opened my Twitter account, which is why I looked at them to eliminate another variable.



    Sorry for the trouble!

    I’m going to pass this up the food chain and get some more eyes on it. Please hang in there.


    I’m hanging. Any idea when I’m likely to hear something?



    We did identify the problem and are currently working on a fix.



    This should be all fixed up now, and you should notice an improvement with future posts, or whenever Twitter clears their cache.

    Sorry for the trouble!

The topic ‘Publicising new blogs with Twitter’ is closed to new replies.