Publicize connection to Twitter

  • Author
    Posts
  • #1020238

    margatesands
    Member

    My blog has become disconnected from Twitter but publicize settings insist it is still connected. Clicking on disconnect from Twitter does not disconnect as setting returns to connected.
    Blog url: http://margatesands.wordpress.com/

    The blog I need help with is margatesands.wordpress.com.

    #1020329

    ibsimpact
    Member

    Same problem, I think. My Twitter widget seems to register my retweets automatically when I tweet from the Twitter website. But my own blog posts have not shown up for a couple of weeks, either from Publicize or from the Twitter site. I prefer to tweet posts manually from the Twitter site, but in the past, they have always shown up in the feed in my WP widget soon after. My settings show that my blog is connected to Twitter.

    #1020388

    beau
    Staff

    I know this sounds silly, but can you please try clicking Disconnect a few times? Click it, wait for the page to reload, then click again — repeat a few times and see if that does it?

    #1020392

    margatesands
    Member

    I’ve already tried this and it doesn’t work. I get message saying I’ve disconnected from Twitter, but the actual setting has a green dot and says I’m still connected. The option to disconnect is still displayed. This is despite dozens of attempts.

    #1020405

    margatesands
    Member

    This is what I see on screen after attempting to disconnect from Twitter:

    #1020408

    stuwj
    Member

    I’ve got a variation on this: as of today if I Preview a post draft it gets published on Twitter when it shouldn’t. Also, today I’ve started seeing “Twitter (2)” in the Publicize dialog on a draft page – there are two Twitter feeds ticked in there when there should only be one, and one of them is greyed-out so I can’t turn the feature off!!

    Likewise, repeated attempts to disconnect the service on the Sharing page don’t work. It’s happening across all 3 of my devices and I haven’t done anything to provoke it!

    #1020409

    beau
    Staff

    @margatesands: I’ve just manually removed your connection, can you please try connecting to Twitter again?

    #1020410

    beau
    Staff

    @stuwj: the publicize-before-publishing bug should be fixed now, please see https://en.forums.wordpress.com/topic/wp-publicizing-my-drafts-to-twitter-before-i-postschedule-them?replies=14#post-1018331

    I’ll look into the other one.

    #1020412

    beau
    Staff

    @stuwj: What happens if you go to Settings > Sharing and disconnect from Twitter, then reconnect?

    #1020413

    blakecoffee
    Member

    Same problems here. Still. Two Twitter feeds showing on my Publicize settings on the draft page of all my posts, one that says Twitter: Blakecoffee and one that just says Twitter. Tried disconnecting and connecting at the Sharing page. Can’t. and now I can’t get the Twitter publicize option to do anything at all…stay checked or not checked.

    #1020414

    margatesands
    Member

    Thanks for your attention to this problem beau, but unfortunately I’m still seeing exactly the same as per the posted image. I’ve clicked on Disconnect several more times but no joy.

    #1020415

    stuwj
    Member

    Still the same: “Twitter (2)” in the Publicize dialog, and can’t disconnect from Twitter despite multiple attempts.

    Apologies for not seeing the other thread otherwise I’d have posted in there.

    #1020426

    ibsimpact
    Member

    I disconnected from Twitter and got a message “You have disconnected…” but the green “light” by the Twitter icon still said “Connected.” Logged out of blog account and logged in. Still says Connected. Now, one of my recent tweets that wasn’t showing up before does show up in the widget, but one still doesn’t.

    Before this problem, if I didn’t wish to publicize automatically on posting (which I don’t, because WP seems to count characters differently from Twitter and tweets get cut off), I would leave the Twitter box unchecked, and go to Twitter to post, then it would show up automatically. Should I still do this, or do I need to check the box in WP? I don’t want to post each tweet twice by accident.

    #1020437

    same bugs for me, still unresolved

    #1020439

    beau
    Staff

    @margatesands: what WordPress.com username are you logging in as, and which blog URL is this on? I don’t see any Publicize connections of any kind for http://margatesands.wordpress.com/

    @blakecoffee: I see you have the same Twitter account connected to 4 different blogs. Can you please disconnect it from all of them, then go back and connect it one at a time and check the Post Editor page and see when/if the Twitter (2) (or any other problem) comes back?

    @stuwj: Are you using the username “stuwj” to log into WordPress.com? I only see one connection (to a Twitter account) for that user. Also, which blog/URL are you seeing this on?

    @ibsimpact which username/blog are you posting on? I don’t see any record of any Publicize connections for your account.

    #1020442

    beau
    Staff

    Actually, I think I see what’s happened here — somehow a group of you have your Publicize connection details stored in our older system, and they haven’t been migrated over to the new one (which should have happened automatically). That leaves you stuck in a bit of a limbo position.

    I’m working on a fix for it now.

    #1020445

    ibsimpact
    Member

    I am posting on ibsimpact.wordpress.com. which is a public blog, and the only one connected to this email address and account. I have another private blog connected to a totally separate username and email. ibsimpact.wordpress.com should only be connected to Twitter at the moment. We have a FB page and widget but have not connected it to publicize automatically. Thanks for your help.

    #1020448

    stuwj
    Member

    @beau: yes, stuwj is my login and there is only one Twitter connection. I only have one public blog (thisbikerslife.wordpress.com), which is the one I’m seeing the fault on; the others are private and defunct.

    #1020450

    beau
    Staff

    Hi, can everyone on this thread who’s still having trouble disconnecting please try again now? Hopefully the fix I’ve just put in place will allow you to disconnect properly, then connect and get publishing.

    #1020469

    margatesands
    Member

    It worked! Many thanks for your efforts to sort this out!

The topic ‘Publicize connection to Twitter’ is closed to new replies.