Need help? Check out our Support site, then

Publicize: Facebook - a vicious circle of failure

  1. I am trying to get my posts "publicized" on my Facebook page. It used to work, now it doesn't seem to do so. Whenever I select FB in the publicize area of the new/edit post control panel, I get the message:

    "To enable Publicize: Facebook, you will need to authorize your account on wandering through my mind… to connect with your Facebook account.
    Click the link below to go to Facebook. You will need to log in and click allow. Facebook Page accounts must have a corresponding Profile at this time.
    Authorize connection with Facebook."

    I click the link to authorize, it seems to take, but then the next time I do a post, nothing. No FB listing. So I open up the panel, check the FB box, and the process begins again.

    What am I missing here?

    The blog I need help with is

  2. Additional information: My sharing page shows that FB sharing is enabled, but whenever I click on the 'set options' link I get a pop-up which doesn't show anything except the 'title bar' for the pop up.

  3. Please post an active link to the blog that you are referring to starting with http:// Please try the full reconnect procedure detailed at including step 3 (removing the FB app), which is probably the most important step.

  4. If that does not work for you then will you please provide us with some details so we can try to help you?

    1. How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    2. Are you using http:// or https:// see

    3.Which browser and version of it are you using?

    4. Have you tried clearing your browser cache and cookies?

    5. Is your browser version up to date? You can upgrade any browser version here.

    6. Do you have third party cookies enabled?

    7. Do you have JavaScript enabled?

    8. Do you have another browser you can try?

    9. You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.

  5. timethief, sorry, I thought that the forum automatically linked my posts to my blog.

    I did the remove FB app steps and have gone in and re-enabled FB in my WP Publicize settings. We'll see if that makes a difference (although I think I've been down this road before and things are not looking any different that before).

    1. How are you connecting to the internet and to ComCast cable.

    2. Are you using http:// or https://? HTTP://

    3.Which browser and version of it are you using? Yes!! :) I've tried Safari, Firefox and Opera (which WP does not like, btw).

    4. Have you tried clearing your browser cache and cookies? No, didn't do that. I'll try that if I keep having issues.

    5. Is your browser version up to date? Yes.

    6. Do you have third party cookies enabled? Yes.

    7. Do you have JavaScript enabled? Yes.

    8. Do you have another browser you can try? Not many left (I suppose I could install Chrome and try it).

    9. You can use this link to see if your Flash is up to date. My flash is up to date. I didn't think WP used flash.

  6. Dang it. Still no luck. Still stuck in the loop. Now, it looks like one of my other blogs < > won't authorize in either FB or LinkedIn. I seem to be going backward on this. :(

    Any more suggestions or thoughts?

  7. Please try following the full reconnect procedure detailed at including the crucial app deleting step.

  8. macmanx, been there, done that. :(

  9. Are you trying to share to a Page-only Facebook account, or is this a full account with a profile page and a wall?

  10. Regular FB account: profile and wall.

  11. What browser (and version of) are you using for this?

  12. I've tried Safari 5.1.1 and FF 7.01.

  13. And both browsers definitely exhibit the same cycle of failure?

    Are you able to manually share links to your Facebook page? If not, do you see any error messages?

  14. macmanx, yes authorization fails in both browsers. If by manually share a link you mean clicking on the "share" button at the bottom of a post, mostly yes. I had a few errors sharing to LinkedIn but not always. FB no problem.

  15. Do you remember the error that you saw when attempting to share to LinkedIn?

  16. No, I don't recall exactly. I do recall that when I tried to authorize LinkedIn I kept getting an error message about an invalid token.

  17. Alright, there are two different places where you can initiate the connection:

    Settings -> Sharing in your Dashboard


    Do both exhibit the same problem?

  18. macmanx, The global dashboard ( ) shows they are already authorized, both on FB and LinkedIn. Hmmm. Give me a day or two do test it (I'm kinda swamped at the moment) and I'll get back to you and let you know what the status is.


  19. Oh, I neglected to mention that the FB options link still gives me nothing...

  20. I'm having the same exact issue. I authorize my connection to FB but nothing posts or connects. That didn't used to be the case. Very frustrating!

  21. Nope. Still not posting to Facebook, still says I still need to authorize it, still won't connect even though everything say's it is. Except that it isn't.

  22. I installed Chrome and went through the process again. It may have gone this time. Still not sure yet. But at least with Chrome, when I click on the link for the Facebook Options in my sharing panel of the WP controls, I get a full dialogue box, not just the title bar.

  23. @ldmartin1959 and ldmartin1959

    I'm so sorry this is not working for you. Would you like to try an alternate method? You can use Networked Blogs or RSS Grafitti for posting to Facebook walls if you prefer.

    RSS Graffiti periodically checks the RSS/Atom feeds that you specify and posts any new entries it finds to the Facebook Walls that you specify.

    You can get any feed written on any wall (Facebook Profiles, Fan Pages, Groups, Events and Application Profile Pages). In fact, multiple feeds to multiple walls. You choose the combination.

  24. timethief, we posted at the same time. As you can see, I think I have gotten things to work. I am suspecting that there is something about the Facebook Configuration settings dialogue box that is incompatible with some browsers/configurations. Safari's popup blocker isn't very flexible and perhaps that was causing the problems there (although why I could see the title bar to the pop-up but not the contents is perplexing) but Firefox should have at least given notification of a blocked pop-up. Or perhaps it is getting caught in an ad-blocker setting somewhere because of the way it is coded. Don't know. But it is definitely an issue that needs to be looked at since it is apparent from other posts from the past (with solutions provided) that I am not the only one to whom this has happened.

    Well, I'm glad I got it resolved, even if it did mean I had to install Chrome.

  25. I'm experiencing similar problems. Everything was fine until a week or so ago. Now the Facebook connector doesn't work. At that time I rebuilt my netbook and changed my default browser to Chrome.

    Deleting and reconnecting appeared to work. But I still got the "To enable Publicize: Facebook, you will need to authorize your ..." message. However, clicking on the authorise link in Firefox (no cookies, no extensions) resolved the problem.

    I'm running a few Apps and extensions with Chrome, e.g. Tweetdeck, Adblock, Sync.

Topic Closed

This topic has been closed to new replies.

About this Topic