Need help? Check out our Support site, then

Publicize not working?

  1. The publicize option doesn't seem to work. I have connected twitter, linkd in, tumblr and facebook. after it didn't work, i disconnected and reconnected and still didn't work?

    The blog I need help with is

  2. Hello Apolloliquor,

    Publicize has not worked for the last two days for Google+ on my blog either, and I even double checked my settings and I tried to manually check and update the Publicize Setting from the Visual Editor; but it still did not work.

    Publicize was working before, but then it magically stopped working.

    I think that this is a bug and it may/might be connected to the major updates being done around WordPress.

    Here are my last two posts that did not Publicize to Google+:

    Here is my Google+ Profile:

    Thank you,
    -John Jr

  3. I'm sorry to hear your Publicize option isn't working.

    I'll need more details so I can try to troubleshoot this further for you. If you can walk me through how you are creating your posts, I might be able to figure out what's going on, and report the issue if it looks like something's broken.

    Are either of you scheduling your posts that aren't going out via Publicize, or are you publishing them immediately?

    How are you creating the posts: are you writing them in the post editor or from one of the quick post (drop down) options, from the home page, via a mobile browser or the mobile WordPress app, or via post by email?

    Do you save the posts as a draft first, or publish/schedule immediately?

    If you are using a desktop/laptop to create the posts, which browser (and version) are you using?

  4. Hello Jackiedana,

    Publicize stopped working on my posts on 3-26-2014, 3-27-2014, 3-3-28-2014, but then it started back working; but when I tried to go back to manually Publicize the first of those posts it still would not Publicize for that post, and so I gave up since at least it is working for my newer posts again.

    Here are the three posts that failed to Publicize:

    My posts since then have been Publicizing to Google+ normally again.

    I publish my posts immediately most of the time, and all of those were set to publish immediately.

    I make my posts from the Visual Editor in the Dashboard under Posts | Add New.

    Sometimes I save as a draft if I am taking too long to post them or if the weather is bad, but I can not remember if I saved any of them as a draft or not.

    I use a desktop with Ubuntu 12.04.4 LTS and Windows 7 with Firefox 28.

    Thank you,
    -John Jr

  5. Thanks @johnjronline. Are you just publishing to Google+, not Facebook/Twitter/etc.? Please keep an eye on this and let me know if things change. I've seen a few threads recently that suggest Publicize sometimes isn't firing on scheduled posts, but I think that may be resolved.

    @apolloliquor please let me know if you're still having issues with Publicize and if so, if you can provide more details as well.

  6. You are welcome Jackiedana,

    Just Google+, I do not have any other social networking accounts, and I only have that one because Google seems to be trying to get everyone to have one. ;)

    So I guess that I will have to manually post those three posts directly using Google+?

    Thank you,
    -John Jr

  7. Yes, you will need to manually post these three to Google+.

  8. Okay, thank you Jackiedana. :)

    -John Jr

  9. This is the first time I have used scheduling posts as an option and I am having trouble with it! Also, scheduling posts is kind of messed up with the android app!

  10. @johnjronline I assume these were published immediately?

  11. @Jackiedana


  12. Heya johnjronline, I reported the issue to our developers for you. Looks like it's happening to other users as well but we haven't pinpointed a cause.

    If you can hold off on pushing those posts out to Google+ temporarily, that may be helpful. I'll let you know if I get any updates or need any other information from you. Thanks for your help!

  13. Hello Jackiedana,

    After looking at my Google+ Profile I see that there are more posts that did not Publicize, thank you for reporting this issue/problem to the Developers, and you are welcome. :)

    Have a nice day,
    -John Jr

  14. I've also had problems with Publicize---with immediate publishing not Scheduled---but only with G+---Twitter and LinkedIn are working fine...

    My blog is

  15. Thanks for letting me know. I'm keeping an eye on this issue for all of you and will let you know if I learn anything more.

  16. I'm also having this issue, and I've tried everything. Right now I'm manually posting to Google+, but it's not ideal.

  17. hi5productions

    There were Jetpack and WP updates recently and I have done them both and attempting to use publicize - has not worked for at least 2 days. :(
    The blog is Last post from the blog was Apr8.

  18. We are aware of the issues with Google+, which is apparently widespread across users, and continue to investigate why many posts aren't being pushed out to that platform. In the short run, you may need to post your updates manually while the developers look into this further.

  19. wow.. i've lost a few hairs over this going crazy thinking I was doing something wrong setting this up the first time last night.. I tend to think the issue may be on google's side.. I spent 4 hours last night trying to get this to work and I finally gave up.. I woke up in the morning and tried to publicize an article w/o changing anything and it magically worked.. seems to me either google takes time for the trust to propagate or they're refreshing something from time to time that wipes the trust out.. this option broke again out of nowhere today so I lost another 2 hours troubleshooting and it's still broken.. very frustrating but glad I found this thread which I'm going to follow..

  20. @Byyear

    Hello Byyear, welcome to the club ;) , I am also wondering if this could also be a problem on Google's side as well.

    Either way I am curious, this is an interesting mystery that WordPress is trying to solve, and so we will wait until WordPress and/or Google solves it. ;)

    -John Jr

  21. @johnr
    I completely agree.. we'll wait and see what they find..

    an fyi for the developers - I logged in this morning to see if i could magically publicize without making any changes and it worked.. so perhaps the issue has something to do with the scheduling - so far I have always tried to publish immediately but maybe the code has a glitch and does a date/time comparison when it should not .. i'll run some tests tonite if the problem occurs again..

    here are the characteristics of my problem so far:
    1. i could not get publicize 'immediately' to work on Wednesday eve no matter what I did
    2. i checked Thurdsay morning and i was magically able to publicize without making any changes to my settings
    3. i could not publicize anything not matter what I did on Thurdsay eve
    4. I again checked on Friday morning and I was able to magically publicize

    *this is starting to appear to be a 'time of the day issue' .. i will play with the scheduled date/time next time i see this problem and i will see if that contributes to the publish 'immediately' feature

  22. brightfirewoman

    Not working for me either. I have connected my facebook page, my google+ page, my Linked In and my twitter and have done two posts and nothing yet has been published to any of them.

  23. We are still digging into this. It looks like we're hitting limits with Google+ and we're still trying to sort out where this limit is being triggered and how to prevent it in the future. For right now my best suggestion is to manually post your updates on Google+ and hang in there as we continue to work through this issue.

  24. Thank you for the update Jackiedana. ;)

    -John Jr

  25. Okay, I'm also having this problem but only with Google+. Facebook and LinkedIn appear to be working fine. I posted a question on this topic to the forum and was told to subscribe here. Thank you @jackiedana :) I've spent hours on this trying to figure it out on my end.

  26. Hello, I too am having issues with Google+ Publicize, the featured images are not posting at all, just an empty box which looks bad, and the posts sometimes don't post at all. The website is and the google+ page is

  27. I'm having the same issue but with Facebook, Twitter, and Google+. I was able to publish immediately before. The most I changed was my theme to one called TwentyFourteen, but I wouldn't think that would do it.

    I have to go to my blog and share in manually that way. Publicize (via Jetpack) will not immediately publish for me.

  28. @shazam27, you're using Jetpack so your issues are a bit different. It looks like Facebook is reporting a 500 error when trying to pull the data from your site. You may wish to check your server logs for the source of the error, or check with your hosting provider. It could also be an issue on Facebook's end. Due to the nature of this error, it isn't your Jetpack connection that's misbehaving, so it's not something we can resolve for you.

    As general troubleshooting tips, you could try uninstalling and deleting Jetpack, and then reinstall/reconnect it, and make sure you are running the most current versions both for Jetpack and WordPress as well. I don't think this would be the source of the issue, but it's easy enough to do that it's worth a shot. You might also temporarily disable other plugins to see if that resolves things, which would then point to a plugin conflict.

  29. @jackiedana, thanks for the info. I'm hosting the site myself, and it was responsive and functional at the time. However, it is acting up quite a lot since I patched the openssl vulnerability yesterday. So I have another issue to deal with, which is just adding to this.

    I did notice that one of my posts eventually showed up on Facebook. So maybe it is an issue on my end.

    I'll try uninstall jetpack and reconnecting and see what that does.


Topic Closed

This topic has been closed to new replies.

About this Topic