Need help? Check out our Support site, then

Publicize not working?

  1. The issue with Google+ posts should be resolved now for those using Publicize on a blog. You may need to reconnect your blog to Google+ via your sharing setting.

    Please let me know if you now have an active connection to Google+ (it will show up in your post editor just above your publish button if it's active) and you're still running into issues with your posts not showing up on Google+.

  2. My blogs have stopped getting published at all. I use Chrome browser and now I can't even get into wordpress the browser says I have lost a secure connection and I have not changed that. Any ideas? I have dumped my cookies and browser history. It is frustrating because it worked for the first 12 or 15 posts I did and then whamo. Before I was locked out I could get to the new post from the top of the page on right and then it asked me if it was to be text, video ect. I chose text. When I would type in heading or content in big box the save draft button would automatically come on and I would get the spinning wheel but it would never stop. Then I emptied my cookies and could not get back in. All my other sites work fine but yours.

  3. @sprtnut77 it sounds like your issue is unrelated to the one being discussed in this thread. Please start a new thread and add the tag 'modlook' so we can take a look at it for you.

    Please also include the site you cannot access.

  4. Hello Jackiedana,

    My post from today properly publicized to Google+, so that is good, but I will try to remember to keep checking it each day after each post for the next few days to make sure that it is still working.

    Thank you for the update,
    -John Jr

  5. Thanks. Please let me know if things change.

  6. You are welcome Jackiedana, okay, I will let you know if this changes.

    -John Jr

  7. Hi My updates when logged on my PC did not publizise directly but did work when i updated the blog from my mobile phone.
    I've tried to unconnect twitter, Facebook from the blog and reconnected them again but no joy.


  8. @sweeneyb, I don't see any errors with your Publicize connections. Were you posting from the main page ( ) or from your Dashboard post editor window?

    I can see you disconnected and reconnected a month ago. Have you not been able to successfully publish any posts to your social media since that time?

    If you would let me know the next time you publish a post, and could hold off on manually posting to your other connections to give me time to check them out, that would be very helpful.

  9. organizedbabble

    I have Facebook and Twitter connected, as well as Google+, and Publicize is not publishing my post for me. I tried several times but no luck. The post that is not working is

  10. I was having a similar problem. I wasn't able to connect to facebook or twitter. I removed jetpack, added it back in, then removed my connection to I have a self hosted site. Once I remade the connection to, everything is working as it should.

  11. Hi @Jackiedana it seems to be okay now when I publish from either the WordPress site online or my Android version.
    We'll see how goes.


  12. @organizedbabble it looks like everything is okay, as your site doesn't seem to have any errors when connecting to your social media sites, and I can see your post on Twitter. Did you manually post your link there?

    If this happens again, please try disconnecting/reconnecting your accounts, and then let me know as soon as possible, without manually posting to your accounts, so I can take a look. Also, please let me know how you composed and published your post - did you do so in your Dashboard editor, from, on mobile, etc. and did you publish automatically or did you schedule the post?

  13. Hi Jackie,
    It's happened again.
    I posted at the weekend from my WordPress on Android and ALL went well and publicize worked a treat. I've published again in the last 30 mins from the desktop version and Publicize has not worked on same.
    Can you help. Thanks

  14. @sweeneyb I can confirm that your most recent post ( ) did not go out to your social media sites.

    I checked, and I don't see any Publicize errors for that post, and it looks like that post does not have any Publicize connections active (there aren't any showing up in the Publish box). Did you modify those yourself by any chance? Was this post published immediately or did you schedule it to post later?

  15. hi Jackie,
    I hadn't modified them directly but had noticed that when I went in to the Edit following posting, they were all unchecked.
    In the android version I think they publicised automatically.
    If I amend the desktop settings will they be saved for the future.
    Can I republish the post and check all the publicize boxes so the post will publish?

  16. It looks like you redid the post and all of the Publicize connections are listed. Did everything work this time around?

    Did you happen to do anything differently when you reposted it?

  17. Same problem. The publicize function is simply not working for me (
    My posts do not publicize to my google+ page I have set up. At all. wasted so many hours trying to trick it into working.
    Last week after I connected via hootsuite it started working, so I was getting double posts of the same thing: one from wordpress, the other through hootsuite. I deleted the google+ publicize connection and went with hootsuite not wanting to bother.
    But I sincerely prefer the native solution if it can be gotten to work. Please. I have reconnected my google+ page to no avail. Please help

  18. We have had periodic reports of Google+ failing. I'll pass this information along to our developers.

  19. @jackiedana
    Hope this post finds you well.
    I have been following this tread for some time now. I have similar problem of Publicize not working for Google+ and LindedIn. These are only once that i am using Publicize for.
    I have spent many hours trying to get it going to no avail. Also trying to reconnect with no hope. Please help. My blog is:

  20. At this time I don't have any updates on Google+, so you will need to publish your posts manually there until our developers are able to resolve this issue. If you remove your connection to Google+ your other connections should work again.

  21. @jackiedana
    Thanks for your quick reply but unfortunately the other connection is unable to publish as well. I have disconnected google+ and only connection left is LinkedIn and it is not publishing.

  22. Hi @valentinoperic. I'm sorry to hear your LinkedIn connection isn't working. Did it work at one time and stop, or have you never been able to publish to LinkedIn via Publicize?

    Since I can't see your profile, this may be a bit hard to troubleshoot. Could you perhaps take a screenshot of what you see on your pulse/activities page, which you should be able to get to by going to[yourusername]/

    How to take a screenshot:

    You can then upload that to your blog's media library so I can take a look.

  23. Hi @jackiedana. I really appreciate you taking time to help me out.
    I had LinkedIn account several months ago and it would update only on couple of occasions with publicize.

    I really got fed up at the time so I deleted my LinkedIn account completely only to open this current account last week.

    But nothing has changed. I'm still unable to upload any updates with publicize.
    What I have noticed is after clicking the box next to LinkedIn and updating the blog post, after page refreshes tick that I placed earlier is not there and Linked in not updated.
    I have uploaded screenshot.
    Once again thanks.

  24. Hi @valentinoperic. Based on that screenshot, it looks like there's an issue with LinkedIn or your ability to view your posts there. The screenshot looks like an empty profile, as there is no image of you, and the error message has no username.

    You might contact LinkedIn support for more help with this:

  25. Hi @jackiedana. Thank you very much for all your help.

  26. You're welcome!

  27. Hi Jackiedana,

    I've got a similar problem. A new post, created initially using the quick post thing, and then completed in the full view, with several draft saves in between, isn't auto-publicizing on twitter. It has worked before, so I wonder if this is a quirk regarding how I created the post in the first place?

    The post is here -

    Thanks, Tom

  28. I am having this problem as well. I have been posting both immediately and scheduled. And I ALWAYS post on the website via a desktop or laptop. I too changed my theme recently and I went through and disconnected and reconnected. The sites my blog isn't publicizing to is Facebook, Twitter, Google+, Tumblr, and Path.

    The blog is and its not working on the following posts

    Just to list a few. There are several more.

    Thank you so much!

  29. @tssharp it looks like your Twitter connection is working, but the box to Publicize the Netflix post was not checked, meaning it would not be sent out.

    It's possible that if you used the new post editor and then switched to the Dashboard editor that there was a glitch, so please keep an eye on this in the future and make sure the box is checked when you publish a post. If you keep running into this issue, please let me know.

    @jessdanow we have had periodic issues with Google+ connections. If you remove that connection, your posts should be sent out to the other sites as normal. If you try this, please let me know if it helps.

  30. I too am having a problem with Publicize. I schedule all of my posts and they have always posted to FB, Twitter, LinkedIn, etc.

    Now they aren't posting to those sites so when I go in to edit (since they aren't connected) I check all the boxes under 'Sharing' and they look like they are connected. When I go back into the post, all the boxes are unchecked and nothing is shared.

    Blog is

    Any help is appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic