Publish Button isn't working for me

  • Author
  • #1058359


    When I try to publish a post, I can save it as a draft and preview it but when I click the publish button nothing happens. I can work around this by going to the ‘all posts’ page, quick edit and changing the status of a draft post to published but this is irritating – that button should work. any thoughts?


    Blog url:

    The blog I need help with is



    There’s an issue with creating posts on the front page of and with editing posts created there that will not be fixed until the next upgrade. Do not create posts here >!/post/

    Instead I recommend that you ONLY create posts here > Dashboard > Posts > All Posts > Add New

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are, please do these four things:

    1. Try clearing your browser’s cache

    2. Make sure that you have third-party cookies enabled

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If you are not successful let us know which browser (and version of it) you’re using and post any error reports you get.



    I’m creating my posts from the dashboard – running safari 6.0.1 – same issue on most current version of chrome. Tried clearing caches and enabling cookies with no success.

    But, Switching to HTTPS fixed it for me. Thanks for the suggestion Timethief!

    Much obliged – mark this one solved, at least for me.



    Hooray! I’m so glad you are up and running by using the secure https:// log-in. Happy blogging.

The topic ‘Publish Button isn't working for me’ is closed to new replies.