Publish button missing!!!

  • Author
  • #673975


    I just finished writing a post and can not locate my Publish, Preview, or Save Draft button.

    I’ve noticed, lately, that often when I sign on one or two things seem different. I haven’t been able to add categories or tags even though I just (re-selected them from screen options. I never un-selected them in the first place. Not sure what is going on.

    The blog I need help with is



    Hi. Have you tried any of the tips here?

    If that doesn’t help, we need the URL of your blog, starting with http:// please.


    Hi I’ve had the same problem today and also unable to open screen options, refreshed my browser and used different browsers still have been unable to publish, B



    It is helpful to know exactly which different browsers and versions of them you tried. Without that information we are not in a position to attempt to duplicate your problem and resolve it. Please provide that information.

    You can use this link to see if your Flash is up to date.
    If it’s not up to date then this link is where to download and install the latest version of Flash.

    The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.
    How are you connecting to the internet and to


    Hiya timethief, I’ve used safari, firefox and explorer, I’m just in my admin again and note that publish has returned but I can’t publish and still can’t open my screen options, hope this helps + Ive used 3 different network ISP’s but I don’t know any of the information requested.

    I did publish around lunch time today and then everything seemed to go weird :-(



    Please try clearing your browser’s cookies and cache:


    Hi macmanx, yes done all the cookie, cache clearing several times, have rebooted and logged back in and still unable to publish.


    Hi macmanx, just realised, the publish and screen option issue is just in my posts section, my two pages still have the update, publish and screen option functions operating, hope this throws some better light on my issue :-)



    Thanks to all for your input. I was away from my computer yesterday and will be again for most of today.

    I’m using Firefox. I have tried to update to the latest version but my OS 10.4.11 won’t allow it. :( I hope this doesn’t been my publishing days are over until I get a new computer?!

    I cleared my cookies and cache to no avail. Just as raphaelslegacy stated, I am able to publish in pages but not in posts.

    I connect to the internet by DSL.

    The URL to my blog is:

    Thanks so much to all for your assistance. :)



    raphaelslegacy, check your Screen Options tab in the top-right of your post, and try checking each box.

    corkie1, which version of Firefox are you using?


    Hi macmanx, tried all that before I started looking for answers, no worries I’m going to park this now, cheers anyway.



    Hi there,

    I’m using Firefox version 3.6.13



    Opera 11.11 is the most modern browser to support OS X 10.4.

    Would you please install it and see if that makes a good difference?



    I just downloaded Opera 11.11, logged out of WordPress, restarted my computer and tried again. Unfortunately, I’m still unable to locate any of those missing buttons.

    I should also mention that I was also having trouble inserting video into my post the other day.

    Thank you.



    Are you running any third-party firewall or security software? If so, would you please try temporarily disabling those?

    If that doesn’t solve the problem, please try resetting your modem and/or router.



    I’ll reset my modem as soon as I’m able to. I am still unable to publish, preview, update, insert video, etc on the New Post page but I was able to publish my already written post by going into the Quick Post area, changing “draft” to “published” and then updating. It is a round about way of getting things done but for the time being that is what I’ll do.

    Hopefully your troubleshooting suggestions will rectify the problems.



    My missing buttons have miraculously returned!!! :) However I am still unable to insert video clips into my posts.



    Where are you trying to insert the videos from?



    I was trying to insert a video clip from the Yoga Journal website. This one:

    (Deep breathes…)

    I used to be able to add a clip easily by going to “Add Video” and posting the url into the proper field. This no longer works. I was able to post from YouTube copying the embedded code into HTML but this didn’t work with the YJ clip. I seriously prefer the other method since it was so much easier.

    Also, those buttons I was missing that miraculous reappeared yesterday are gone again.

    Argh… And thanks! I am getting frustrated but do appreciate all of your help!!! :)



    For security purposes, we can only support embedding videos from the servies listed at

The topic ‘Publish button missing!!!’ is closed to new replies.