Publish on facebook with unique or blog picture instead of the "W"

  • Author
    Posts
  • #934961

    marcoboehme
    Member

    Hi,

    when i share a blogpost from e at facebook, there is only this “w” in the content below my post. Is it possible to show there my picture? For a normal wordpress installation i use “unique image” plugin to solve that, but for the wordpress.com platform it doesn’t work… :-(

    The blog I need help with is marcoboehme.wordpress.de.

    #935057

    timethief
    Member

    We have no control over which images Facebook chooses to display and we have no control over how long it takes for the image caches at Facebook to be flushed. What follows may ot may not be where they are at today as they make change frequently.
    Only the first five images uploaded to a post (direct inclusion/gallery/slideshow) will be sent to Facebook. The images size has to be at least 200 x 200 pixels.
    To select which image will be used for things like Facebook Publicize, you can use a theme that supports featured images. If a featured image isn’t set or your theme doesn’t use featured images, then the code tries to pick the first image in the post or page. If no image is found, then the blavatar is used.

    The solution to your issue may be found if you upload a blavatar image.
    http://en.support.wordpress.com/avatars/gravatars/
    http://en.support.wordpress.com/avatars/blavatars/

    #935062

    marcoboehme
    Member

    Hi,

    thanks for your fast help. Unfortunatelly it doesn’t work… i have already chosen my gravatar, but when i click on “share” only that “W” appears…

    http://marcoboehme.wordpress.com/2012/06/29/kulturwandel-in-unternehmen/

    Any idea?

    #935065

    timethief
    Member

    If you did upload a blavatar then do know it will not display immediately. It usually takes a couple of days to display. Aside from what I posted above, I have no other ideas to offer.

    #935072

    hakanertr
    Member

    I don’t see any pictures in your posts. So, facebook picks to default “W”ordpress image for sharing. I think, you can’t change it. Just add featured images in your post like timethief’s said.

    #935074

    hnsaifi
    Member

    The solution to your issue may be found if you upload a blavatar image.http://en.support.wordpress.com/avatars/blavatars/

    Change your blavatar not gravatar.When I changed it on my test blog it appeared in seconds. That will sort it out. BTW when you share something on facebook there’s an option to choose which image/s to be shown. But the wordpress icon remains there if you have not chosen a blavatar.

    #935212

    marcoboehme
    Member

    Thanks!

The topic ‘Publish on facebook with unique or blog picture instead of the "W"’ is closed to new replies.