Need help? Check out our Support site, then

Publishing only creates a draft - with much of the post gone!

  1. On my blog - I just wrote a very lengthy post, hit "publish" and it only saved to the drafts category. When I clicked on it, I discovered that less than half of it was actually there! I tried to repost a new one under the same name and it happened all over again! What happened!!!!!!

  2. Having the same problem here. This is very irritating!

  3. bongocelebrity

    I am also having same difficulties when trying to post.

  4. What browser and operating system are you using?

  5. I doubt if browser and operating system has anything to do with it because I've put up many posts since July and everything has been fine until just a little while ago. Actually I put up two posts very close in time to each other. One showed up and I've yet to be able to get the other one to post or even to save in the drafts ... it's just vanishing. I've also checked the timestamp and it is fine.

  6. I'm sorry to say that the long and short of this is that what you lost cannot be recovered. Please consider using a free off-line blog editor. It will save you all this worry and frustration because for every post you publish via the off-line blog editor you will have a backup copy on your own computer.

  7. I have copies of my posts, the big problem here is the fact that things are not publishing to the site ... for me and apparently several other people as well.

  8. Volunteers cannot help you. We do not have bacckend access to blogs, only staff do. Best wishes :)

  9. i just received the following from Mark at WordPress:

    I'm really sorry but we do have a problem right now which is causing the issues
    you are seeing.
    It is being worked on as I type this and everything will be back to normal
    really soon.



  10. bongocelebrity

    Yeah,everything is back to normal now.Thanks

  11. @onemom
    Thanks so much for posting Mark's response. he has now put up a sticky post at the head of the forum

    It's good to hear that your problem has been resolved. Happy blogging. :)

  12. This has happened to me, too, several times recently, and I agree it's a worry.

    *##* It would be really handy to have any "undo" button in's editor, just like you do in Word or Excel.

    Because it's going to happen some time - I agree that it's better to write offline if poss, but the problems I had were actually in editing mode. I had posted recently and then done a bunch of edits to space the paragraphs better on the page. And then 'whump' - suddenly half the whole ruddy post was gone. Yikes !

    How do you get it back, when that happens ?

    Two routes I found that work:

    1) if it's not a brand new post, then try to retrieve the Google cache of the post. Open and then save it as a file onto your hard disk, and then open that file with Notepad to see the original code. You can then usually fish out the text section of your post from amongst all the html. If you repost that section back into the code editor, then you can use that as a back-up to recreate the old Google-indexed version of your post.

    2) if the post is very recent - like less than a day old, then a white screen in IE7 means you've lost your work for ever.

    But I've found that with luck, working with good old Firefox can save the day here - since now pressing the 'back' button takes me back through several previous versions of the post.

    Doesn't always work, but when it does ... Phew ! What a relief !

  13. It would be really handy to have any "undo" button in's editor, just like you do in Word or Excel.

    Yo! I see undo and redo icons in our visual rich text editor - Tiny MCE
    Click icon 16 for the advanced toolbar and now look at icon K

  14. Until the problem gets sorted out, before hitting save, or save and continue editing, highlight all the text in the post or page to the clipboard (by mouse or using ctrl-a or command-a (mac)) and copy it to the clipboard (ctrl-c or command-c (mac)). If it disappears when you save, you can paste it back in and continue. I know it's a pain, but it will save you a lot of work.

    Also, I suggest contacting support at which is open for about another hour and a half I think. Include your operating system and the browser(s) you are using or have tried.

  15. Thanks TT, that's new to me and I'll check those out.

    But will those buttons work when the problem happens whilst saving - as it often has done recently ?

    Come to think of it - 'undo' won't help you in Word or Excel at that point either.

    The old Google cache or the friendly 'back' button in Firefox (see above) might just be the only saviours then, after all.

  16. @energetic
    IMHO the sensible approach is to put your time and effort out only once when creating a post. This can be achieved by using a free off-line blog editor. If and when you do use one all the fuss and frustration described in this thread and others simply evaporate into thin air. Moreover, you also have a backup copy of every post you publish through an off-line blog editor on your own computer.

  17. @energetic
    I've been using one [offline editor ] for about 8 months and really like it. As TT says, there is no frustration, you can just blog.

  18. Thanks again, TT and TSP. Problem is, it's always easier just to go into, and start editing away if you spot something you want to change, more or less on the fly.

    That approach has had its dangers and frustrations, recently. So, offline editing - yep, I (and everyone) really should get to it.

  19. @energetic
    Welcome aboard. Using an off-line blog editor is easy. It eliminates all frustration as described above. ;)

  20. Has anyone used WinJournal as the offline editor? I am having difficulties with the images, it asks me where they are going to be hosted.. I don't want to go to the WP site to upload them!!! That isone of the points.

    I am also having problems because it doe snot recognize the secondaty blog I have, it always default to the primary blog. HELPPP!!!!!!!

  21. I have problems! I published my posts, but it doesnt appear on my blog. When I go back and check on the editor, the 'Publish' button is missing!


  22. I have problems! I published my posts, but it doesnt appear on my blog. When I go back and check on the editor, the 'Publish' button is missing!


Topic Closed

This topic has been closed to new replies.

About this Topic