Reader: scroll not working / Notifications 2…

  • Author
    Posts
  • #1290874

    pellymade
    Member

    Hi,
    Infinite scroll isn’t working, I only see 5-6 posts. I use mozilla firefox (updated version) and I cleared cache and cookies with no result.

    The notifications star is stuck and flashes showing the same “like” although I’ve clicked on it.

    Both problems are happening all the time lately…

    The blog I need help with is pellymade.wordpress.com.

    #1291005

    timethief
    Member

    It’s so weird that you experience these issues. I use Firefox 21. I am using a PC and a high speed DSL line that dedicated only to this computer. I’m beginning to wonder if you have connectivity issues.

    Would you please consider telling us how you are connecting to the internet and to WordPress.com, where you are located and who your ISP is?

    #1291009

    pellymade
    Member

    I am not so familliar with this… but I’ll try:
    I have a Adsl line (2mbps), I live in Athens – Greece and my ISP is OTENET.
    2mpbs is not high speed but I’ve never had problems with anyone else..

    #1291011

    timethief
    Member

    Thank you so much for posting that information. Hopefully it will be helpful for Staff who will be the ones who will assist you with sorting this conundrum out.

    Off Topic: Your images are lovely.

    #1291013

    pellymade
    Member

    I do hope they will!! I am feeling very tired with all this…

    Thanx Timethief! It’s much appreciated :)

    #1291014

    timethief
    Member

    Do understand the Staff here are excellent and they try very hard to please us. In order to comprehend what’s going wrong for you what they have to do is duplicate your computer setup and browser settings. Then they have to replicate the same errors you get so they can determine what’s going wrong and how to fix it.

    #1291019

    pellymade
    Member

    Unlike my will, I became a frequent user of the forum, but never found a solution to the old same problems I have :)
    My reader is not working properly almost since day one… My activity also. Especially the “likes” section.
    Anyway, thank you very much for answering and for giving me hope!

    #1291021

    timethief
    Member

    As we say in Canada – hang in there, please.

    #1291170

    csonnek
    Staff

    @pellymade: I looked into your problem and I’m unable to replicate it. Can you verify what version of Windows you’re running? Also, in a previous thread you mentioned using Chrome with no luck – can you verify what browsers you’ve tried?

    Have you disabled any anti-virus or anti-malware programs you might have running (like Norton or Microsoft Security Essentials) and tried to view the Reader again? Sometimes these programs will block or cripple JavaScript, which is what allows the Infinite Scroll and other Reader features to properly function. If JavaScript (or scripting in general) is being blocked/disabled, the Reader won’t work properly.

    There are also settings in your browser that can block scripting. Here’s a reference from Mozilla where you can find and check your settings:
    https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages

    Can you check your program settings (disabling them if necessary) and try to view your Reader again and let me know if that makes any difference?

    Thank you.

    #1291178

    pellymade
    Member

    Hi csonnek,
    I am using XP and have tried Internet Explorer 8 (backup browser), Chrome and Firefox (my main browser). My blog in IE is a total mess… I’ve notified WP about it many times in the past with no result. You could see the latest thread on this:
    https://en.forums.wordpress.com/topic/huge-appearance-problems-in-internet-explorer-8?replies=22#post-1165162

    Nobody ever told me to disable them. I have Symantec antivirus but no malware program is installed. I tried disabling it and I got the same malfunctions. No infinite scroll and not all posts are shown in My Activity. In fact My Activity never worked properly since day one. I never had an issue with the previous feature (“My Likes”).

    And I find it strange, but I never had a problem with infinite scroll in the “topics” area also. If it was the antivirus program that caused the java not to function properly, wouldn’t that affect the “topics” feature also?

    Thank you

    #1291179

    pellymade
    Member

    Oh, I checked the link you provided and my Java settings are correct.

    #1291197

    csonnek
    Staff

    Thanks for verifying your settings.

    When you say “tried disabling it”, were you able to successfully disable the antivirus program? From what I’ve researched, people have reported difficulty disabling Symantec antivirus programs so I wanted to make sure.

    I understand your frustrations, but please realize we’ve been unable to replicate any of the issues you’ve been experiencing these past months even using the same OS and browser configuration. The only variable that we don’t have is that you have Symantec installed so we need to see if that’s having an effect.

    Do you have access to a computer that does not have this program installed that you can try to view the Reader? Also, can you restart your computer in safe mode and try to access the Reader?

    To start your computer in safe mode:

    1. Click Start and then click Shut Down.
    2. In the drop-down list of the Shut Down Windows dialog box, click Restart, and then click OK.
    3. As your computer restarts but before Windows launches, press F8.
    4. Use the arrow keys to highlight “safe mode with networking”, and then press ENTER.

    Please note your screen will be at a fixed 800×600 resolution with minimal color support, meaning colors that you’re used to won’t display correctly in safe mode.

    Once you’ve launched a browser and tested things, you can restart your computer as normal to get out of safe mode.

    Thanks for your assistance in doing these tests and let me know if you have any questions.

    #1291205

    pellymade
    Member

    Hi,
    “tried disabling it”:
    I right clicked the Symantec shortcut on my taskbar and unchecked “enable auto-protect”. After that I opened Firefox and went to My Activity.
    I noticed that when I disabled it, a red circle appeared on the shortcut. But after a little while, the red circle had gone. I then repeated the whole ritual at least 4-5 times. I observed that when I scrolled down my likes in My Activity, the circle was there, but as I mentionned, without me enabling it again, the circle disappeared.

    “Do you have access to a computer that does not have this program installed?”
    I’ve already done it. I have the exact same problems without Symantec installed. In fact the pc I’ve tested the Reader, doesn’t have ANY antivirus program installed. Again the OS is XP and browser Firefox (and IE as backup).

    As for “safe mode”, I’ll do it and let you know of the outcome.

    Could you please give a clue on why I’ve never had that sort of problems in the topics area?

    Thank you

    #1291206

    csonnek
    Staff

    Thanks again for verifying what you’ve already tried.

    Could you please give a clue on why I’ve never had that sort of problems in the topics area?

    I’m as stumped as you are! I do appreciate your patience while we narrow down what might be causing these problems.

    I’ll wait to hear back from you regarding the safe mode test. Thanks!

    #1291220

    pellymade
    Member

    Hi,
    I did the safe mode test twice.
    The first time,
    the Reader and My Activity > Likes looked ok. Infinite scroll was working and for the first time after a very long time I managed to see all the posts that I’ve liked in the right order! A miracle!
    In My Activity > All, infinite scroll worked ok, but after 5-6 posts I’ve liked, I saw the usual OLD posts I’ve commented on (stucked in a group, even though I’ve liked other posts in between) and after that instead of seing the rest of my likes in chronological order, there was the usual time leap.
    I restarted, went to normal “mode” and to the Reader and My Activity to see. It was the same. Infinite scroll ok, My Activity > Likes, ok (!!), My Activity > All, the same as in safe mode.
    The second time,
    The infinite scroll worked ok in Reader. BUT, in My Activity > Likes, NO… Plus, I had the usual mutilated and messed up view of the posts I’ve liked. I’ve taken a screen shot, but I can only show you that there is no infinite scroll
    http://pellymade.files.wordpress.com/2013/06/safe-mode_scroll-likes.jpg
    So that sends me back to zero I guess…
    Please consider that the Reader in general and My Activity > Likes in particular are very important and favorite features for me.

    Thank you for your efforts

    #1291226

    csonnek
    Staff

    Thanks for the information.

    I’m going to check with one of our developers to see if they can grasp any clues from your results and I will get back to you once I have more information.

    Thanks again for your help!

    #1291229

    csonnek
    Staff

    Hi again!

    The developer would like you to try a couple of things:

    First, can you get the HTTP headers by following the instructions for the Firefox browser here?
    http://en.support.wordpress.com/browser-issues/advanced-browser-troubleshooting/#mozilla-firefox

    Second, can you check the JavaScript console in Firebug when you’re viewing Reader and let us know if there are any errors? Here is a reference that will help:
    http://getfirebug.com/errors

    If you do have errors, taking a screenshot or copying/pasting the code in a response here would be helpful.

    Let me know if you have any questions!

    #1291232

    pellymade
    Member

    Hi…
    I really don’t have a clue on what I am doing!
    Anyway, I tried to understand what I supposed to do and here are the results:
    I didn’t have firebug installed (never heard of it actually…). After I enabled it, my pc started to make noises (on the verge of exploding…) and gradually slowed down, as I scrolled down in Reader. Whenever I right clicked > open in new tab to a post, it got even worse and almost freezed. The first time I returned to my Reader, I saw 140 errors next to the little orange bug icon… But I didn’t know what to do with them yet, so no screens… It said that there was not enough space to show all results.
    Today, I tried harder… I heard the same noises, slow down, freeze and in My Activity > Likes, infinite scroll didn’t work, but I didn’t see errors near the bug. On the contrary the error rectangle appeared (and disappeared) whenever I tried to open in new tab. That’s when things got even noiser and slower till freeze..
    Anyway I took some screens… I don’t know if they’re the right ones, but I really did my best.
    http://pellymade.files.wordpress.com/2013/06/firebug1.jpg
    http://pellymade.files.wordpress.com/2013/06/firebug2_headers1.jpg
    http://pellymade.files.wordpress.com/2013/06/firebug2_headers2.jpg
    http://pellymade.files.wordpress.com/2013/06/firebug5_console.jpg

    Please note that english is not my mother language and I am far of being a techie

    I hope something will come out after all this…

    Thanks!

    #1291233

    csonnek
    Staff

    Thank you for that information!

    Firebug is a web developer extension for Firefox, so it shouldn’t be causing your computer any distress. But, you can always disable it if you’re concerned:
    https://support.mozilla.org/en-US/kb/disable-or-remove-add-ons

    I’ve forwarded your results to the developer and I will let you know if they need you to run anything else.

    Otherwise, I’ll be back in touch once I have more information for you.

    #1291244

    csonnek
    Staff

    Hi there – I need you to run two more things for the developer.

    First, they would like you to run a traceroute. Here are the instructions for Windows XP:

    1. Click on the Start menu.
    2. Click on Run.
    3. In the “Open” text box type: cmd
    4. Click on the OK button. This will bring up the Windows command prompt.
    5. In the command prompt, type: tracert wordpress.com

    Once the traceroute is completed, you can copy text from the window with the following steps:

    1. Right-click your mouse on the command window to bring up a menu, and select “Mark” by clicking with your left mouse button.
    2. Using your arrow keys, move the cursor (the highlighted box) to the beginning of the text you wish to copy.
    3. Hold down your Shift key and move the right and down arrow keys until you have everything you wish to copy highlighted.
    4. Press the Enter key to copy the text.
    5. Return to this thread and paste the traceroute text by holding down your CTRL key and pressing V once to paste the text into the message.

    Next, enable Firebug again and check the JavaScript console again, and when you see an error like this (in red):
    http://d.pr/i/6cRx

    Click the little + sign next to that error to expand the error message and take a screenshot of that as that will give us more detail for the error.

    Let me know if you have any questions!

The topic ‘Reader: scroll not working / Notifications 2…’ is closed to new replies.